Mediaportal steals focus for IR remote events (1 Viewer)


Portal Member
April 10, 2009
Hi all,

I'm having a problem with MediaPortal and the iMon remote software. I'm using the iMon software to create profiles for MediaPortal and KMPlayer, which is the external player I'm using. Both of them work fine, the remote buttons are mapped to keyboard keys which can control both programs.

However, if MediaPortal is active (full-screen or windowed, not in tray) MediaPortal appears to be stealing remote events (key presses) away from the program that currently has the focus, such as KMPlayer. As a result, I cannot use my remote when I launch KMPlayer from MediaPortal. If I run Mediaportal windowed, and put the focus on KMPlayer, pressing the play/pause button (mapping in a iMon profile to play/pause in KMPlayer), I can clearly see the MediaPortal window flashing, as though shortly obtaining focus, and giving it away again. After this, the focus is still on KMPlayer, but MP has somehow consumed the key press event. If I press the key with which the remote button is associated (space), then KMPlayer does respond.
If I minimize MP to the system tray, everything is fine, and I can control KMPlayer with my remote.
It does not matter if I have MP launch KMPlayer, or if I start it myself.

It appears so as that the problem really lies with MP. It also steals the focus away from IExplorer, for which there is an iMon profile. Having IExplorer and KMPlayer open (without MP), does not give this focus problem: the program that is in focus reponds to the remote commands.

I've got the following extra plugins enabled: MP-TV Series, Moving Pictures, MiniDisplay, Keyboard Input (to remap the fixed backspace button of the remote to Esc). Disabling these plugins did not help.

This appears to be a similar question:

TV-Server Version: NA
MediaPortal Version: 1.0
MediaPortal Skin: Xface
Windows Version: Vista Ultimate 64 bit
CPU Type: Intel E5200
HDD: WD Green 1TB
Memory: 4GB
Motherboard: Gigabyte E7AUM-DS2H
Video Card: IGP 9400
h.264 Video Codec: CoreAVC
HTPC Case: Antec Micro Fusion 350
Remote: iMon Mini (RM100)
TV: Samsung LE37A656
TV - HTPC Connection: HDMI


Portal Member
April 10, 2009
Ah, apparently this guy had the same problem and just fixed it:

I can confirm that this solution works. In the end it wasn't MP causing the problem, but the iMon software. I think the "Use exclusive mode" tickmark sends all commands to the application that is associated with the quicklaunch button, if that application is running.

Users who are viewing this thread

Top Bottom