MediaPortal SVN-Snapshot:-03-07-2009 01-58h - Revision:21864.rar

Discussion in '[untested] MediaPortal and TV-Server 1.0 svn-build' started by MediaPortal-Bot, March 7, 2009.

  1. MediaPortal-Bot

    MediaPortal-Bot Worlds greatest bot!

    Joined:
    March 26, 2007
    Messages:
    3,715
    Likes Received:
    90
    Ratings:
    +93 / 0
    Home Country:
    Germany Germany
    Infos:
    These Subversion-snaps are compiled automatically, every week on friday.
    They are not pre-tested, so please use the backup option from time to time.
    If you'd like the bleeding edge code and don't mind the inherent risks, upgrade to the snapshot releases as they become available.
    If stability is important to you, you might want to stay with the fully-tested releases.​

    Report Issues / Bugs:
    1. Before you start an bugreport, make sure that you system meets the ::requirements::
    2. After you checked the requirements, take a look at our ::Bugtracker::, to find out if your issue has allready been reported.
      Roadmap/Changelog: MediaPortal 1 - TV-Server - Installers
    3. If the Problem is not known yet, please have a look at the correct Bugreport forum.

    How to install MediaPortal SVN-Snapshots in short:
    1. Install MediaPortal 1.0, not necessary if already done
    2. Run the Snapshot-Installer. You should create a backup.
    3. Run Configure. Sometimes the settings and database versions change from build to build, so you have to reconfigure your TV for example
    4. Hopefully enjoy the new version
    5. If not, restore your old files and you will have the former version back.




     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. MediaPortal-Bot

    MediaPortal-Bot Worlds greatest bot!

    Joined:
    March 26, 2007
    Messages:
    3,715
    Likes Received:
    90
    Ratings:
    +93 / 0
    Home Country:
    Germany Germany
    ===> DOWNLOAD <===


    This thread is open to everyone to provide feedback for this particular snapshot.
    If you found or confirm a bug please still open a single thread with full details in the related Bugsection. See first post for details.


    MediaPortal-changelog:
    Show Spoiler
    ------------------------------------------------------------------------
    r21821 | manfred-mp | 2009-03-01 15:10:56 +0100 (So, 01 Mrz 2009) | 1 line

    After user findings addition to Mantis: #0001972
    ------------------------------------------------------------------------
    r21824 | rtv_sf | 2009-03-02 22:15:27 +0100 (Mo, 02 Mrz 2009) | 1 line

    added sf.net #2655162 (DeviceVolumeMonitor / Winamp Visualization Caused GUI Freeze) - thx fforde!
    ------------------------------------------------------------------------
    r21825 | rtv_sf | 2009-03-02 23:07:51 +0100 (Mo, 02 Mrz 2009) | 1 line

    added sf.net #2655142 (Prevent Crash / Access Violation Errors) - thx fforde!
    ------------------------------------------------------------------------
    r21826 | chemelli_sf | 2009-03-03 14:18:15 +0100 (Di, 03 Mrz 2009) | 1 line

    Fixed mantis #0002032: DVD playback stop crash due to MiniDisplay plugin
    ------------------------------------------------------------------------
    r21827 | tourettes_ | 2009-03-03 15:41:02 +0100 (Di, 03 Mrz 2009) | 1 line

    Removed unused .cs files (windowless mode)
    ------------------------------------------------------------------------
    r21829 | rtv_sf | 2009-03-03 20:40:58 +0100 (Di, 03 Mrz 2009) | 13 lines

    some changes for mantis #1969 (Default skin has huge performance issue with 128MB GPUs)
    - added possibilty ("debug" setting) to choose _what_ should be cached into packedgfx:
    "packSkinGfx" - defaults to false for some testing - skin gfx will not be added
    "packLogoGfx" - defaults to true (like before) - tv thumbs will be added
    "packPluginGfx" - defaults to false (like before) - tetris and weather gfx were already commented out earlier
    - fixed radio thumbs not being handled like tv thumbs
    - fixed max texture dimension being restricted to 1920x1080 instead of 2048x2048
    - fixed lower gfx quality depending on chosen thumb quality
    - fixed some minor resource usage
    - fixed slow "Initialize Texture Manager during startup" using the ImageFast class I added for thumbnails - performance improved from ~ 10 seconds to 4 seconds for cache generation.
    - added logging for the supported texture size by the gpu driver
    - added logging for each packed texture which is saved
    - code cleanups
    ------------------------------------------------------------------------
    r21830 | chemelli_sf | 2009-03-04 11:10:03 +0100 (Mi, 04 Mrz 2009) | 1 line

    Updated Italian strings
    ------------------------------------------------------------------------
    r21831 | chemelli_sf | 2009-03-04 11:12:57 +0100 (Mi, 04 Mrz 2009) | 1 line

    Forgot to update version (based on date) in previous commit
    ------------------------------------------------------------------------
    r21835 | chef_koch | 2009-03-05 04:21:03 +0100 (Do, 05 Mrz 2009) | 3 lines

    CommonMPMacros: splitted MediaPortalOperatingSystemCheck into MediaPortalOperatingSystemCheck, MediaPortalAdminCheck and MediaPortalVCRedistCheck
    CommonMPMacros: added MediaPortalNetFrameworkCheck (from mediaportal/Setup/setup.nsi)
    DeployToolUnPacker: use MediaPortalNetFrameworkCheck instead of include-DotNetFramework.nsh
    ------------------------------------------------------------------------
    r21838 | chemelli_sf | 2009-03-05 10:56:17 +0100 (Do, 05 Mrz 2009) | 1 line

    Fixed mantis #0002033: ShouldStack() / RemoveStackEndings() need a small rework
    ------------------------------------------------------------------------
    r21839 | ronilse | 2009-03-05 13:58:22 +0100 (Do, 05 Mrz 2009) | 1 line

    Updated Norwegian language
    ------------------------------------------------------------------------
    r21844 | rtv_sf | 2009-03-05 17:52:46 +0100 (Do, 05 Mrz 2009) | 1 line

    commented CleanupThumbs() as Dispose already handles that now
    ------------------------------------------------------------------------
    r21845 | rtv_sf | 2009-03-05 17:54:09 +0100 (Do, 05 Mrz 2009) | 2 lines

    Handle empty last.fm playlists titles (their bug)
    removed unused code
    ------------------------------------------------------------------------
    r21846 | rtv_sf | 2009-03-05 17:59:25 +0100 (Do, 05 Mrz 2009) | 1 line

    Fixed: Using recordedtv share thumbs and deleting the thumb cache did not recreate the cache inmediately upon next start
    ------------------------------------------------------------------------
    r21847 | rtv_sf | 2009-03-05 18:01:57 +0100 (Do, 05 Mrz 2009) | 2 lines

    SVN preparation: re-enable "packSkinGfx" by default as not packing gfx _will_ cause issues.
    Changed weather gfx to be cached recursively independant from their folder name
    ------------------------------------------------------------------------
    r21849 | rtv_sf | 2009-03-05 18:16:38 +0100 (Do, 05 Mrz 2009) | 2 lines

    Fixed process starvation / output redirection deadlock
    Log redirected output from stdout and stderr
    ------------------------------------------------------------------------
    r21850 | rtv_sf | 2009-03-05 18:27:24 +0100 (Do, 05 Mrz 2009) | 1 line

    Check and log whether a file exists
    ------------------------------------------------------------------------
    r21852 | chemelli_sf | 2009-03-06 10:31:26 +0100 (Fr, 06 Mrz 2009) | 1 line

    Fixed mantis #0002035: MiniDisplay: kill iMON Manager under Vista leave systray icon in place (thx disaster123!)
    ------------------------------------------------------------------------
    r21854 | hwahrmann | 2009-03-06 11:13:40 +0100 (Fr, 06 Mrz 2009) | 1 line

    Fixed: 0002037: Upgrade of BassVis, Sonique Vis are now working fine again
    ------------------------------------------------------------------------
    r21856 | tourettes_ | 2009-03-06 16:22:50 +0100 (Fr, 06 Mrz 2009) | 1 line

    Fixed Mantis issue: 0002038: Crash can occur if HDMI audio device is disabled / removed during tv playback
    ------------------------------------------------------------------------
    r21857 | manfred-mp | 2009-03-06 17:17:08 +0100 (Fr, 06 Mrz 2009) | 1 line

    Fix #0002028: Commercial skipping does not work if logo file exist
    ------------------------------------------------------------------------
    r21861 | rtv_sf | 2009-03-06 21:43:05 +0100 (Fr, 06 Mrz 2009) | 1 line

    updates strings
    ------------------------------------------------------------------------
    r21862 | manfred-mp | 2009-03-06 21:45:49 +0100 (Fr, 06 Mrz 2009) | 1 line

    Fix #0002028: Commercial skipping does not work if logo file exist -> better solution
    ------------------------------------------------------------------------
    r21863 | chef_koch | 2009-03-06 22:09:56 +0100 (Fr, 06 Mrz 2009) | 1 line

    fixed/changed the way how an update 1.0 to 1.0.1 can be done
    ------------------------------------------------------------------------
    r21864 | rtv_sf | 2009-03-06 22:52:05 +0100 (Fr, 06 Mrz 2009) | 1 line

    fixed PathNotFound Exception in VisualizationManager.GetVisualizationPluginsInfo()
    ------------------------------------------------------------------------


    TvEngine3-changelog:
    Show Spoiler
    ------------------------------------------------------------------------
    r21816 | mr_hipp | 2009-02-28 21:50:27 +0100 (Sa, 28 Feb 2009) | 1 line

    Fixed wrong logo when playing recorded TV
    ------------------------------------------------------------------------
    r21820 | manfred-mp | 2009-03-01 15:02:01 +0100 (So, 01 Mrz 2009) | 1 line

    Fix #0002015: MediaPortal will freeze when TV is viewed non-fullscreen mode and TVServer goes down
    ------------------------------------------------------------------------
    r21835 | chef_koch | 2009-03-05 04:21:03 +0100 (Do, 05 Mrz 2009) | 3 lines

    CommonMPMacros: splitted MediaPortalOperatingSystemCheck into MediaPortalOperatingSystemCheck, MediaPortalAdminCheck and MediaPortalVCRedistCheck
    CommonMPMacros: added MediaPortalNetFrameworkCheck (from mediaportal/Setup/setup.nsi)
    DeployToolUnPacker: use MediaPortalNetFrameworkCheck instead of include-DotNetFramework.nsh
    ------------------------------------------------------------------------
    r21843 | rtv_sf | 2009-03-05 17:51:24 +0100 (Do, 05 Mrz 2009) | 2 lines

    order of thumb creation from recordings reversed - newest files first now,
    omit h.264 files with mediainfo for now - until mtn support is verified
    ------------------------------------------------------------------------
    r21848 | rtv_sf | 2009-03-05 18:13:50 +0100 (Do, 05 Mrz 2009) | 1 line

    include h.264 files again - enabling debug output of mtn will report broken recordings due to stream / tswriter errors.
    ------------------------------------------------------------------------
    r21853 | gibman_dk | 2009-03-06 11:05:11 +0100 (Fr, 06 Mrz 2009) | 1 line

    fixed mantis 0002036: xmltv importer (remote download) would not wake up system.
    ------------------------------------------------------------------------
    r21855 | gibman_dk | 2009-03-06 15:46:40 +0100 (Fr, 06 Mrz 2009) | 2 lines

    fixed mantis 0002036: xmltv importer (remote download) would not wake up system.
    forgot to commit file.
    ------------------------------------------------------------------------
    r21859 | rtv_sf | 2009-03-06 19:51:30 +0100 (Fr, 06 Mrz 2009) | 1 line

    Fixed wrong count..
    ------------------------------------------------------------------------
    r21863 | chef_koch | 2009-03-06 22:09:56 +0100 (Fr, 06 Mrz 2009) | 1 line

    fixed/changed the way how an update 1.0 to 1.0.1 can be done
    ------------------------------------------------------------------------
     
  4. iosub

    iosub Portal Pro

    Joined:
    April 26, 2006
    Messages:
    573
    Likes Received:
    30
    Occupation:
    Computer Bussines
    Location:
    San Sebastian
    Ratings:
    +30 / 0
    cant change recording settings on series, I get 'label missing '

    hi I dont know if is new to this snv but when I got to tv/scheduder to change a setting for a schedude (when is a Serie and there is not outgoing recordings,so is emptly)
    I get 'label missing'
    steps
    1 go to mytv
    2 select 'scheduled' and have series checked
    3 on scheduled recordings select a recording serie
    4 chick 'lnfo' on the remote
    5 select ' 3 settings '
    you get an screen with 'label missing' ONLY IF THERE ARE NOT UPCOMMING Episodes"

    is allways reproducible

    Logs
    When "Series" is checked "I get Label missing"
    2009-03-07 05:16:00.103400 [Info.][MPMain]: OnShowContextMenu: Rec = Dutifrí on 39 02/06/2008 0:45:00 - 02/06/2008 2:00:00 ID=18
    2009-03-07 05:16:00.117400 [Debug][MPMain]: WindowManager: route TvPlugin.TvScheduler:601->MediaPortal.Dialogs.GUIDialogMenu:2012
    2009-03-07 05:16:00.119400 [Debug][MPMain]: DialogWindow: MediaPortal.Dialogs.GUIDialogMenu init
    2009-03-07 05:16:01.569400 [Debug][MPMain]: WindowManager: unroute to MediaPortal.Dialogs.GUIDialogMenu:2012->TvPlugin.TvScheduler:601
    2009-03-07 05:16:01.607400 [Info.][MPMain]: recording fname:
    2009-03-07 05:16:04.893400 [Debug][MPMain]: Window: TvPlugin.TvScheduler deinit
    2009-03-07 05:16:04.894400 [Debug][MPMain]: TextureManager: CleanupThumbs()
    2009-03-07 05:16:04.955400 [Debug][MPMain]: Window: TvPlugin.TVProgramInfo init

    When "series" is not checked
    2009-03-07 05:17:53.959400 [Info.][MPMain]: OnShowContextMenu: Rec = La noria on 39 07/03/2009 21:45:00 - 08/03/2009 2:15:00 ID=546
    2009-03-07 05:17:53.967400 [Debug][MPMain]: WindowManager: route TvPlugin.TvScheduler:601->MediaPortal.Dialogs.GUIDialogMenu:2012
    2009-03-07 05:17:53.968400 [Debug][MPMain]: DialogWindow: MediaPortal.Dialogs.GUIDialogMenu init
    2009-03-07 05:17:55.412400 [Debug][MPMain]: WindowManager: unroute to MediaPortal.Dialogs.GUIDialogMenu:2012->TvPlugin.TvScheduler:601
    2009-03-07 05:17:55.454400 [Info.][MPMain]: recording fname:
    2009-03-07 05:17:58.650400 [Debug][MPMain]: Window: TvPlugin.TvScheduler deinit
    2009-03-07 05:17:58.652400 [Debug][MPMain]: TextureManager: CleanupThumbs()
    2009-03-07 05:17:58.665400 [Debug][MPMain]: Window: TvPlugin.TVProgramInfo init
    2009-03-07 05:17:58.744400 [Info.][11]: TVProgrammInfo.item_OnItemSelected: La noria


    iosu
     
  5. argypak

    argypak Portal Pro

    Joined:
    November 21, 2007
    Messages:
    62
    Likes Received:
    0
    Location:
    Berwick
    Ratings:
    +0 / 0
    Home Country:
    I've tried this and it works okay.
     
  6. Helios61
    • Team MediaPortal

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Installation not possible here on a clean install! I get this error - message:

    [​IMG]

    Then i have installed it -> same issue again! Older SVN is working fine!

    Best regards

    Helios
     
  7. RoXoR
    • Premium Supporter

    RoXoR MP Donator

    Joined:
    August 3, 2008
    Messages:
    347
    Likes Received:
    17
    Gender:
    Male
    Occupation:
    student
    Location:
    B-W
    Ratings:
    +23 / 0
    Home Country:
    Germany Germany
    Same here! XP Pro SP3 is installed...


    RoXoR
     
  8. flokel
    • Team MediaPortal

    flokel Portal Developer

    Joined:
    October 11, 2005
    Messages:
    1,601
    Likes Received:
    157
    Location:
    Unterfranken
    Ratings:
    +157 / 0
    Home Country:
    Germany Germany
    What value do you have in the following registry key
    after installing the SP2 for .NET 2.0 ?

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727\SP
     
  9. argypak

    argypak Portal Pro

    Joined:
    November 21, 2007
    Messages:
    62
    Likes Received:
    0
    Location:
    Berwick
    Ratings:
    +0 / 0
    Home Country:
    I had the same problem with the Service Pack for Framework 2, but I found out that it was the link that is at fault.
    It sends you to the Compact Frame work service pack 2.

    Just google Framework 2 SP2 and download that file, it will work.
     
  10. Helios61
    • Team MediaPortal

    Helios61 Retired Team Member

    Joined:
    January 30, 2008
    Messages:
    4,587
    Likes Received:
    584
    Gender:
    Male
    Location:
    NRW
    Ratings:
    +897 / 4
    Home Country:
    Germany Germany
    Show System Specs
    I hope, this Screenshot will help!
     
  11. flokel
    • Team MediaPortal

    flokel Portal Developer

    Joined:
    October 11, 2005
    Messages:
    1,601
    Likes Received:
    157
    Location:
    Unterfranken
    Ratings:
    +157 / 0
    Home Country:
    Germany Germany
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!