MediaPortal SVN-Snapshot:-07-04-2009 09-04h - Revision:23143.rar (1 Viewer)

MediaPortal-Bot

Worlds greatest bot!
March 26, 2007
3,715
180
Germany Germany
Infos:
These Subversion-snaps are compiled automatically, every week on friday.
They are not pre-tested, so please use the backup option from time to time.
If you'd like the bleeding edge code and don't mind the inherent risks, upgrade to the snapshot releases as they become available.
If stability is important to you, you might want to stay with the fully-tested releases.​

Report Issues / Bugs:
  1. Before you start an bugreport, make sure that you system meets the ::requirements::
  2. After you checked the requirements, take a look at our ::Bugtracker::, to find out if your issue has allready been reported.
    Roadmap/Changelog: MediaPortal 1 - TV-Server - Installers
  3. If the Problem is not known yet, please have a look at the correct Bugreport forum.

How to install MediaPortal SVN-Snapshots in short:
  1. Install MediaPortal 1.1.0 Alpha, not necessary if already done
  2. Run the Snapshot-Installer. You should create a backup.
  3. Run Configure. Sometimes the settings and database versions change from build to build, so you have to reconfigure your TV for example
  4. Hopefully enjoy the new version
  5. If not, restore your old files and you will have the former version back.

 

MediaPortal-Bot

Worlds greatest bot!
March 26, 2007
3,715
180
Germany Germany
===> DOWNLOAD <===


This thread is open to everyone to provide feedback for this particular snapshot.
If you found or confirm a bug please still open a single thread with full details in the related Bugsection. See first post for details.
 

doornjoostje

Portal Pro
December 6, 2007
432
14
Netherlands Netherlands
I've installed this version (upgrade from 1.0.1).
Works really well.
No problems yet.
Nice work.
 

rekenaar

Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    South Africa South Africa
    Changelog

    MediaPortal
    ------------------------------------------------------------------------
    r23098 | manfred-mp | 2009-06-27 11:39:43 +0200 (Sat, 27 Jun 2009) | 1 line

    fix 2302: Daemon tools setup doesn't find installed program and drives are not filtered
    ------------------------------------------------------------------------
    r23100 | tourettes_ | 2009-06-27 20:39:33 +0200 (Sat, 27 Jun 2009) | 1 line

    Updated fin language file
    ------------------------------------------------------------------------
    r23101 | chemelli_sf | 2009-06-28 00:59:33 +0200 (Sun, 28 Jun 2009) | 4 lines

    Additional fix for mantis #0002235: MiniDisplay: code cleanup for iMON driver (fourth part)

    - Added handling for IRSS when in systray application mode (x64 systems)

    ------------------------------------------------------------------------
    r23102 | flokel | 2009-06-28 09:18:34 +0200 (Sun, 28 Jun 2009) | 1 line

    updated hebrew translation of MP (thx bob987)
    ------------------------------------------------------------------------
    r23104 | morpheus_xx | 2009-06-28 12:45:56 +0200 (Sun, 28 Jun 2009) | 1 line

    Fix mantis 0002309: MP Watchdog tries to write into MediaPortal.xml in program path
    ------------------------------------------------------------------------
    r23105 | morpheus_xx | 2009-06-28 13:01:19 +0200 (Sun, 28 Jun 2009) | 1 line

    additional fix for mantis 2293: move skin to config dir
    ------------------------------------------------------------------------
    r23106 | flokel | 2009-06-28 14:19:51 +0200 (Sun, 28 Jun 2009) | 1 line

    updated dutch translation of MP and DeployTool (thx Lbr_Lion)
    ------------------------------------------------------------------------
    r23107 | morpheus_xx | 2009-06-28 14:23:22 +0200 (Sun, 28 Jun 2009) | 1 line

    major refactoring of Settings: use MPSettings() now to access MediaPortal.xml
    ------------------------------------------------------------------------
    r23109 | manfred-mp | 2009-06-28 14:32:34 +0200 (Sun, 28 Jun 2009) | 1 line

    Update
    ------------------------------------------------------------------------
    r23112 | chemelli_sf | 2009-06-28 22:35:50 +0200 (Sun, 28 Jun 2009) | 4 lines

    Fixed mantis #0002306: Null ref in FrameGrabber

    + minor code formatting

    ------------------------------------------------------------------------
    r23119 | manfred-mp | 2009-06-30 16:51:33 +0200 (Tue, 30 Jun 2009) | 1 line

    Fix 2312: IMDB fails always if extension is not hidden
    ------------------------------------------------------------------------
    r23120 | manfred-mp | 2009-06-30 17:54:34 +0200 (Tue, 30 Jun 2009) | 2 lines

    fix 2302: Daemon tools setup doesn't find installed program and drives are not filtered
    - additional fix to scan all drives
    ------------------------------------------------------------------------
    r23126 | hwahrmann | 2009-07-02 10:45:14 +0200 (Thu, 02 Jul 2009) | 4 lines

    0002318: Integrate the SavePlayList Plugin into MediaPortal

    when leaving MP the current playlist is saved as default.m3u.
    default.m3u is loaded when starting Mediaportal.
    ------------------------------------------------------------------------
    r23127 | rtv_sf | 2009-07-02 12:44:34 +0200 (Thu, 02 Jul 2009) | 3 lines

    Fix for mantis #2319: MediaPortal does not abort the startup gracefully if core components are missing
    - added exception handling for string and texture manager
    - minor cleanups on the splashscreen messages
    ------------------------------------------------------------------------
    r23128 | hwahrmann | 2009-07-02 13:00:42 +0200 (Thu, 02 Jul 2009) | 1 line

    Fix 0002253: MediaPortal does not start if "show last active module" would open a PIN protected folder
    ------------------------------------------------------------------------
    r23130 | flokel | 2009-07-02 13:40:32 +0200 (Thu, 02 Jul 2009) | 1 line

    updated spanish translation (thx Pedernal74)
    ------------------------------------------------------------------------
    r23131 | manfred-mp | 2009-07-02 18:49:11 +0200 (Thu, 02 Jul 2009) | 1 line

    0002320: Refresh rate was not applied to TV
    ------------------------------------------------------------------------
    r23132 | manfred-mp | 2009-07-02 19:11:05 +0200 (Thu, 02 Jul 2009) | 2 lines

    0002320: Refresh rate was not applied to TV
    - better fix
    ------------------------------------------------------------------------
    r23133 | seidelin | 2009-07-02 19:40:54 +0200 (Thu, 02 Jul 2009) | 1 line

    Mantis 1138: localization problem. Thanks UNOPARATOR
    ------------------------------------------------------------------------
    r23134 | rtv_sf | 2009-07-02 20:32:01 +0200 (Thu, 02 Jul 2009) | 9 lines

    Fix for mantis #2321: Weather plugin does not use high resolution images
    - fixed code to use 128 pixel images if skin height is >= 720
    - enlarged current image to 175px
    - enlarged 5 day's images to 128px
    - fixed double refreshes
    - fixed improper usage of GUIImage control
    - improved performance when changing of cities
    - minor code cleanups

    ------------------------------------------------------------------------
    r23135 | rtv_sf | 2009-07-02 20:48:19 +0200 (Thu, 02 Jul 2009) | 1 line

    fixed bogus char
    ------------------------------------------------------------------------
    r23137 | rtv_sf | 2009-07-02 22:50:56 +0200 (Thu, 02 Jul 2009) | 1 line

    Fixed: weather icons did not keep aspect ratio
    ------------------------------------------------------------------------
    r23138 | rtv_sf | 2009-07-02 22:53:20 +0200 (Thu, 02 Jul 2009) | 2 lines

    Fix for REV 23063 - mantis #2293: skin folder is moved to config dir & mantis #2294: language folder is moved to config dir:
    - postbuild.bat did not copy files into correct destination dir
    ------------------------------------------------------------------------
    r23139 | rtv_sf | 2009-07-03 00:53:31 +0200 (Fri, 03 Jul 2009) | 5 lines

    Fix for mantis #2323: Weather plugin is unresponsive while downloading images
    - added background thread to fetch the detail images
    - fixed aspect ratio of TWC logo
    - removed bad texture cleanups

    ------------------------------------------------------------------------
    r23142 | flokel | 2009-07-03 20:24:52 +0200 (Fri, 03 Jul 2009) | 1 line

    updated Macedonian translations for MP and DeployTool (thx dimrubin)
    ------------------------------------------------------------------------
    r23143 | manfred-mp | 2009-07-03 22:27:34 +0200 (Fri, 03 Jul 2009) | 1 line

    Fix 2304: Null ref when stopping TV if refreshrate change is in use
    ------------------------------------------------------------------------

    TVServer
    ------------------------------------------------------------------------
    r23097 | tourettes_ | 2009-06-26 20:29:28 +0200 (Fri, 26 Jun 2009) | 1 line

    Added DVB-T tuning details for Australia - QLD - Mackay
    ------------------------------------------------------------------------
    r23099 | morpheus_xx | 2009-06-27 13:57:21 +0200 (Sat, 27 Jun 2009) | 2 lines

    additional fix for mantis #2151: fixed null ref when "CloseDisplay" called before menu shown
    changed handling of SetupTv card sections, so that CI menu handler un/-registers
    ------------------------------------------------------------------------
    r23108 | morpheus_xx | 2009-06-28 14:24:29 +0200 (Sun, 28 Jun 2009) | 1 line

    major refactoring of Settings: use MPSettings() now to access MediaPortal.xml #2 TvPlugin
    ------------------------------------------------------------------------
    r23113 | rtv_sf | 2009-06-30 00:19:30 +0200 (Tue, 30 Jun 2009) | 4 lines

    Fix for mantis #2311: TV-Server should not record [series] schedules that are already present
    - upgrade MpTvDb to V46 to include episode titles for recordings
    - omit recordings of the same episode (no settings yet)

    ------------------------------------------------------------------------
    r23114 | rtv_sf | 2009-06-30 00:32:44 +0200 (Tue, 30 Jun 2009) | 4 lines

    Fix for mantis #2311: TV-Server should not record [series] schedules that are already present
    - added check for the record "title" itself as some EPG sources could misuse the episode field for other, non-unique information
    - added error handling in case of comparison exceptions

    ------------------------------------------------------------------------
    r23115 | rtv_sf | 2009-06-30 11:06:09 +0200 (Tue, 30 Jun 2009) | 3 lines

    Fix for mantis #2311: TV-Server should not record [series] schedules that are already present
    - Trim strings before comparing them

    ------------------------------------------------------------------------
    r23116 | rtv_sf | 2009-06-30 11:51:36 +0200 (Tue, 30 Jun 2009) | 4 lines

    Fix for mantis #2311: TV-Server should not record [series] schedules that are already present
    - Added setting (default off) to toggle the repeating detection


    ------------------------------------------------------------------------
    r23117 | rtv_sf | 2009-06-30 13:17:20 +0200 (Tue, 30 Jun 2009) | 3 lines

    Fix for mantis #2311: TV-Server should not record [series] schedules that are already present
    - Turned off autosize of the label to better fit on vista.

    ------------------------------------------------------------------------
    r23118 | rtv_sf | 2009-06-30 13:56:03 +0200 (Tue, 30 Jun 2009) | 4 lines

    Fix for mantis #2311: TV-Server should not record [series] schedules that are already present
    - Check for 1KB files left over from unsuccessful previous recording attempts
    - Minor cleanups

    ------------------------------------------------------------------------
    r23121 | rtv_sf | 2009-06-30 18:34:26 +0200 (Tue, 30 Jun 2009) | 3 lines

    TVProgramInfo:
    - increased date restriction for upcoming episode from 14 to 28 days (for people with better EPG)
    - added invoke delegate for the item_selected event
    ------------------------------------------------------------------------
    r23122 | rtv_sf | 2009-06-30 19:18:52 +0200 (Tue, 30 Jun 2009) | 5 lines

    Fix for mantis #2311: TV-Server should not record [series] schedules that are already present
    - Improved logging,
    - Removed schedule of duplicate to avoid a re-schedule try every 15 seconds
    - Made crash check more relaxing (only checking same date)

    ------------------------------------------------------------------------
    r23123 | rtv_sf | 2009-06-30 22:49:43 +0200 (Tue, 30 Jun 2009) | 1 line

    fixed some logging
    ------------------------------------------------------------------------
    r23125 | morpheus_xx | 2009-07-01 17:51:47 +0200 (Wed, 01 Jul 2009) | 1 line

    Fix mantis 0002313: StreamingServer crashes whole TvServer in case of failures #2
    ------------------------------------------------------------------------
    r23129 | flokel | 2009-07-02 13:35:55 +0200 (Thu, 02 Jul 2009) | 1 line

    updated spanish DVB-T frequencies
    ------------------------------------------------------------------------
    r23136 | manfred-mp | 2009-07-02 20:58:54 +0200 (Thu, 02 Jul 2009) | 1 line

    Fix 2322: Hardcoded value for lock on signal timeout, thx seco
    ------------------------------------------------------------------------
    r23140 | chef_koch | 2009-07-03 03:36:47 +0200 (Fri, 03 Jul 2009) | 1 line

    added plugin icon from tve2 PS to PowerSchedulerClientPlugin
    ------------------------------------------------------------------------
    r23141 | flokel | 2009-07-03 20:18:08 +0200 (Fri, 03 Jul 2009) | 1 line

    updated DVB-C frequencies for The Netherlands-Ziggo (thx Lbr_Lion)
    ------------------------------------------------------------------------
     

    disaster123

    MP Donator
  • Premium Supporter
  • May 14, 2008
    3,546
    432
    Germany Germany
    Country flag
    I cannot see any recordings:
    this happens for every .ts file in recordings:
    Code:
    2009-07-05 19:21:27.260715 [Warn.][MPMain]: TVRecorded: Error building item from recording O:\VID\Grey's Anatomy - Die jungen Ärzte\Grey's Anatomy - Die jungen Ärzte - (Geister) S-E- - 2009-05-27 - 20_15.ts
    Error: UnexpectedRowCountUnclassified
    Gentle.Common.GentleException: The number of returned rows 0 did not match the expected count of 1.
    If concurrency control is enabled this may indicate that the record was updated or deleted by another process.
     bei Gentle.Common.Check.FailWith(Severity severity, Error error, Exception e, String msg)
     bei Gentle.Common.Check.Fail(Exception e, Error error, Object[] args)
     bei Gentle.Common.Check.Verify(Boolean condition, Error error, Object[] args)
     bei Gentle.Framework.ObjectFactory.GetInstance(Type type, SqlResult sr, Key key)
     bei Gentle.Framework.PersistenceBroker.RetrieveInstance(Type type, Key key, IDbConnection conn, IDbTransaction tr)
     bei Gentle.Framework.PersistenceBroker.RetrieveInstance[T](Key key)
     bei Gentle.Framework.Broker.RetrieveInstance[T](Key key)
     bei TvDatabase.Channel.Retrieve(Int32 id)
     bei TvDatabase.Recording.ReferencedChannel()
     bei TvPlugin.TvRecorded.BuildItemFromRecording(Recording aRecording)
    Could fix it with removing all recordings from DB and reimporting them.
     

    wouter1971

    MP Donator
  • Premium Supporter
  • November 19, 2008
    911
    143
    Purmerend, Holland
    Netherlands Netherlands
    Country flag
    I cannot see any recordings:
    this happens for every .ts file in recordings:

    Could fix it with removing all recordings from DB and reimporting them.
    I got the same on ALPHA release too. Very anoying.

    Just installed this svn. pfff.....no signal on all channels, satellite DVB-S(2).

    Just went through tv-server config. Remembered that i adjusted the "tune" paramater to 0 sec.
    Setting it to 2 seconds again fixed it all. Strange that it was of no influence earlier.
     

    rekenaar

    Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    South Africa South Africa
    Just went through tv-server config. Remembered that i adjusted the "tune" paramater to 0 sec.
    Setting it to 2 seconds again fixed it all. Strange that it was of no influence earlier.
    see this in the changelog:
    Fix 2322: Hardcoded value for lock on signal timeout, thx seco

    Everyone else: Please remember full logs and guidelines required here.
     

    Seidelin

    Retired Team Member
  • Premium Supporter
  • August 14, 2006
    1,755
    652
    Kgs. Lyngby
    Denmark Denmark
    Country flag
    Hi, is anyone else not getting DVB subtitles since alpha? DVBS subs are fine but no DBV.

    Kev.
    I assume you have activated DVB subs in the Television/TVClient/Subtitle settings part of MediaPortal Configuration.

    Did you install this SVN on top of 1.1.0 Alpha?

    Your symptoms fit with Visual C++ 2008 SP1 not being installed as stated on the general requirements page. This should(!) be installed by the 1.1.0 installer.

    Try installing it and then do a regsvr32 dvbsub2.ax from a dos prompt in the MediaPortal program folder.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    doskabouter Installing mediaportal MediaPortal 1 3
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 41
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper MediaPortal configuration error log message General Support 1
    Rob Hexenmeister Mediaportal Properties #plot etc... General Support 3
    ajs [News] MediaPortal 1 - 1.24 Released! News and Announcements 3
    S [solved] access the desktop without leaving mediaportal General Support 5
    J New computer with win10 and how will i set Mediaportal up ? Newcomers Forum 55
    T MediaPortal Extensions Manager Fehlermeldung bei Installation einer Erweiterung Installationsprobleme? 1
    Similar threads

























    Top Bottom