mediaportal.xml truncated to zero-> instant crash (1 Viewer)

Craydk

Portal Member
June 4, 2007
31
1
Denmark Denmark
had an unusual experiance with MP... One day (after my grilfriend had been home alone) MP would start anymore (crashed unexpectedly) config would start either. TV-server worked fine though...
After alot of going back and forth i eventually discovered that mediaportal.xml had been truncated to zero (ie file exist but no content). I deleted the emty file and everything ran smoothly.

unfortunaly i have no logs (deleted accidently) and i have no idea why the file was truncated to zero. so no reproduce (give my girlfriend another go ;)). but perhaps an exceptionhandler should not just look at if the file exist (which i would image it does?) but also if it is valid too?

/regard

this was on vista with the SVN build of last week
 

ronilse

Retired Team Member
  • Premium Supporter
  • July 19, 2005
    4,422
    282
    Moss
    Norway Norway
    Country flag
    Hi,
    Yeah live & learn(that means don't let gf/wife get the hands on MP ;) )

    Joke aside. Not sure we can do anything, but will check. Btw was the MediaPortal.xml complete clean(nothing in it)?

    Regards
    Roy
     

    Craydk

    Portal Member
    June 4, 2007
    31
    1
    Denmark Denmark
    think i discovered the problem.... as it happened again...
    It was running (very) short on disk space. this time it was not truncated to zero but the problem disappered when i deleted mediaportal.xml... oh well i deleted a bunch of old recordings and dont plan on seing the issue again...
     

    ronilse

    Retired Team Member
  • Premium Supporter
  • July 19, 2005
    4,422
    282
    Moss
    Norway Norway
    Country flag
    Hi,
    Yeah, the 0byte file & crash it's fixed by Bavarian so that shouldn't happen again, the space left on hdd i can't help you with ;)

    Thanks for reporting :)

    Regards
    Roy
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Symphy Version 0.2.9.0 for MediaPortal 1.25 ASIO music player 0
    doskabouter Installing mediaportal MediaPortal 1 3
    A Mediaportal Allgemeines Support- und Diskussionsforum 0
    G Update von MediaPortal Installationsprobleme? 0
    ajs [News] MediaPortal 1 - 1.25 Released! News and Announcements 1
    horned_reaper Standby is prevented by MediaPortal client General Support 0
    U [solved] MediaPortal crashing on startup General Support 10
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    high [unanswered] Hallo möchte gerne Mediaportal. nutzen kann mich jemand anrufen? contactform feedback and requests 2
    ajs [News] MediaPortal 1.25 Pre-Release ready for testing! News and Announcements 0
    ajs [Rejected] Mediaportal Codename MediaPortal 1 41
    M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
    N Steam release of MediaPortal MediaPortal 1 Talk 0
    torone Dritter versuch mit Mediaportal 2 Allgemeines Support- und Diskussionsforum 1
    M Fehlerhafter Link auf der aktuellen MediaPortal Seite Page- und Forumsfeedback 0
    H 1.24.0 MP 1.24 high CPU utilization when 'Keep MediaPortal always on top' option enabled Bugreports 4
    mickb [solved] Mediaportal Stops working General Support 5
    J [solved] Newbie to MediaPortal 2 - Cannot open/run TV programs Newcomers Forum 4
    atlantic How to use Spotify inside Mediaportal? Listen Music 18
    horned_reaper MediaPortal configuration error log message General Support 1
    Rob Hexenmeister Mediaportal Properties #plot etc... General Support 3
    ajs [News] MediaPortal 1 - 1.24 Released! News and Announcements 3
    S [solved] access the desktop without leaving mediaportal General Support 5
    J New computer with win10 and how will i set Mediaportal up ? Newcomers Forum 55
    T MediaPortal Extensions Manager Fehlermeldung bei Installation einer Erweiterung Installationsprobleme? 1
    Similar threads

























    Top Bottom