MKV Optimizer, entfernen von nicht benötigten Audiospuren (4 Viewers)

johnnybargeld

Portal Member
January 1, 2015
10
1
Home Country
Germany Germany
Das finde ich dreist und Anstand sehe ich da auch nicht. Ich habe mich bisher anständig verhalten! Aber bieten lassen muss ich mir das nicht!
9 Post seit 2015 . Auch für Dich. Ich habe meine Meinung geäußert und KEIN Recht abgeleitet bzw. eingefordert!
Moin, ich muss mich ja nicht an der Anzahl meiner Meldungen messen lassen. Ich selbst nutze das Tool hier gar nicht.
Und ich habe nie behauptet, dass DU einen Anspruch abgeleitet hast oder ein Recht eingefordert hast.

Auch ich habe meine Meinung kund getan:
Ich finde der Thread sollte nicht geschlossen werden! Das kann der Entwickler - so fern er es denn möchte - selber tun / veranlassen.
Man darf nicht vergessen, dass dieses Tool (wie viele andere) kostenlos von jemand zur Verfügung gestellt wird. Daraus ergibt sich für die Nutzer aber nicht das Recht irgendeinen Anspruch abzuleiten.


Das war also allgemein gehalten und sollte niemand persönlich ansprechen. Wenn das so rübergekommen ist, tut es mir leid.
Hier hilft es zu wissen wie die zwischenmenschliche Kommunikation abläuft. 4-Ohren-Modell nach Schulz von Thun.
Dann haben wir uns einfach falsch verstanden :)
 

Wulfman

Portal Member
March 17, 2010
24
0
Home Country
Germany Germany
Irgendwas klappt bei MKVToolNix 69.0 und 70.0 nicht mehr sauber mit MKV Optimizer.

Bei der 69 hatte ich 5-6 Files gefunden - hab alle markiert und 4 (ein Release) wurde sofort übersprungen. Die anderen gingen aber. Jetzt hab ich die v70 drauf und MKV Optimizer überspringt jetzt auch "Standard"-MKVs ...

Liegt das an mir? Werde die Tage mal wieder auf die MKVToolNix 68 updaten und gucken ... aber komisch ist das schon ... alle betroffene files sind MKV mit eac/ac-Tonspuren und h264 ... also absoluter Standard.
 

Wulfman

Portal Member
March 17, 2010
24
0
Home Country
Germany Germany
Ok es liegt NICHT (nur) an MKVOptimizer ...

Ich hab zwei Systeme:

Windows 11 + MKVToolnix 69
Windows 10 + MKVToolnix (60-70 jetzt durchprobiert)
=> MKVOptimizer braucht auf beiden Systemen jebenfalls ewig bis zum start - ich markiere ein Film. Drücke auf optimieren -> ich sehe unten kurz "mkvpropit" und dann ist der Vorgang auch beendet. Auf beiden Systeme.

Aber nicht bei allen Files: Ich hab jetzt das MKV mal auf das andere PC geschoben -> auch hier weigert sich MKVOptimizer. Ein anderes File klappt ohne Probleme. Beide Files mal mit Mediainfo angeschaut:

Video: kein nennenswerter Unterschied
geht / geht nicht
16:9 / 2,40:1
12Mbit / 10Mbit
Auflösung

Geht: Kodierungseinstellungen : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=12 / lookahead_threads=2 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=16.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00

Geht nicht: hat keine


----

Audio:
Auf beiden Seiten nichts was ich nicht sonst auch immer hatte...
AC3 / EAC3

Allgemein
Geht nicht:
Kodierendes Programm : Lavf58.45.100
verwendete Encoder-Bibliothek : Lavf58.45.100
Geht:
kein Eintrag

Geht nicht: ErrorDetectionType : Per level 1
Geht: hat dieses Setting nicht

Ich hab das File jetzt durch mkvtvoolnix gehauen
ErrorDetectionType ist danach weg.

Dann hab ich das File mit mkvtoolnix einfach nur remuxen lassen - ohne etwas zu ändern. Keine Tonspur gelöscht usw.
DANACH klappt die Datei mit MKVOptimizer

Also irgendwas ist an dem File was mkvtoolnix ignoriert oder korrigiert während MKVOptimizer sich dran stört. Das problem hab ich jetzt schon bei 5 von 10 Files - alles neuere Files (die 5 die geklappt haben waren älter)

MKVOptimizer schickt ja bestimmt nur eine cmd-Line an mkvtoolnix? Leider ist die mir nicht bekannt - würde sonst mal versuchen das ganze auf der Konsole zu machen - vielleicht bekomme ich da eine Aussagekräftige Fehlermeldung?
 

Wulfman

Portal Member
March 17, 2010
24
0
Home Country
Germany Germany
Gerade das Tool MKVAlidator gefunden ...

Geht nicht-File: WRN311: The Cues entry for timecode 60019 ms is listed after entry 60060 ms (und weitere Zeilen.... mit geänderten ms - dauert ewig - hab es nicht zu ende laufen lassen)
Nachdem ich das File einfach nur remuxed habe - ohne Änderungen: sauber

Das File ist ja grundzätzlich in der Lage remuxed zu werden - mkvtoolnix macht das ja. MKVOptimizer muss hier vermutlich bei der übergabe an die cmd-line ein "ignore"/"repair"-Flag gesetzt bekommen oder was auch immer mkvtoolnix hier macht.

@lightshock Geht ja nicht um ein neues Feature sondern nur vermutlich eine Ergänzung ... vielleicht kannst du da was machen?

Ansonsten: wenn dir die Zeit doch fehlt - warum nicht rauf auf Github - Opensource? Dann lebt das Tool wenigstens weiter? - es finden sich sicher welche die dran arbeiten wollen. Leider ist mkvoptimizer alternativlos ;(
 
Last edited:

Lehmden

Retired Team Member
  • Premium Supporter
  • December 17, 2010
    12,448
    3,875
    Lehmden
    Home Country
    Germany Germany
    Hi.
    Dann hab ich das File mit mkvtoolnix einfach nur remuxen lassen - ohne etwas zu ändern. Keine Tonspur gelöscht usw.
    DANACH klappt die Datei mit MKVOptimizer
    Das liegt an mediainfo.dll Die Dateien, die nicht funktioniert haben, hatten die Header Daten nicht oder nicht nur am Anfang der Datei. Das ist zwar von den MKV Specs her erlaubt, aber mediainfo.dll kommt damit öfter mal nicht klar. Und Mediainfo wird im Gegensatz zu mkvtoolnix bei MKV-Optimizer zwingend benötigt.

    Verursacht wird das Ganze dadurch, das der Speicherplatz am Anfang der Datei begrenzt ist. Bei MKV kann man aber auch Dateien wie Cover usw. in das Video integrieren. Damit kann der verfügbare Platz sehr leicht überschritten werden. Deswegen erlauben die MKV Spezifikationen das Anhängen der Header Daten auch am Ende des Videos wo es keine Platzbeschränkung gibt. Allerdings müssten Verweise zu den Daten am Ende des Videos im Header- Bereich am Anfang des Videos hinterlegt sein. Und das funktioniert (zu) oft nicht, abhängig vom Programm, mit dem das Video kodiert worden ist. Durch das simple Remuxen korrigiert mkvtoolnix (genauer mkvmerge) dieses Problem.

    Leider ist mkvoptimizer alternativlos ;(
    Als Stand Alone Tool, ja. Aber wir haben in Media-Buddy (an dem @lightshock und ich zusammen arbeiten) zumindest teilweise vergleichbare Funktionen eingebaut. Die volle Funktionalität von MKV Optimizer wäre aber wohl zu viel des Guten geworden. In sofern ist Media-Buddy eine Ergänzung, kein Ersatz. Man kann mkv damit ebenfalls von unerwünschten Ton- und Untertitel- Spuren befreien, sogar auch von unerwünschten Video- Spuren, sofern es mehrere Video Spuren gibt. Dabei wird auch das Remuxen (aka. reparieren) automatisch mit erledigt.
     

    lightshock

    Test Group
  • Team MediaPortal
  • June 3, 2008
    550
    124
    bei Karlsruhe
    Home Country
    Germany Germany
    Moin,

    MKVOptimizer braucht auf beiden Systemen jebenfalls ewig bis zum start
    Habe ich bei mir lokal schon behoben. Da geht es um die Versionsabfrage von MKVToolNix.

    Geht ja nicht um ein neues Feature sondern nur vermutlich eine Ergänzung ... vielleicht kannst du da was machen?
    Ich schau mir das mal an was es da für Parameter bezüglich "interessiert mich nicht, ich mache einfach was ich will" gibt :)

    Und Mediainfo wird im Gegensatz zu mkvtoolnix bei MKV-Optimizer zwingend benötigt
    Stimmt nicht ganz. MediaInfo ist beim Optimizer gar nicht mit dabei. Das ist nur beim nfo4htpc so, weil wir es da ja eh haben.
    Beim Optimizer nutze ich nur die MKVToolNix eigenen Programme.

    wenn dir die Zeit doch fehlt
    Ich schau mal ob ich diese Woche etwas Luft habe. Es stehen noch weitere Korrekturen bei anderen Programmen an.
     

    lightshock

    Test Group
  • Team MediaPortal
  • June 3, 2008
    550
    124
    bei Karlsruhe
    Home Country
    Germany Germany
    @Wulfman
    Hast du vielleicht noch so eine kaputte Datei?
    Ich habe bei den CLI Parametern jetzt nichts spezielles gefunden um Fehler einfach zu "ignorieren".
    Vielleicht kann ich den Fehler auslesen und dann entscheiden wie es weiter geht.
    Danke
     

    Wulfman

    Portal Member
    March 17, 2010
    24
    0
    Home Country
    Germany Germany
    Ja ... aber damit gibt es ein anderes Problem - hab dich gerade mal angeschrieben.

    Vielleicht gibt es noch eine andere Möglichkeit?

    Mediainfo sagt mir ja das hier:
    Kodierendes Programm : mkvmerge v68.0.0 ('The Curtain') 64-bit
    verwendete Encoder-Bibliothek : libebml v1.4.2 + libmatroska v1.6.4

    kann man so ein File damit ggf. nachstellen? Aber das es an den verwendeten Tools liegt, glaub ich eher nicht.

    Was ich gerade sehe: Es hat übrigens 42 (!!) Untertitel (ALLES dabei...) und 2 Tonspuren ...

    Da muss ich jetzt noch mal an das denken was @Lehmden geschrieben hat
    "Verursacht wird das Ganze dadurch, das der Speicherplatz am Anfang der Datei begrenzt ist."

    Speicherplatz?
    Wie erstelle ich den jetzt einfach ein MKV mit 42 Tonspuren? ;) Dann könnte ich das testen ob es vielleicht an der Menge liegt. Hab das File jetzt mal durch MKVToolnix gejagt - OHNE das ich etwas entferne ... Klappt aber danach mit deinem Tool :| Aber vielleicht trotzdem in der Richtung? Hab jetzt leider kein weiteres File mehr gehabt ... achte mal drauf ...
     

    Users who are viewing this thread

    Top Bottom