MovingPictures causes video freezes and slow menu operation (1 Viewer)

quba54

Portal Member
November 24, 2007
17
0
Warsaw
Poland Poland
I have big movie database and not all movies have complete artwork downloaded (some of them can't be downloaded).

Every time plugin is started there is created background process which scans database and downloads missing artwork : LookForMissingArtwork()

For mine case it takes about 30 minutes to complete scan and over this time I have video freezes.

My HTPC CPU is Athlon x2 2.6G.
Most HTPC computes are much slower!!!

Maybe this thread should be running with lower priority, because with enabled movingpictures plugin mediaportal is NOT usable.
 

RoChess

Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,348
    1,828
    Country flag
    I have big movie database and not all movies have complete artwork downloaded (some of them can't be downloaded).

    Every time plugin is started there is created background process which scans database and downloads missing artwork : LookForMissingArtwork()

    For mine case it takes about 30 minutes to complete scan and over this time I have video freezes.

    My HTPC CPU is Athlon x2 2.6G.
    Most HTPC computes are much slower!!!

    Maybe this thread should be running with lower priority, because with enabled movingpictures plugin mediaportal is NOT usable.
    My HTPC is equipped with an AMD BE-2400 which runs at 2.3Ghz, so slower then yours, and never did I experience any video freezes, not even on high bitrate 1080p videos with the same background tasks running to look for missing artwork. Of course all the video decoding is done by the $20 HD4530 videocard I use, but even when GPU is not used (it's an UVD2 card, so XviD/DivX is still done by CPU, unlike the HD6000 series which also decodes it), and I fire up an 8000Kbps encoded XviD file did it had no problem keeping up with background processes going.

    So you might want to look at all the other processes you have going on in the background, and tweak things a bit more.

    Another way is to help the community at large is to find out which of the artwork is missing, then google/bing/etc search a nice cover and upload this to TheMovieDb.org website. Those will then automatically be downloaded by your HTPC next time, and improve the experience for everybody. If however you have some media files that don't belong on TheMovieDb, then you can manually add them to MovingPictures via the Movie Manager tab.

    I did the same myself for my own library, but my reasons weren't because my computer froze during playback, but because I look in the log files a lot to help with testing and I didn't like all the errors in there, so I finally took the time to correct them.

    Also your codec settings in MediaPortal otherwise, MPC-HC for example has much improved stand-alone filters available, but if you do not update your system to use them then you will not benefit, and are more then likely using the older versions bundled with MediaPortal. You can also tweak the codecs via a DirectShow Filter Manager to make them run faster. That is of course if the problem relates to that, because you can also have some anti-virus scanner running in the background causing the delays, etc.
     

    quba54

    Portal Member
    November 24, 2007
    17
    0
    Warsaw
    Poland Poland
    I check it under debuger. When I remove LookForMissingArtwork() call there are no freezes on video.
    I don't have antivirus scanner.
    I use HD4550 to decode video.
    CPU utilization is about 60% when this process is running.
     

    mareks99

    Portal Member
    April 6, 2010
    20
    0
    Poland Poland
    I think you found about the problem i didn't know what was the cause..
    Have the same problem, after playing movie for few minutes CPU usege s huge an i have video freezes.
    What logs did you check to find out about it?

    BTW could it be a problem with FILMWEB scraper?
     

    quba54

    Portal Member
    November 24, 2007
    17
    0
    Warsaw
    Poland Poland
    I run plugin under debugger and check working threads.
    I think filmweb scraper is responsible for this.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,348
    1,828
    Country flag
    Scraper scripts have access to a wide range of methods that they can use. So if a scraper developer decides he needs to count from 1 to a billion, then this is possible, but will indeed put a lot of stress on your system to do that as a background process.

    I'll have a look this weekend at the scraper script, see if I can find something obvious, unless the scraper script creator has time before then.
     

    mateuszsz

    New Member
    February 13, 2012
    1
    0
    Poland Poland
    Hi!
    I've got the same problem. If MovingPictures is enabled, MP working very slow and causes freezes. I tested on small 35 movies library and bigger - 150 movies.
    Is there any solution for this?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M MovingPictures: Hang at retrieving details (connection fails) ? Moving Pictures 23
    K Genres in MovingPictures not show ... Fanart Handler 12
    S MovingPictures: Library View oder Thumbsview anpassen ? Plugins & Erweiterungen 14
    BlueMax1916 Tool: MPTVSeries and MovingPictures to MP2 General 0
    krebbi [Rejected] MovingPictures alike Feature Requests 25
    1gkar [solved] LiveTV Records Causing 100% Drive Activity Television (MyTV frontend and TV-Server) 10
    RoChess Weird GPU crash -- possible cause: resizing media MediaPortal 1 Talk 8
    Rob Hexenmeister DVD Skip steps causing crash General Support 2
    D Skip to end/live during dvbip recording causes it to stop playing instead. General Support 15
    G limit upscaling, due to 4k causing audio glitches General Support 4
    A cursor.wav or click.wav set in keyboard and keys cause recordings to be set in upcoming episodes 1.20 2
    B Changing to Full HD causes crash of Video Driver General Support 13
    N [not reproducible] Online videos not working at all Submit: Bug Reports 1
    R Bug: Video Folders disappear General Support 11
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    B some music videos stutter Watch / Listen Media 0
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    Rob Hexenmeister Skinning Online Videos question OnlineVideos 2
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    O 1.25.0 Codecs and Video Format for PlayStation 2 Codecs, External Players 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    I Video Playback Stuttering General Support 45
    B some videos jerky Television (MyTV frontend and TV-Server) 0
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    Similar threads

























    Top Bottom