MP Hangs on Alt+TAB

Discussion in '1.1.x and SVN Builds' started by argd, July 25, 2011.

  1. argd

    argd Portal Member

    Joined:
    August 17, 2010
    Messages:
    90
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Russian Federation Russian Federation
    MediaPortal Version: v1.1.3.0
    MediaPortal Skin: Blue3
    Windows Version: Windows XP ( Service Pack 3 ) [5.1.2600.196608]
    CPU Type: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
    HDD: ST3160815AS
    Memory: DDR2 2048Mb
    Motherboard: GA-M55plus-S3G v1
    Video Card: ATI HD 4670 (1024 Мб)
    Video Card Driver: 6.14.10.7028 - ATI Catalyst 9.0
    Sound Card: integrated
    Sound Card Driver: Realtek HD Audio 5.10.0.5497
    1. TV Card: none
    Remote: Microsoft MCE
    TV: BBK LCD
    TV - HTPC Connection: VGA

    Preface:
    This report opened as advised in thread: https://forum.team-mediaportal.com/general-support-51/watchdog-default-action-98571/
    The problem exist since I installed MP more than a year ago, so still the same across versions and seems not related to specific plugin etc, but maybe I'm wrong.

    General setup description
    I'm still too lazy to setup a separate box for MP, so use it on home PC. PC user is non-administrative (kids on board, yeah), but as soon as I found no way to set buffering percentage for OnlineVideos for non-admins, I'm using "runas administrator" for the MP. It starts on a 2nd monitor (TV) with a tab on taskbar. To switch back to MP when needed, I set ALT+TAB key sequence for GREEN button of Microsoft MCE remote (using IR suite translator).

    So, The problem.
    Very often, when I'm switching back to MP window, not obviously with remote, but even by pressing Alt+TAB on keyboard,
    MP becomes unresponsive. If watchdog is active, it is possible to switch to and collect support info, MP comes back to life then.
    If watchdog is inactive, there is no way to manage MP anymore until MP process killed.

    Similar issues.
    https://forum.team-mediaportal.com/general-support-51/controls-stop-responding-lost-focus-58825/
    this workaround ("always on-top") is surely solves the problem, but this is not a solution for me, for sure - PC should be available for parallel users' tasks.



    https://forum.team-mediaportal.com/general-support-51/mce-remote-stops-functioning-52643/#post361641
    this last post in thread actually describes the same workaround i'm currently using.

    https://forum.team-mediaportal.com/...al-keeps-loosing-remote-control-access-97415/
    Issue looks similar.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mm1352000
    • Team MediaPortal

    mm1352000 Development Group

    Joined:
    September 1, 2008
    Messages:
    21,518
    Likes Received:
    4,730
    Ratings:
    +8,196 / 17
    Home Country:
    New Zealand New Zealand
    Hmm

    This is certainly unusual. I also use MP *a lot* in windowed mode with "always on top" disabled because my computer is used for other things. I'm unable to reproduce what you are experiencing. Even when I use EventGhost with a key mapping to start MP, MP detects that it is already running and does not open additional instances (or freeze etc...). Alt+tab does not cause any bad side effects either. I'm using almost the latest SVN version...

    mm
     
  4. argd

    argd Portal Member

    Joined:
    August 17, 2010
    Messages:
    90
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Russian Federation Russian Federation
    mm1352000, thank you for your comment anyway.
    This is not a new problem, I'm facing it long ago and believe, the problem is somewhere between running MP with another credentials and IR mappings.
    Actually, as I referred above, just unattended watchdog option would be a great workaround for me.
     
  5. argd

    argd Portal Member

    Joined:
    August 17, 2010
    Messages:
    90
    Likes Received:
    1
    Ratings:
    +1 / 0
    Home Country:
    Russian Federation Russian Federation
    bump? any idea please?
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!