MP locks up when watching videos. VMR related. (1 Viewer)

imported_ASiDiE

Portal Member
December 2, 2005
11
0
44
Windows Version: Windows XP SP2
CPU Type: Athlon XP +2800
Memory: 512 MB DDR
Motherboard: Biostar M7VIG 400
Motherboard Chipset: VIA
Motherboard Bios: Latest
Video Card: Nvidia FX5200
Video Card Driver: 84.12 - Latest
Sound Card: Onboard
Sound Card AC3: NA
Sound Card Driver: NA
1. TV Card: PVR-500
1. TV Card Type: Analog
1. TV Card Driver: 2.0.35.23348
2. TV Card: Skystar 2
2. TV Card Type: DVB
2. TV Card Driver: 4.3.2.9999
Video Codec: NVIDIA Pure Video
Audio Codec: Nvidia Pure audio
Satelite/CableTV Provider: Comcast/dishnetwork
HTPC Case: NA
Power Supply: Silenx
Remote: Rs 2117
TV: 21 Inch CRT
TV - HTPC Connection: S-video

I am running RC4 with 6-15-06 SVN file.

This issue has been plaguing me for the longest time. I will be watching a video and all the sudden the video will just STOP. The audio will keep going for another 2 seconds and then stop also. At this point I try to see if I can get it out of it's lockup. I try to Jump ahead, stop, pause... anything to try to get it out of this lockup. Usually the OSD will come up when I try to skip and then it really locks up. I can't do anything. At this point I need to do a ctrl-alt-del. When I do this sometimes the sound starts to play for the video I was watching but I never get the video back.

At this point I kill MP and start it up again. I can go right back in and watch the same video I was just watching and it will not lock up at the same place. I have had this happen to the same video several times in different places.

Here is the LINE that it always locks up on:

1 VMR9Helper: playing->repaint 0

I have a TON of logs for this issue.

HERE
HERE

I thought I had more logs, but I guess I set them to expire within 30 days or something. I will post more as they come in.

HERE is my post over at the MP forums. There are others that are getting this issue.

I will do anything it takes to get this issue solved. If anyone has any further questions, please find me in IRC or post here.
 

imported_ASiDiE

Portal Member
December 2, 2005
11
0
44
Sorry about that... Here are the logs posted again... The first logs that I posted do come up... they just seem to take along time. I cut and pasted them again so these have new links

My logs are HERE and HERE

Here is my test log... thingy.
 

infinite.loop

Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    asidie there are NO MediaPortal logs in your zip file!

    read and follow HowTo: report SVN bugs

    no issues with mpeg2, divx, xvid, mpeg1, mjpeg ect. movies here.

    if you encounter issues always:
    1. clean MediaPortal install no configuration done
    2. apply latest svn-snapshot
    3. execute start.bat
    4. restart the PC
    5. configure MP
    6. use MPV and MPA for testing
    7. start TestTool -> step1
    8. start MediaPortal
    9. after you encountered the issue close MediaPortal
    10. TestTool -> step2 export all logs
    11. post issue
     

    imported_ASiDiE

    Portal Member
    December 2, 2005
    11
    0
    44
    Windows Version: Windows XP SP2
    CPU Type: Athlon XP +2800
    Memory: 512 MB DDR
    Motherboard: Biostar M7VIG 400
    Motherboard Chipset: VIA
    Motherboard Bios: Latest
    Video Card: Nvidia FX5200
    Video Card Driver: 84.12 - Latest
    Sound Card: Onboard
    Sound Card AC3: NA
    Sound Card Driver: NA
    1. TV Card: PVR-500
    1. TV Card Type: Analog
    1. TV Card Driver: 2.0.35.23348
    2. TV Card: Skystar 2
    2. TV Card Type: DVB
    2. TV Card Driver: 4.3.2.9999
    Video Codec: NVIDIA Pure Video
    Audio Codec: Nvidia Pure audio
    Satelite/CableTV Provider: Comcast/dishnetwork
    HTPC Case: NA
    Power Supply: Silenx
    Remote: Rs 2117
    TV: 21 Inch CRT
    TV - HTPC Connection: S-video

    Using SVN 6-20-06

    This happened again when my wife and her friend were watching a movie. The only thing I had different then what i-loop said is that I was using nvidia codec for video and sound., I will change this back to defaults (MPV and MPA).

    In the Mediaportal.log you will see that it stopped here:

    6/20/2006 6:49:09 PM 1 VMR9Helper: playing->repaint 0
    6/20/2006 6:49:30 PM seekabs:826.0868772

    She tried to seek ahead, but it didn't work.

    I did not remove the logs this time (step 1) so they should be included.
     

    FlipGer

    Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    44
    Leipzig, Germany
    Germany Germany
    Hi,

    öhm. Did you ever look into your error.log? 4MB! Full of exceptions. No wonder that MP locks up.

    Does the log always look like this? Or is it just this example....

    Flip.
     

    FlipGer

    Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    44
    Leipzig, Germany
    Germany Germany
    Hi,

    please use BlueTwo skin. Project Mayhem 3 is not supported for SVN. Only BlueTwo and mostly MCE is maintained for SVN.

    Flip.
     

    FlipGer

    Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    44
    Leipzig, Germany
    Germany Germany
    Hi,

    it also looks like you are starting in windowed and then switching to fullscreen. Does the lockup also occur when you stay either in windowed or fullscreen right from the beginning?

    Flip.
     

    infinite.loop

    Retired Team Member
  • Premium Supporter
  • December 26, 2004
    16,163
    4,133
    127.0.0.1
    Austria Austria
    ASiDiE said:
    I did not remove the logs this time (step 1) so they should be included.
    please follow the advice i have posted before!

    you run Step1 BEFORE the test to delete all OLD logs.
    you run Step2 AFTER the test so there are NEW logs to export.

    is this a clean MediaPortal installation or have you allready applied multiple SVN-Snapshots?

    and like Flipger said use a skin that comes with the release version of MediaPortal. Best would be with Blue2.
    And always use MPV and MPA do be sure that it is not a 3rd party codec issue.
     

    imported_ASiDiE

    Portal Member
    December 2, 2005
    11
    0
    44
    It is a very clean install of 6-20-06. I copy over my backup of RC4 and then load the SVN file. I run the statup.bat and then go through the wizard. I then run setup again and change anything I missed. I will make sure I have everything removed and post the new logs using MPV and MPA.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Dark Eyes TVService locks up or fails to restart on resuming from sleep, and crashes when grabbing EPG Installation, configuration support 7
    C Attempt to play DVD locks up MediaPortal watch/edit Videos 0
    HTPCSourcer [Approved] Nikki Locke as SuperUser Suggestions for new Team Members 2
    morpheus_xx [Finished] Debugging dead locks in UPnP library MediaPortal 2 1
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    SpudR Forum Duplicate lines in 'Watched' Website/Forum/Wiki Feedback 2
    TLD Can not watch tv from remote clients Television (MyTV frontend and TV-Server) 19
    R Visual status of watched TV programs MediaPortal 1 Talk 2
    M How to Watch my videos from my Media Portal to My TV without TV Tuner Newcomers Forum 1
    limpwhizkid 1.22.0 Stutter and or artifact problem when recording and watching the same live tv channel 1.22 2
    K sudden complication watching recorded TV Newcomers Forum 6
    R [solved] Watching a record during recording stops sometimes 2.2 Archive 30
    Scheibes Automatischer Serienimport fehlerhaft (Share Watch) Allgemeines Support- und Diskussionsforum 18
    doskabouter Black screen while watching some iptv streams General Support 2
    A Flag Mover: backup and restore watched flags Plugin Development 33
    zunixnuz TV recording is watched state 1.20 2
    A Plugin to transfer watched states between two MP2 installations Archive 47
    CyberSimian MP 1.20: Watched percent sometimes incorrect MediaPortal 1 47
    M partially watched video/song/recorded tv show file text color + remember cursor in folders other features (of release or svn versions) 28
    Alberto83 [no Bug] Watched status not retained when rewatching an episode and stopping. Archive 49
    doskabouter Notification mail for new posts on watched threads Website/Forum/Wiki Feedback 5
    M Recorded TV - Watched status is not updated 1.20 Pre Release 11
    N Can't Watch DVB-T2 Channels General Support 44
    mp2-ulrich [solved] MP2 W10 watching tv not possible General 3
    P Multiple clients - share resume/watched data General 1
    Similar threads

























    Top Bottom