My Videos - DVD Navigation issues..... (1 Viewer)

Taipan

Retired Team Member
  • Premium Supporter
  • February 23, 2005
    2,075
    44
    Melbourne
    Australia Australia
    Country flag
    Windows Version: XP Professional, SP2
    CPU Type: AMD 2700+
    Memory: 512 MB
    Motherboard: Gigabyte 7VM400M-RZ
    Motherboard Chipset: VIA KM400
    Motherboard Bios: Award, F5
    Video Card: ATI Radeon 9550
    Video Card Driver: 6.2
    Sound Card: VIA VT1617
    Sound Card AC3: no AC3
    Sound Card Driver: 6.14.1.4100
    1. TV Card: Dvico FusionHDTV DVB-T
    1. TV Card Type: DVB-T
    1. TV Card Driver: 3.30.01
    2. TV Card: DNTVLive! LP
    2. TV Card Type: DVB-T
    2. TV Card Driver: 2.0.0.4
    Video Codec: various - see below
    Audio Codec: various - see below
    Satelite/CableTV Provider: n/a
    HTPC Case: Custom built
    Power Supply: 200W, custom modified
    Remote: MCE 2005 (EU version)
    TV: BENQ DLP Projector
    TV - HTPC Connection: Sub-D


    Playing a DVD and navigating the menu varies significantly, depending upon which video decoders are used and which Navigator is used. None of the ones that I have tried work correctly. Here is a summary of the tests that I have done - in each case I have the option "Don't Autoplay, never ask" set and I have used the same DVD for each test:-

    1. Using the MPE2Dec Video Decoder, DVD Navigator & MPEG/AC3/DTS/LPCM Audio Decoder

    Navigation works OK, but the response of the cursor to remote inputs is very slow - typically 1 -> 1.5 seconds.

    Here's the relevant part of the MediaPortal.log file:-

    24/03/2006 8:19:17 PM DVDPlayer: move down
    24/03/2006 8:19:17 PM planescene: PresentSurface() frame:0 enabled:True allowed:False
    24/03/2006 8:19:17 PM EVT: DvdButtonChange: buttons:#16
    24/03/2006 8:19:17 PM 1 VMR9Helper: repaint->playing 1
    24/03/2006 8:19:18 PM 1 VMR9Helper: playing->repaint



    2. Using the DScaler Video Decoder, DVD Navigator & DScaler Audio Decoder

    Can navigate the root-menu OK (no significant delay) but the cursor position indicator is missing on sub-menus, so it is difficult to know which item has been selected. However, if I carefully count the number of key presses, I can "estimate" which menu item is selected, and it is usually correct! So, navigation works, but the current cursor position is unknown.

    Here's the relevant section of the MediaPortal.log file - which looks exactly the same as in point 1. above:-

    24/03/2006 8:10:00 PM DVDPlayer: move down
    24/03/2006 8:10:00 PM planescene: PresentSurface() frame:0 enabled:True allowed:False
    24/03/2006 8:10:00 PM EVT: DvdButtonChange: buttons:#16
    24/03/2006 8:10:00 PM 1 VMR9Helper: repaint->playing 1
    24/03/2006 8:10:01 PM 1 VMR9Helper: playing->repaint



    3. Using the NVIDIA PureVideo Video Decoder, DVD Navigator & NVIDIA Audio Decoder

    Same result as point 2. above.

    4. Using the NVIDIA PureVideo Video Decoder, NVIDIA Navigator & NVIDIA Audio Decoder

    Pressing "Play DVD" brings up a dialogue box with the message

    Unable to play Disc
    Did you insert a Disc?
    OK​
    Here is the section of the MediaPortal.log file:-

    24/03/2006 7:56:26 PM DVD:enable dx9 exclusive mode
    24/03/2006 7:56:26 PM goto fullscreen:True
    24/03/2006 7:56:26 PM app:confused:witch to fullscreen mode False
    24/03/2006 7:56:26 PM app:confused:witched to fullscreen mode
    24/03/2006 7:56:26 PM 1 vmr9:ctor()
    24/03/2006 7:56:26 PM 1 vmr9:ctor() done:True
    24/03/2006 7:56:26 PM 1 vmr9:addvmr9
    24/03/2006 7:56:26 PM VMR9: now active
    24/03/2006 7:56:26 PM 1 VMR9Helper:Vmr9 Added
    24/03/2006 7:56:26 PM DVDPlayer9:Add NVIDIA Navigator
    24/03/2006 7:56:26 PM add filter:NVIDIA Navigator to graph
    24/03/2006 7:56:26 PM added filter:NVIDIA Navigator to graph
    24/03/2006 7:56:26 PM add filter:NVIDIA Video Decoder to graph
    24/03/2006 7:56:26 PM added filter:NVIDIA Video Decoder to graph
    24/03/2006 7:56:26 PM add filter:NVIDIA Audio Decoder to graph
    24/03/2006 7:56:26 PM added filter:NVIDIA Audio Decoder to graph
    24/03/2006 7:56:26 PM add filter: Default DirectSound Device to graph clock: Default DirectSound Device
    24/03/2006 7:56:26 PM added filter: Default DirectSound Device to graph
    24/03/2006 7:56:26 PM got pins
    24/03/2006 7:56:26 PM got pin#0:Audio
    24/03/2006 7:56:26 PM render ok
    24/03/2006 7:56:26 PM got pin#1:Video
    24/03/2006 7:56:26 PM planescene: PresentImage()
    24/03/2006 7:56:26 PM PlaneScene: PresentImage() dispose surfaces
    24/03/2006 7:56:26 PM planescene: PresentImage()
    24/03/2006 7:56:26 PM PlaneScene: PresentImage() dispose surfaces
    24/03/2006 7:56:26 PM render ok
    24/03/2006 7:56:26 PM got pin#2:confused:ubpicture
    24/03/2006 7:56:26 PM render ok
    24/03/2006 7:56:26 PM Dvdplayer9:disable line 21
    24/03/2006 7:56:26 PM Dvdplayer9:graph created
    24/03/2006 7:56:26 PM SetDefaultLanguages
    24/03/2006 7:56:26 PM DVDPlayer:confused:et default language:English 1033 Success.
    24/03/2006 7:56:26 PM DVDPlayer:confused:et default menu language:English 1033 Success.
    24/03/2006 7:56:26 PM DVDPlayer:confused:et subtitle language:English 1033 Success.

    24/03/2006 7:56:26 PM DVDPlayer:Unable to start playing() 0x:80004005
    24/03/2006 7:56:26 PM DVDPlayer9:cleanup DShow graph
    24/03/2006 7:56:26 PM 1 vmr9: Dispose
    24/03/2006 7:56:26 PM VMR9: not active
    24/03/2006 7:56:26 PM planescene: PresentImage()
    24/03/2006 7:56:26 PM PlaneScene: PresentImage() dispose surfaces
    24/03/2006 7:56:26 PM planescene: PresentImage()
    24/03/2006 7:56:26 PM PlaneScene: PresentImage() dispose surfaces
    24/03/2006 7:56:26 PM DVD:disable dx9 exclusive mode
    24/03/2006 7:56:26 PM goto windowed:False
    24/03/2006 7:56:26 PM app:confused:witch to windowed mode False
    24/03/2006 7:56:27 PM app:confused:witched to windowed mode
    24/03/2006 7:56:27 PM g_Player.PlayDVD():failed to play
    24/03/2006 7:56:27 PM dvdplayer:bla
    24/03/2006 7:56:27 PM dvdplayer:sendmsg
    24/03/2006 7:56:27 PM window:MediaPortal.Dialogs.GUIDialogOK init
    24/03/2006 7:56:30 PM key:13 0xD (2)
    24/03/2006 7:56:33 PM window:MediaPortal.GUI.Video.GUIVideoFiles deinit
    24/03/2006 7:56:33 PM texturemanager:CleanupThumbs()
    24/03/2006 7:56:33 PM Recorder:disable dx9 exclusive mode


    And here is the error.log file:-

    24/03/2006 7:56:26 PM DVDPlayer:Unable to start playing() 0x:80004005
    24/03/2006 7:56:27 PM g_Player.PlayDVD():failed to play



    :confused:

    I would be interested to hear if other users have a similar experience....:(
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,342
    1,824
    Country flag
    Have you tried the new core.dll from tourettes yet? If the issue is solved by using that one, please reply, so we can close this issue as well.
     

    Taipan

    Retired Team Member
  • Premium Supporter
  • February 23, 2005
    2,075
    44
    Melbourne
    Australia Australia
    Country flag
    RoChess said:
    Have you tried the new core.dll from tourettes yet? If the issue is solved by using that one, please reply, so we can close this issue as well.
    Yes, I have tried tourettes version from yesterday (CVS is down today) and there is no change for me - all the above symptoms still exist....:(

    I understand that he has done some more mods, so I am eager to try the latest version, as soon as it is available...:)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    hounddog How to get My Films working in MP 1.20 My Films 5
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    O 1.25.0 Codecs and Video Format for PlayStation 2 Codecs, External Players 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    I Video Playback Stuttering General Support 45
    B some videos jerky Television (MyTV frontend and TV-Server) 0
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    T Kurze Tonaussetzter bei Videos und TV Allgemeines Supportforum 1
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    ajs [Proposal] Video embedded cover MediaPortal 1 1
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    H random black screen live tv and videos (amended) General Support 0
    404 [solved] Live TV...video and audio freeze General Support 20
    R kein Ton bei TV, Video, Aufnahme, Musik Allgemeines Support- und Diskussionsforum 0
    U [solved] Dynamic Refresh Rate for 23fps video Watch / Listen Media 1
    J Debug OnlineVideos, How To? OnlineVideos 1
    A MP2.2.2, understanding movies/videos/tv and WTV recordings. General 16
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    H [solved] Video database genres, sort titles and collection thumbnails Newcomers Forum 12
    M How to Watch my videos from my Media Portal to My TV without TV Tuner Newcomers Forum 1
    cbr954rr Issue BOOTSUWRNQ with online videos? Plugin Development 1
    A Working server, no video playback on client General 5
    Megane [Configuration] Be more specific in Video Codec Improvement Suggestions 0
    M Online Video Plugin V.2.32 keine Installtion unter MediaPortal 1.22 ? TV / Streaming 3
    C where is the Online Videos plugin General Support 1
    Similar threads

























    Top Bottom