[fixed] My Videos "Years" view & Thumbnails/ Icons? (1 Viewer)

Wo0zy

Retired Team Member
  • Premium Supporter
  • April 30, 2008
    394
    134
    United Kingdom United Kingdom
    Hi Guys,

    I've been doing a little customisation on my favorite skin recently but I've hit a wall with what I thought was going to be something simple (but then again I'm only starting to get to grips with skinning so that's hardly surprising :)).

    Is there any way to add either a fixed thumbnail/ icon or a custom set of icons to the "Year" database view in MyVideos?

    When in list view if I filter by "year" the missing cover image appears (at least on the skins I've tried) however, if I switch to any other view (Icons, Big Icons, Filmstrip & Coverflow) you just see an emply mask. No missing cover image or anything.

    To make matters worse, my prefered skin doesn't enable item text by default (<renderFocusText> & <renderUnfocusText> both set to no). I've rectified this but it still isn't very nice to look at :).

    What I'd ideally like to do is have the "Years" view support a custom thumbnail folder like "Genre's" does. I would happily put in the work to create a set of calendar based icons for a century or so (sad I know :D). If this requires changes to the main code (guessing it would) then I'd happily accept a single generic calendar icon appearing for all years or even the "missing coverart" icon (this could be modified so it wouldn't look so bad).

    I appreciate that this is a very trivial thing in the grand scheme of things but any thoughts or suggestions would be greatly appreciated.

    Thanks and all the best,

    Mick.
     

    Wo0zy

    Retired Team Member
  • Premium Supporter
  • April 30, 2008
    394
    134
    United Kingdom United Kingdom
    Yes, code needs to be added for those thumbs. Will add this to my to do list.
    Thanks Deda.

    Wish I could help reduce the size of the list rather than keep adding to it.:(

    Cheers,

    Mick.
     

    Wo0zy

    Retired Team Member
  • Premium Supporter
  • April 30, 2008
    394
    134
    United Kingdom United Kingdom
    Hi Deda,

    When you get around to looking at this, can you also check out what's going on with the default "Sort by" option in year view please.

    I have my video view for "years" configured as default

    Selection = year, Layout = List, SortBy = Year

    However, when I go to "Year" view in MP it defaults to "Sort by size".

    Screencaps attached.

    I appreciate that this could be a bug rather than a dev question so if you confirm it, please feel free to move/ split the thread. Just thought I'd post it here as it's kind of continuing the discussion.

    Cheers,

    Mick
     

    Attachments

    Deda

    Lead Dev MP1 Videos
  • Premium Supporter
  • March 18, 2009
    2,423
    2,385
    Zagreb
    Croatia Croatia
    Country flag
    I think you have VS to compile patch. Can you test this and see if Year sort is ok and can you see Years thumbs.

    For Years thumbs, look after start of MP in (MP Config - \Thumbs\Videos\Year) and put there some pics named as year numbers you see in Years view (ie. 2001.jpg...)
     

    Attachments

    Wo0zy

    Retired Team Member
  • Premium Supporter
  • April 30, 2008
    394
    134
    United Kingdom United Kingdom
    I think you have VS to compile patch. Can you test this and see if Year sort is ok and can you see Years thumbs.

    For Years thumbs, look after start of MP in (MP Config - \Thumbs\Videos\Year) and put there some pics named as year numbers you see in Years view (ie. 2001.jpg...)
    Hi Deda,

    I'm speechless and very grateful! How you found time for this I don't know.:D

    Works perfectly! (see attached)

    Now to make the icons look nice :). I'm sure there's better designers than me here but I'll step up with a first attempt.

    Thanks again mate :)

    All the best,

    Mick
     

    Attachments

    Deda

    Lead Dev MP1 Videos
  • Premium Supporter
  • March 18, 2009
    2,423
    2,385
    Zagreb
    Croatia Croatia
    Country flag

    Wo0zy

    Retired Team Member
  • Premium Supporter
  • April 30, 2008
    394
    134
    United Kingdom United Kingdom
    Hi Deda,

    Thanks for explaining but, more importantly, thanks again for fixing.

    Well, I'll put my money where my mouth is :p so, for anyone that's interested, please find attached a set of generic year icons for use with this patch/ post 28089 svn's.

    I've done "1920-2016". Hopefully that's far enough back and a bit future proof but if anyone has a movie prior to 1920 and would like an icon I'm happy to supply :D.

    They're not "flashy" but do the job (at least for me).

    As usual, feel free to move this if it's better else where :).

    All the best,

    Mick
     

    Attachments

    Deda

    Lead Dev MP1 Videos
  • Premium Supporter
  • March 18, 2009
    2,423
    2,385
    Zagreb
    Croatia Croatia
    Country flag
    Thx for icons :). Will see with Dadeo to put them somewhere on more proper place for community download.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    N [not reproducible] Online videos not working at all Submit: Bug Reports 1
    R Bug: Video Folders disappear General Support 11
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    B some music videos stutter Watch / Listen Media 0
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    Rob Hexenmeister Skinning Online Videos question OnlineVideos 2
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    O 1.25.0 Codecs and Video Format for PlayStation 2 Codecs, External Players 0
    g0rsq Info box randomly popping up when watching TV or other video MediaPortal 2 Newcomers Forum 1
    I Video Playback Stuttering General Support 45
    B some videos jerky Television (MyTV frontend and TV-Server) 0
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    T Kurze Tonaussetzter bei Videos und TV Allgemeines Supportforum 1
    mrmojo666 [Tv Server Plugin ]Direct Show Video Control Plugin 0.0.0.1 for Hauppauge PVR cards MediaPortal 1 Plugins 0
    ajs [Proposal] Video embedded cover MediaPortal 1 1
    G [solved] Black Screen on all videos after upgrading to either 1.23 or 1.24 from 1.22 General Support 4
    H random black screen live tv and videos (amended) General Support 0
    404 [solved] Live TV...video and audio freeze General Support 20
    R kein Ton bei TV, Video, Aufnahme, Musik Allgemeines Support- und Diskussionsforum 0
    U [solved] Dynamic Refresh Rate for 23fps video Watch / Listen Media 1
    J Debug OnlineVideos, How To? OnlineVideos 1
    A MP2.2.2, understanding movies/videos/tv and WTV recordings. General 16
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    H [solved] Video database genres, sort titles and collection thumbnails Newcomers Forum 12
    Similar threads

























    Top Bottom