MyPictures creates folder.jpg in every directory (1 Viewer)

civikdude

Portal Pro
March 17, 2005
110
0
U.S.A.
As soon as I navigate to an image folder in MP, a 'folder.jpg' file is created in that directory and remains indefinitely. Is there some way I can turn off this "feature"? I do not want thumbnails created in the same directory as my images, especially if the file is going to remain there.

Steps to recreate:
1. delete the folder.jpg file that may already exist in the image directory (using Windows Explorer)
2. open mediaportal
3. navigate to My Pictures
4. navigate to the image directory above
5. notice the folder.jpg file created (using Windows Explorer)
6. close mediaportal
7. notice the folder.jpg file still exists (using Windows Explorer)

Regards,
Aaron
 

Smirnuff

Portal Pro
December 7, 2004
630
3
United Kingdom
I've made some changes to ensure that the generated folder.jpg gets hidden as per Windows standard but haven't implemented an option for totally disabling the creation of the files, if you feel this is still needed then pls post back.

The changes will not do anything to hide your existing folder.jpg files, easiest way for you to do this will be to open Windows Explorer, right-click on the root of your Picture shares and select Search and search for all folder.jpg and then right-click them all, check Hidden and ...

These changes are available in the current CVS build and later.

Cheers,
Smirnoff.
 

civikdude

Portal Pro
March 17, 2005
110
0
U.S.A.
Smirnoff said:
I've made some changes to ensure that the generated folder.jpg gets hidden as per Windows standard but haven't implemented an option for totally disabling the creation of the files, if you feel this is still needed then pls post back.

Wow, thanks for the quick response and action! However, I would still like to see an option for disabling the creation of the 'folder.jpg', or AT LEAST a cleanup routine that, when leaving the MyPictures module, will delete any created 'folder.jpg' files. Maybe the latter is easier to implement and, in my mind, seems sufficient for now. Otherwise, I would suggest having a checkbox in the MyPictures setup module to "Disable automatic thumbnail creation."

One of my pet peeves with leaving folder.jpg in the pictures folder is that Windows uses this file for its own thumbnail view.

Another reason is that I "Show hidden files and folders". :wink:

Regards,
Aaron
 

thorazine

New Member
January 12, 2006
2
0
I bring back this old thread because I posted some topic but got no replies.
Using latest RC version MP still creates this folder.jpg files in every picture directory. If posible it would be nice to have an option to turn this off. The reason is XP's explorer uses that file as a folder thumbnail when using thumbnail view, but I dont think MP's folder.jpg are designed for that, so they look quite bad, specially when MP's folder.jpg dimensions doesnt match XP thumbnails' dimensions, and also this file is not update when MP is not running so it can show wrong thumbnails.

mpthumbs3jm.png
xpthumbs2gg.png


If the feature cant be or should not be turned off I think it should use a different file name for the folder thumbnail or store it with the rest of MP's thumbnails instead of in each visited folder.
 

seven5

Portal Pro
April 23, 2007
72
0
43
This happens for Videos too. When browsing my folders in My Videos, i see the poster of a movie inside it. This is not really appropriate when my Action genre folder has the poster of Black Hawk Down.

I say make it an option across the entire application. Also, not everyone is using windows. My media sits on a linux fileserver, i use os x, and mediaportal sits on a windows box.
 

bhill1980

Portal Member
December 27, 2007
6
1
Vancouver
Home Country
Canada Canada
I am ressurecting this thread... I have 2 requests.

1) Have the option to disable the creation of "folder.jpg" in the My Pictures. This is annoying because it is not hidden and when doing a slide show it is displayed. Either that or have an option to ignore "folder.jpg" during a slide show.

2) Have the slide show use images from all folders & sub-folders. Everytime I connect my camera to my Media PC it automatically downloads the images into a new folder for the date the pictures were taken. So in my pictures folder I have many sub-folders with names like "11-21-2007". When I play the current slide show it only uses images from the first folder, or from the current folder I'm in.
 

rekenaar

Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    Home Country
    South Africa South Africa
    Point number 2: Just use the R.Slideshow button. It stands for Recursive Slideshow. All subdirectories should then be processed.
     

    bhill1980

    Portal Member
    December 27, 2007
    6
    1
    Vancouver
    Home Country
    Canada Canada
    Point number 2: Just use the R.Slideshow button. It stands for Recursive Slideshow. All subdirectories should then be processed.

    Thanks for the tip. I always thought that R. Slideshow stood for reverse slideshow.

    The problem with the "folder.jpg" still exists though.
     

    rekenaar

    Retired Team Member
  • Premium Supporter
  • December 17, 2006
    4,421
    805
    Home Country
    South Africa South Africa
    Yes, it is quite annoying to manually make the folder.jpg hidden everytime a new directory is created. I am not aware of a current workaround method. Anyone else?
     

    Users who are viewing this thread

    Top Bottom