New install troubles. (1 Viewer)

7andy

Portal Member
March 13, 2006
6
0
Well, I think the App installer has some way to go yet!

I set up a brand new install of XP Pro, installed all the latest M$ stuff, and made sure all the requirements were met. Installation was a breeze - everything works - except the TV section. I have a Leadtek DTV1000 T DVB-T card installed, and the bundled PVR App works fine. I can get live TV from the configuration App's Channel Preview. But can I get MP to show TV? Can I heck as like!!!
Everything I try results in the same error: "Unable to play live1-0.ts.tsbuffer/Audio codec:"
Being somewhat used to PCs (Network Manager with 15 yrs experience) I have tried most things that come to mind. Mind you, using the term 'codec' at one point and then interchanging it with 'decoder' at another doesn't help. I'm fairly sure they are the same thing...

Tried doing a search of the Forums. One significant result - in German, which I don't speak... Web translation didn't help much, I suspect a number of vernacular terms were being used!

I don't expect things to work 'out of the box' (been around far too long for that!), but I would have expected MP to at least got off the ground...

I also have tons of pre-recorded TV show (courtesy of WebScheduler - great App) which won't play - MP complains about both video and audio codecs! They all play just fine in M$ MP11.

Don't know where to go from here, unless someone has some suggestions...

Cheers, 7&Y

Log from latest attempt:

2009-05-10 17:41:08.625000 [PowerEventThread]: TV service PowerEventThread 49361
2009-05-10 17:41:08.625000 [PowerEventThread]: TV service PowerEventThread 49361
2009-05-10 17:42:30.671875 [PowerEventThread]: TV service PowerEventThread 537
2009-05-10 17:42:30.671875 [PowerEventThread]: TV service PowerEventThread 537
2009-05-10 17:44:01.062500 [11]: Controller: StartTimeShifting Dave 61
2009-05-10 17:44:01.062500 [11]: Controller: find free card for channel Dave
2009-05-10 17:44:01.062500 [11]: Controller: got 1 tuning details for Dave
2009-05-10 17:44:01.062500 [11]: Controller: channel #1 DVBT:tv:UKTV Dave Freq:642000 ONID:9018 TSID:20480 SID:22272 PMT:0x2C0 FTA:True LCN:19 BandWidth:8
2009-05-10 17:44:01.062500 [11]: Controller: card:1 type:DvbT is available priority:2 #users:0 same transponder:False
2009-05-10 17:44:01.062500 [11]: Controller: card:2 type:RadioWebStream cannot tune to channel
2009-05-10 17:44:01.062500 [11]: Controller: found 1 available
2009-05-10 17:44:01.062500 [11]: card: CardTune 1 Dave media:1:-1
2009-05-10 17:44:01.062500 [11]: card: Tune 1 to Dave
2009-05-10 17:44:01.078125 [11]: card: user: media:1:-1 tune DVBT:tv:UKTV Dave Freq:642000 ONID:9018 TSID:20480 SID:22272 PMT:0x2C0 FTA:True LCN:19 BandWidth:8
2009-05-10 17:44:01.078125 [11]: dvbt: Tune:DVBT:tv:UKTV Dave Freq:642000 ONID:9018 TSID:20480 SID:22272 PMT:0x2C0 FTA:True LCN:19 BandWidth:8
2009-05-10 17:44:01.078125 [11]: dvbt: tune: Assigning oldChannel
2009-05-10 17:44:01.078125 [11]: dvbt: tune: Current channel is null
2009-05-10 17:44:01.078125 [11]: dvbt: tune: Graph is tunning
2009-05-10 17:44:01.078125 [11]: dvbt: tune: Getting default locator
2009-05-10 17:44:01.093750 [11]: dvbt: tune: Putting bandwidth 8
2009-05-10 17:44:01.093750 [11]: dvbt: tune: put_ONID 9018
2009-05-10 17:44:01.093750 [11]: dvbt: tune: put_SID 22272
2009-05-10 17:44:01.093750 [11]: dvbt: tune: put_TSID 20480
2009-05-10 17:44:01.093750 [11]: dvbt: tune: Carrier frequency 642000
2009-05-10 17:44:01.093750 [11]: dvbt: tune: put_Locator
2009-05-10 17:44:01.093750 [11]: dvbt: tune: Submitting tune request: SubId -1, channel DVBT:tv:UKTV Dave Freq:642000 ONID:9018 TSID:20480 SID:22272 PMT:0x2C0 FTA:True LCN:19 BandWidth:8
2009-05-10 17:44:01.093750 [11]: dvbt: tune: Submitting tune request: System.__ComObject
2009-05-10 17:44:01.093750 [11]: dvb:confused:ubmiting tunerequest Channel:Dave subChannel:-1
2009-05-10 17:44:01.093750 [11]: dvb:Getting new subchannel
2009-05-10 17:44:01.093750 [11]: dvb:GetNewSubChannel:0 #0
2009-05-10 17:44:01.093750 [11]: TvDvbChannel ctor new subchIndex:0
2009-05-10 17:44:01.093750 [11]: dvb:confused:ubmit tunerequest size:1 new:0
2009-05-10 17:44:01.093750 [11]: subch:0 OnBeforeTune
2009-05-10 17:44:01.093750 [11]: dvb:confused:ubmit tunerequest calling put_TuneRequest
2009-05-10 17:44:01.343750 [11]: dvb:confused:ubmit tunerequest done calling put_TuneRequest
2009-05-10 17:44:01.343750 [11]: subch:0 OnAfterTune
2009-05-10 17:44:01.343750 [11]: dvbt: tune: Running graph for channel TvLibrary.Implementations.DVB.TvDvbChannel
2009-05-10 17:44:01.359375 [11]: dvbt: tune: SubChannel 0
2009-05-10 17:44:01.359375 [11]: subch:0 OnGraphStart
2009-05-10 17:44:01.359375 [11]: subch:0 Graph already running - skip WaitForPMT
2009-05-10 17:44:01.359375 [11]: dvb: RunGraph
2009-05-10 17:44:01.625000 [11]: dvb: LockedInOnSignal ok
2009-05-10 17:44:01.625000 [11]: subch:0 OnGraphStarted
2009-05-10 17:44:01.625000 [11]: subch:0 SetupPmtGrabber:pid 2C0 sid:5700
2009-05-10 17:44:01.625000 [11]: subch:0 set pmt grabber pmt:2C0 sid:5700
2009-05-10 17:44:01.625000 [11]: WaitForPMT: Waiting for PMT.
2009-05-10 17:44:01.828125 [4]: subch:0 OnPMTReceived() True
2009-05-10 17:44:01.828125 [11]: WaitForPMT: Found PMT after 0.203125 seconds.
2009-05-10 17:44:01.828125 [11]: subch:0 SendPmt:5700 5700 FFFFFFFF 15
2009-05-10 17:44:01.828125 [11]: Decode pmt
2009-05-10 17:44:01.828125 [11]: Set descriptor data with length 3
2009-05-10 17:44:01.828125 [11]: Set descriptor data with length 6
2009-05-10 17:44:01.828125 [11]: PROBLEM : descriptor lengths dont match 3 9
2009-05-10 17:44:01.828125 [11]: Set descriptor data with length 6
2009-05-10 17:44:01.828125 [11]: PROBLEM : descriptor lengths dont match 3 9
2009-05-10 17:44:01.828125 [11]: Set descriptor data with length 10
2009-05-10 17:44:01.828125 [11]: PROBLEM : descriptor lengths dont match 3 13
2009-05-10 17:44:01.828125 [11]: subch:0 SendPMT version:21 len:67 22272
2009-05-10 17:44:01.828125 [11]: subch:0 cam flags:True
2009-05-10 17:44:01.828125 [11]: subch:0 SetMpegPidMapping
2009-05-10 17:44:01.828125 [11]: subch:0 pid:191 pcr
2009-05-10 17:44:01.828125 [11]: subch:0 pid:2C0 pmt
2009-05-10 17:44:01.828125 [11]: subch:0 pid:191 video type:MPEG-2
2009-05-10 17:44:01.828125 [11]: subch:0 map pid:191 video type:MPEG-2
2009-05-10 17:44:01.828125 [11]: subch:0 pid:192 audio lang:eng type:MPEG-2
2009-05-10 17:44:01.828125 [11]: subch:0 map pid:192 audio lang:eng type:MPEG-2
2009-05-10 17:44:01.828125 [11]: subch:0 pid:194 audio lang:eng type:MPEG-2
2009-05-10 17:44:01.843750 [11]: subch:0 pid:193 subtitle type:6
2009-05-10 17:44:01.843750 [11]: subch:0 map pid:193 subtitle type:6
2009-05-10 17:44:01.843750 [11]: subch:0 stop tif
2009-05-10 17:44:01.843750 [11]: WaitForPMT: sending PMT to CAM took 0.015625 seconds.
2009-05-10 17:44:01.843750 [11]: dvbt: tune: Graph running. Returning TvLibrary.Implementations.DVB.TvDvbChannel
2009-05-10 17:44:01.921875 [11]: card: Tuner locked: False
2009-05-10 17:44:01.921875 [11]: **************************************************
2009-05-10 17:44:01.921875 [11]: ***** SIGNAL LEVEL: 0, SIGNAL QUALITY: 0 *****
2009-05-10 17:44:01.921875 [11]: **************************************************
2009-05-10 17:44:01.921875 [11]: card: tuned user: media subchannel: 0
2009-05-10 17:44:01.921875 [11]: user:media add
2009-05-10 17:44:01.921875 [11]: card2:media 1 0
2009-05-10 17:44:01.921875 [11]: Controller: media 1 0
2009-05-10 17:44:01.921875 [11]: control2:media 1 0
2009-05-10 17:44:01.921875 [11]: Controller: delete timeshift files C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live1-0.ts
2009-05-10 17:44:01.921875 [11]: card: StartTimeShifting 1 C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live1-0.ts
2009-05-10 17:44:01.921875 [11]: card: CAM enabled : False
2009-05-10 17:44:01.921875 [11]: subch:0 SetTimeShiftFileName:C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live1-0.ts
2009-05-10 17:44:01.921875 [11]: Set video / audio observer
2009-05-10 17:44:01.921875 [11]: subch:0 SetTimeShiftFileName fill in pids
2009-05-10 17:44:01.937500 [11]: subch:0-0 tswriter StartTimeshifting...
2009-05-10 17:44:01.937500 [11]: card: WaitForTimeShiftFile - waiting _eventAudio & _eventVideo
2009-05-10 17:44:02.015625 [4]: PID seen - type = Video
2009-05-10 17:44:02.015625 [4]: audioVideoEventHandler Video
2009-05-10 17:44:02.093750 [4]: PID seen - type = Audio
2009-05-10 17:44:02.093750 [4]: audioVideoEventHandler Audio
2009-05-10 17:44:02.093750 [11]: card: WaitForTimeShiftFile - video and audio are seen after 0.15625 seconds
2009-05-10 17:44:02.109375 [11]: user:media card:1 sub:0 add stream:C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live1-0.ts.tsbuffer
2009-05-10 17:44:02.109375 [11]: RTSP: add stream stream1.0 file:C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live1-0.ts.tsbuffer
2009-05-10 17:44:02.109375 [11]: Controller: StartTimeShifting started on card:1 to C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live1-0.ts.tsbuffer
2009-05-10 17:44:11.703125 [15]: Controller: StopTimeShifting 1
2009-05-10 17:44:11.718750 [15]: card WinFast DTV1000 T BDA DVB-T Tuner/Demod (Thomson DTT7579): StopTimeShifting user:media sub:0
2009-05-10 17:44:11.718750 [15]: card: StopTimeShifting user:media sub:0
2009-05-10 17:44:11.718750 [15]: card not IDLE - freeing subch: 0
2009-05-10 17:44:11.718750 [15]: subch:0-0 tswriter StopTimeshifting...
2009-05-10 17:44:11.718750 [15]: tvcard:FreeSubChannel: subchannels count 1 subch#0 keep graph=False
2009-05-10 17:44:11.718750 [15]: DVB subch:0 Decompose()
2009-05-10 17:44:11.718750 [15]: FreeSubChannel CA: freeing sub channel : 0
2009-05-10 17:44:11.718750 [15]: tvcard:FreeSubChannel : no subchannels present, stopping graph
2009-05-10 17:44:11.718750 [15]: dvb:confused:topGraph called
2009-05-10 17:44:11.718750 [15]: tvcard:FreeAllSubChannels:
2009-05-10 17:44:11.718750 [15]: dvb:confused:topGraph
2009-05-10 17:44:11.718750 [15]: user:media remove
2009-05-10 17:44:11.718750 [15]: Controller:Timeshifting stopped on card:1
2009-05-10 17:44:11.718750 [15]: RTSP: remove stream stream1.0
2009-05-10 17:48:39.546875 [PowerEventThread]: TV service PowerEventThread 537
2009-05-10 17:48:39.546875 [PowerEventThread]: TV service PowerEventThread 537
2009-05-10 17:50:31.890625 [PowerEventThread]: TV service PowerEventThread 537
2009-05-10 17:50:31.890625 [PowerEventThread]: TV service PowerEventThread 537
2009-05-10 17:57:25.484375 [PowerEventThread]: TV service PowerEventThread 49361
2009-05-10 17:57:25.484375 [PowerEventThread]: TV service PowerEventThread 49361
2009-05-10 17:57:27.156250 [PowerEventThread]: TV service PowerEventThread 537
2009-05-10 17:57:27.156250 [PowerEventThread]: TV service PowerEventThread 537
2009-05-10 17:57:27.171875 [PowerEventThread]: TV service PowerEventThread 537
2009-05-10 17:57:27.171875 [PowerEventThread]: TV service PowerEventThread 537
 

7andy

Portal Member
March 13, 2006
6
0
Uh-oh, talking to myself!

Fixed this. I changed the recording and timeshift file locations to c:\timeshift.

Everything work just fine now...

Mind boggling as to why this should fix it.

7&Y
 

Paranoid Delusion

Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    Home Country
    United Kingdom United Kingdom
    Did you install using admin account or run as admin, the auto creation of the relevant recording\timeshifting folder not appearing did relate to a earlier release of MP on some setups, this was easily solved by using the TVServer config\recording folder, then hit the browse button for both recording and timeshifting folders and then it should have worked (they were not auto created as they should of been on installation).

    Can you let us know if you are using MP1.0.2, because this problem should not exist now.
     

    7andy

    Portal Member
    March 13, 2006
    6
    0
    Installed using 1.0.1
    I'm going to do a completely fresh install in a few days time (messed up something else on the PC...)
    I've downloaded 1.0.2, so I'll be using that.
    Let you know if anything goes wrong...

    7&Y
     

    Users who are viewing this thread

    Similar threads

    this seems to be related to the Ares skin. It can be somewhat fixed by replacing the mytvrecordedtv.xml with the one found in the DefaultWide skin. It really messes up the overlays though.
    this seems to be related to the Ares skin. It can be somewhat fixed by replacing the mytvrecordedtv.xml with the one found in the...
    For the past year or so I have not been able to get into my TV recordings menu. MediaPortal wont crash, but it just hangs and...
    Replies
    1
    Views
    695
    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes 1 to 2 minutes to write the data to disk. To speed up the EPG stuff (not only writing but also reading the EPG guide in MediaPortal), I changed the program table (and only that table) from InnoDB to...
    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes...
    I get a few "Continuity error..." after the EPG scan finished: [2021-01-30 18:56:10,278] [4c45530] [18c8] - mhw reset [2021-01-30...
    Replies
    2
    Views
    1K
    So, for anyone that would like EPG data for radio stations in the US, here's my finished grabber. You'll need to customize it much like what's required for the IMDb US TV grabber. Go to DAR.fm to figure out the "siteId" (a 4 digit number) for each station you'd like guide data for, and modify the www_dar_fm_com.xml file according to...
    So, for anyone that would like EPG data for radio stations in the US, here's my finished grabber. You'll need to customize it much...
    I'm attempting to create a WebEPG grabber for US radio stations using DAR.fm as a source. I don't appear to be getting any errors...
    Replies
    4
    Views
    2K
    Hi Edalex, thanks. Sadly the plugin isn't finished yet. I had some issues at work ad I had to halt the development. Feel free to clone the repository and fix what needs to be fixed, if you want and have time.
    Hi Edalex, thanks. Sadly the plugin isn't finished yet. I had some issues at work ad I had to halt the development. Feel free to...
    Hello there, I'm a long user of Mediaportal but I always managed to fix my problems without having to start new threads. This time...
    Replies
    23
    Views
    5K
    I want to emphasize that I only said it was a possibility. These are the trade-offs of using a custom version.
    I want to emphasize that I only said it was a possibility. These are the trade-offs of using a custom version.
    So now the Sky UK EPG grabber won't work due to changes made by Sky, I figured I'd try to use the Freesat EPG instead, which is...
    Replies
    3
    Views
    3K
    Top Bottom