Non bitperfect audio

grubi

Portal Pro
June 16, 2007
1,216
48
127.0.0.1
I'm not able to get this version to work for bitperfect audio.
If I play back a 44.1 khz DTS file I only hear noise / silence / noise / silence and my amp is constantly switching between DTS and PCM.

The last version which works perfect for me is 1.2.2. Version 1.3.0 was the first one which shows the ugly behavour described. The MP built in BASS player also works without this problem.

Any ideas?

grubi.
 

Helios61

Retired Team Member
  • Premium Supporter
  • January 30, 2008
    4,587
    113
    58
    NRW
    Country flag
    Hi grubi!

    Maybe the problem is the HDMI-Connection! Is it possible to try S/PDIF!

    Best regards
    Helios
     

    grubi

    Portal Pro
    June 16, 2007
    1,216
    48
    127.0.0.1
    Hi grubi!

    Maybe the problem is the HDMI-Connection! Is it possible to try S/PDIF!

    Best regards
    Helios
    Thank's for your reply.
    I'm already using S/PDIF and not HDMI. As said previously simply switching back to 1.2.2. solves the problem.

    grubi.
     

    Arn01805

    Portal Pro
    July 31, 2006
    206
    18
    Breda
    Hi there,

    I want to let you guys know that I have the same behaviour. I remember I had pureaudio installed when it was first released and the first few versions worked fantastic for my DTS collection of flac files. The first version where gapeless playback was introduced worked like a charm and used this for a long time.

    Now I recently reïnstalled everything with MP1 and newest plugins (both pureAudio newest, ASIO4ALL newest, realtek drivers newest) and all I get is noise.. gggggghhhhhk ggggggggghhhhhkkkkk (on DTS; (L)PCM works)

    I tried older versions of realtek driver and asio4all but this doesn't solve the problem. I wanted to try the very old pureAudio plugin, but can't find it anywhere anymore.

    Grubi, can you send me the old pureAudio plugin to test/use? Does the old plugin work on MP1 final?

    My specs:

    ASUS P5N32 SLI Motherboard
    onboard Realtek HD-Audio with SPDIF (both optical and philips/sony interface) ACL850

    Even when not using ASIO and with directsound all I get is noise. I would like to be able to play my DTS flacs again soon. It doesn't have to be bitperfect and super high sample rates, my receiver only supports 44,1 and 48 in 16 or 24 bits; codings (L)PCM, DD and DTS; so it would be nice to get it working in 48KHz/24bit!

    My card supports higher sample rates, but for me it's useless coz my amp doesn't support this.

    I hope to get this up and running soon again.
     

    grubi

    Portal Pro
    June 16, 2007
    1,216
    48
    127.0.0.1
    Hi there,

    I want to let you guys know that I have the same behaviour. I remember I had pureaudio installed when it was first released and the first few versions worked fantastic for my DTS collection of flac files. The first version where gapeless playback was introduced worked like a charm and used this for a long time.

    Now I recently reïnstalled everything with MP1 and newest plugins (both pureAudio newest, ASIO4ALL newest, realtek drivers newest) and all I get is noise.. gggggghhhhhk ggggggggghhhhhkkkkk (on DTS; (L)PCM works)

    I tried older versions of realtek driver and asio4all but this doesn't solve the problem. I wanted to try the very old pureAudio plugin, but can't find it anywhere anymore.

    Grubi, can you send me the old pureAudio plugin to test/use? Does the old plugin work on MP1 final?

    My specs:

    ASUS P5N32 SLI Motherboard
    onboard Realtek HD-Audio with SPDIF (both optical and philips/sony interface) ACL850

    Even when not using ASIO and with directsound all I get is noise. I would like to be able to play my DTS flacs again soon. It doesn't have to be bitperfect and super high sample rates, my receiver only supports 44,1 and 48 in 16 or 24 bits; codings (L)PCM, DD and DTS; so it would be nice to get it working in 48KHz/24bit!

    My card supports higher sample rates, but for me it's useless coz my amp doesn't support this.

    I hope to get this up and running soon again.
    See attachment.
    Please post your results.
     

    Arn01805

    Portal Pro
    July 31, 2006
    206
    18
    Breda
    Well, this time the old version is a no-go too. When selected the ASIO4ALL driver and starting music, I get a popup mediaportal crashed (strange enough, mp is still working and I can call homescreen and exit mp)
    Logs with ASIO on debug-level state the following:

    2008-12-30 19:41:49.655873 [Info.][MPMain]: player:pureAudio. author: Sieds Tilstra
    2008-12-30 19:41:49.657873 [Debug][MPMain]: PureAudio: SupportsFile("\\192.168.123.201\mp3\DTS\K\Katie Melua\Pictures (DTS 5.1)\01 01 - mary pickford.flac") called
    2008-12-30 19:41:49.660873 [Debug][MPMain]: PureAudio: Determined FileType: AudioFile/None
    2008-12-30 19:41:49.662873 [Info.][MPMain]: PlayerFactory: Disabling DX9 exclusive mode
    2008-12-30 19:41:49.662873 [Debug][MPMain]: PlayerFactory: Successfully created player instance for file - \\192.168.123.201\mp3\DTS\K\Katie Melua\Pictures (DTS 5.1)\01 01 - mary pickford.flac
    2008-12-30 19:41:49.670873 [Info.][MPMain]: PureAudio: Initializing player ...
    2008-12-30 19:41:49.675873 [Debug][MPMain]: g_player: Setting ShowFullScreenWindowVideo to MediaPortal.Player.g_Player+ShowFullScreenWindowHandler
    2008-12-30 19:41:49.676873 [Debug][MPMain]: PureAudio: Initializing BASS library...
    2008-12-30 19:41:49.784873 [Info.][MPMain]: PureAudio: Loading audio decoder add-ins from C:\Program Files\Team MediaPortal\MediaPortal\musicplayer\plugins\audio decoders...
    2008-12-30 19:41:49.785873 [Debug][MPMain]: PureAudio: Loading: basscd.dll
    2008-12-30 19:41:49.785873 [Debug][MPMain]: PureAudio: Already loaded: basscd.dll
    2008-12-30 19:41:49.785873 [Debug][MPMain]: PureAudio: Loading: bassflac.dll
    2008-12-30 19:41:49.786873 [Debug][MPMain]: PureAudio: Already loaded: bassflac.dll
    2008-12-30 19:41:49.786873 [Debug][MPMain]: PureAudio: Loading: basswma.dll
    2008-12-30 19:41:49.786873 [Debug][MPMain]: PureAudio: Already loaded: basswma.dll
    2008-12-30 19:41:49.787873 [Debug][MPMain]: PureAudio: Loading: bass_aac.dll
    2008-12-30 19:41:49.787873 [Debug][MPMain]: PureAudio: Already loaded: bass_aac.dll
    2008-12-30 19:41:49.787873 [Debug][MPMain]: PureAudio: Loading: bass_ac3.dll
    2008-12-30 19:41:49.788873 [Debug][MPMain]: PureAudio: Already loaded: bass_ac3.dll
    2008-12-30 19:41:49.788873 [Debug][MPMain]: PureAudio: Loading: bass_alac.dll
    2008-12-30 19:41:49.788873 [Debug][MPMain]: PureAudio: Already loaded: bass_alac.dll
    2008-12-30 19:41:49.789873 [Debug][MPMain]: PureAudio: Loading: bass_ape.dll
    2008-12-30 19:41:49.789873 [Debug][MPMain]: PureAudio: Already loaded: bass_ape.dll
    2008-12-30 19:41:49.789873 [Debug][MPMain]: PureAudio: Loading: bass_mpc.dll
    2008-12-30 19:41:49.790873 [Debug][MPMain]: PureAudio: Already loaded: bass_mpc.dll
    2008-12-30 19:41:49.790873 [Debug][MPMain]: PureAudio: Loading: bass_wv.dll
    2008-12-30 19:41:49.790873 [Debug][MPMain]: PureAudio: Already loaded: bass_wv.dll
    2008-12-30 19:41:49.791873 [Info.][MPMain]: PureAudio: No Audio Decoders loaded; probably already loaded.
    2008-12-30 19:41:49.791873 [Info.][MPMain]: PureAudio: Initializing complete.
    2008-12-30 19:41:49.792873 [Debug][MPMain]: PureAudio: Determined FileType: AudioFile/None
    2008-12-30 19:41:49.792873 [Debug][24]: PureAudio: BackGroundPlayer.BackGroundPlayAsync() called...
    2008-12-30 19:41:49.793873 [Info.][MPMain]: g_Player.OnStarted() \\192.168.123.201\mp3\DTS\K\Katie Melua\Pictures (DTS 5.1)\01 01 - mary pickford.flac media:Music
    2008-12-30 19:41:49.794873 [Debug][24]: PureAudio: BackGroundPlayer.BackGroundPlaySync() called...
    2008-12-30 19:41:49.794873 [Debug][24]: PureAudio: Determined FileType: AudioFile/None
    2008-12-30 19:41:49.796873 [Debug][MPMain]: GUITVCropManager.g_Player_PlackBackStarted: media: Music tv:False ts:False
    2008-12-30 19:41:49.796873 [Debug][24]: PureAudio: Using 16 bit streams...
    2008-12-30 19:41:49.800873 [Debug][Scrobbler loader]: Audioscrobbler plugin: Waited 0 seconds for reinit of submit track
    2008-12-30 19:41:49.802873 [Info.][Scrobbler event]: Audioscrobbler plugin: Detected new track as: Katie Melua - Mary Pickford started at: 19:41:49
    2008-12-30 19:41:49.814873 [Info.][Scrobbler event]: Audioscrobbler plugin: Starting song length timer with an interval of 95 seconds
    2008-12-30 19:41:49.824873 [Debug][24]: PureAudio: Stream created for : \\192.168.123.201\mp3\DTS\K\Katie Melua\Pictures (DTS 5.1)\01 01 - mary pickford.flac
    2008-12-30 19:41:49.826873 [Debug][24]: PureAudio: Starting session...
    2008-12-30 19:41:49.826873 [Debug][24]: PureAudio: BackGroundPlayer.ResetSessionState() called...
    2008-12-30 19:41:49.827873 [Debug][24]: PureAudio: Stream info: chans = 2, freq = 44100, origres = 0, ctype = BASS_CTYPE_STREAM_FLAC
    2008-12-30 19:41:49.828873 [Debug][24]: PureAudio: Viz-stream pre-reading offset: 500 ms...
    2008-12-30 19:41:49.828873 [Debug][24]: PureAudio: Playback-stream pre-reading offset: 500 ms...
    2008-12-30 19:41:49.830873 [Debug][24]: PureAudio: Initializing ASIO device: ASIO4ALL v2...
    2008-12-30 19:41:49.837873 [Info.][24]: PureAudio: Using ASIO device ASIO4ALL v2
    2008-12-30 19:41:49.872873 [Debug][24]: PureAudio: ASIO info: name = ASIO4ALL v2, version = 2, outputs = 2, bufmin = 64, bufmax = 2048, bufgran = 8, bufpref = 512, minrate = 44100, maxrate = 192000, latency = 9
    2008-12-30 19:41:49.873873 [Debug][24]: PureAudio: ASIO channel info: Name=Realtek HDA SPDIF Out 1, Group=0, Format=BASS_ASIO_FORMAT_32BIT
    2008-12-30 19:41:49.873873 [Debug][24]: PureAudio: ASIO channel info: Name=Realtek HDA SPDIF Out 2, Group=0, Format=BASS_ASIO_FORMAT_32BIT
    2008-12-30 19:41:49.874873 [Debug][24]: PureAudio: Creating new ringbuffer...
    2008-12-30 19:41:49.876873 [Debug][24]: PureAudio: Creating sinkstream...
    2008-12-30 19:41:49.880873 [Debug][24]: PureAudio: Preparing mixerstream...
    2008-12-30 19:41:49.880873 [Debug][24]: PureAudio: Using 2 channels...
    2008-12-30 19:41:49.880873 [Debug][24]: PureAudio: Creating mixerstream...
    2008-12-30 19:41:49.888873 [Debug][24]: PureAudio: Plugging sinkstream into mixer...
    2008-12-30 19:41:49.889873 [Debug][24]: PureAudio: Mixing Matrix: matrix[0, 0] = 1
    2008-12-30 19:41:49.889873 [Debug][24]: PureAudio: Mixing Matrix: matrix[0, 1] = 0
    2008-12-30 19:41:49.890873 [Debug][24]: PureAudio: Mixing Matrix: matrix[1, 0] = 0
    2008-12-30 19:41:49.890873 [Debug][24]: PureAudio: Mixing Matrix: matrix[1, 1] = 1
    2008-12-30 19:41:49.891873 [Debug][24]: PureAudio: Creating visualization stream...
    2008-12-30 19:41:49.892873 [Debug][24]: PureAudio: Initializing ASIO handler...
    2008-12-30 19:41:49.895873 [Debug][24]: PureAudio: Filling buffer...
    2008-12-30 19:41:49.945873 [Debug][24]: PureAudio: Starting ASIO...
    2008-12-30 19:41:50.800873 [Debug][Scrobbler loader]: Audioscrobbler plugin: Waited 1 seconds for lookup of current track
    2008-12-30 19:41:50.802873 [Info.][Scrobbler loader]: Audioscrobbler plugin: Song loading thread sets submit song - Katie Melua - Pictures
    2008-12-30 19:41:51.813873 [Info.][Scrobbler nowplaying]: AudioscrobblerBase: Announcing current track: a=Katie+Melua&t=Mary+Pickford&b=Pictures&l=190&n=1&m=
    2008-12-30 19:41:51.886873 [Info.][Scrobbler nowplaying]: AudioscrobblerBase: Action successfully completed.
    2008-12-30 19:42:02.301873 [Debug][MPMain]: Window: MediaPortal.GUI.Music.GUIMusicFiles deinit
    2008-12-30 19:42:02.314873 [Info.][MPMain]: TextureManager: Dispose:C:\ProgramData\Team MediaPortal\MediaPortal\Thumbs\Music\Albums\Katie Melua-PicturesL.jpg Frames:1 Total:3 Mem left:1594884
    2008-12-30 19:42:02.315873 [Debug][MPMain]: TextureManager: CleanupThumbs()
    2008-12-30 19:42:02.371873 [Debug][MPMain]: Window: MediaPortal.GUI.Home.GUIHome init
    2008-12-30 19:42:03.583873 [Info.][MPMain]: Main: Exit requested
    2008-12-30 19:42:03.644873 [Info.][MPMain]: Main: Stopping FrameMove
    2008-12-30 19:42:03.646873 [Debug][MPMain]: g_Player.doStop() keepTimeShifting = False keepExclusiveModeOn = False
    2008-12-30 19:42:03.647873 [Info.][MPMain]: g_Player.OnStopped()
    2008-12-30 19:42:03.649873 [Info.][MPMain]: TvRecorded:OnStopped Music \\192.168.123.201\mp3\DTS\K\Katie Melua\Pictures (DTS 5.1)\01 01 - mary pickford.flac
    2008-12-30 19:42:03.650873 [Debug][MPMain]: g_Player.doStop() - stop
    2008-12-30 19:42:03.651873 [Debug][MPMain]: PureAudio: Stop() called...
    2008-12-30 19:42:03.651873 [Debug][24]: PureAudio: BackGroundPlayer.BackGroundStop() called...
    2008-12-30 19:42:03.653873 [Debug][MPMain]: GUIFont:texture disposing:0 debug
    2008-12-30 19:42:03.653873 [Debug][MPMain]: GUIFont:texture disposing:1 font8
    2008-12-30 19:42:03.655873 [Debug][MPMain]: GUIFont:texture disposing:2 font9
    2008-12-30 19:42:03.655873 [Debug][MPMain]: GUIFont:texture disposing:3 font10
    2008-12-30 19:42:03.655873 [Debug][MPMain]: GUIFont:texture disposing:4 font12
    2008-12-30 19:42:03.657873 [Debug][MPMain]: GUIFont:texture disposing:5 font13
    2008-12-30 19:42:03.658873 [Debug][MPMain]: GUIFont:texture disposing:6 font14
    2008-12-30 19:42:03.658873 [Debug][MPMain]: GUIFont:texture disposing:7 font16
    2008-12-30 19:42:03.660873 [Debug][MPMain]: GUIFont:texture disposing:8 font18
    2008-12-30 19:42:03.660873 [Debug][MPMain]: GUIFont:texture disposing:9 dingbats
    2008-12-30 19:42:03.664873 [Debug][MPMain]: GUIFont:texture disposing:10 font32
    2008-12-30 19:42:03.666873 [Debug][MPMain]: GUIFont:texture disposing:11 font48
    2008-12-30 19:42:03.666873 [Debug][MPMain]: GUIFont:texture disposing:12 font72
    2008-12-30 19:42:03.667873 [Debug][MPMain]: GUIFont:texture disposing:13 fontSVT
    2008-12-30 19:42:03.668873 [Info.][MPMain]: TexturePacker: disposing texture:1999
    2008-12-30 19:42:03.668873 [Info.][MPMain]: TexturePacker: disposing texture:1998
    2008-12-30 19:42:03.669873 [Info.][MPMain]: TexturePacker: disposing texture:1997
    2008-12-30 19:42:03.670873 [Info.][MPMain]: TexturePacker: disposing texture:1996
    2008-12-30 19:42:03.672873 [Info.][MPMain]: TexturePacker: disposing texture:1995
    2008-12-30 19:42:03.673873 [Info.][MPMain]: TexturePacker: disposing texture:1994
    2008-12-30 19:42:03.687873 [Debug][MPMain]: PureAudio: BackGroundPlayer.StopThreads() called...


    When selecting Windows device as output and select the digital output of my realtek card, MP doesn't crash but I have the noise sound on my receiver/amplifier again.

    I had good hope... but unfortinatly a no-go this time again.

    I attached The full MP-log; maybe Sieds/Symphy has time to quickly review this one?

    If anyone has this working perfectly with some type of audio card; please advise on what brand/type of card to buy to make this work without any problems. I would love to listen to my DTS tracks again.
     

    Arn01805

    Portal Pro
    July 31, 2006
    206
    18
    Breda
    UPDATE!!

    I was planning to generate a logfile with the most recent 2.0.1b2 version to post here on the forum, so I installed this version again. Unticked all options in de plugin configuration(I never did this before, so disabled gapeless playback and all the other stuff), set the logging level to debug and guess what!!??!!

    It works again. Now I just turn on the settings for gapeless playback again, disabled debug level logging, turned other settings on and off, but now my DTS tracks keep on playing. I can't get it to fail again with whatever setting I do.

    The only thing I can think of is that unticking/ticking checkboxes in the plugin configuration make this plugin work, maybe some setting wasn't saved in the config file before and made this plugin fail on doing a properly job.

    working config for me:
    latest realtek drivers
    asio4all 2.9
    pureaudio 2.0.1b2

    Grubi, can you try to untick every checkbox in plugin config, then save, close mp config (else configuration isn't saved to the xml) then restart mediaportal configuration and set the desired configuration in the plugin again?? I know it sounds strange, but it did the job for me..
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom