NowPlaying bug - not displaying double album cover art (1 Viewer)

BugsBunny

Portal Pro
April 22, 2006
210
24
Tirol
Austria Austria
TV-Server Version:
MediaPortal Version: 0.2.2.0
MediaPortal Skin: BlueTwo wide
Windows Version: XP Pro SP2
CPU Type: Intel Core 2 Duo E6600
HDD: Western Digital Caviar 320GByte
Memory: 2 x 512MB Corsair XMS2 DIMM 1024MB PC2-6400U CL5-5-5-12
Motherboard: ASUS P5B-E
Motherboard Chipset: Intel P965/ICH8R
Motherboard Bios: Asus 1202
Video Card: ASUS EN7600GT/HTDI
Video Card Driver: ForceWare 94.24
Sound Card: ESI Juli@
Sound Card AC3:
Sound Card Driver: v1.18
1. TV Card: FloppyDTV DVB-C/CI
1. TV Card Type: DVB-C
1. TV Card Driver: 4.8 BDA
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec:
MPEG2 Audio Codec:
Satelite/CableTV Provider:
HTPC Case: Zalman HD160
Cooling: Noctua NH-U9F / Noctua NC-U6 / NF-R8
Power Supply: Seasonic SS-301HT
Remote: MCE over IRTrans
TV: Sharp Aquos LC-46 XD1E
TV - HTPC Connection: DVI-HDMI

I use only folder.jpg files for cover art. Each CD I store in a separate folder. For double albums the foldername of the first CD ends with CD1 of the second CD2.
The id3v1 album name tag also ends with CD1/CD2 in this case.
Reported this bug under music here:
https://forum.team-mediaportal.com/showpost.php?p=130354&postcount=3

This bug is there since 0.2.2.0. In 0.2.1.0 this bug did not occur.

Now I had time to investigate the bug and found out under what circumstances the bug occurs. Had a few double CDs where the bug didn't show out. Took a look at the id3 tag of these albums. The album id3 tag didn't end with CD1 but with Disk 1/Disk 2. Then I canged for testing the album id3 tags of a double album that didn't work from "Serenity CD1"/"Serenity CD2" into "Serenity Cd 1"/"Serenity Cd 2" did a rescan of the db and surprise - on now playing the CD cover showed up. Then canged the album id3 tags into "Serenity Cd1"/"Serenity Cd2" rescanned and the cover art still showed up.

Summing up: if the the album id3 tags of double albums end with CD1/CD2 the cover art does not show, when CD is changed into Cd the cover art shows up. The foldername is irrelevant, the bug is only linked to the album id3 tag. This is so very strange but that's the cause. Maybe there is a problem with capital letters in the internal music db.
I really hope this can be fixed - don't want to rename/retag all "CD1"/"CD2" into "Cd1"/"Cd2".
 

BugsBunny

Portal Pro
April 22, 2006
210
24
Tirol
Austria Austria
No one could reproduce this?
Could it be a problem of my tagger?
This problem is very anoying and seems to be present since the thumbs cache was introduced in 0.2.2.0
Started to scan my music archive on where the album art (folder.jpg) is not displayed on else the CD1/CD2 problem.
For the album "Guns N' Roses - Use Your Illusion II" the Album art from "Guns N' Roses - The Spaghetti Incident" get's displayed. Changed the II into 2 and the correct album art got displayed.
Another problem: "Booker T. & The MG's - Green Onions" - no album art in NowPlaying -> Canged the artist into "Booker T. & The Mg's" then the cover got displayed.
I would so really much like to fix this problem, or at least get some answer...
Maybe it is the case, that the music db has got limitations and these things cannot be fixed, else renaming some capital letters in the mp3 tags.
Hope that someone can look into this - I could provide sample files and do testing as well.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

OP Similar threads Forum Replies Date
catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
framug [Approved] Fix Irtrans config bug Submit: code patches (MediaPortal/TV-Server/etc.) 4
ge2301 Bugs and Improvements Nereus 0
N [Finished] Focus problems - I think I've found the bug MediaPortal 2 30
Scheibes [solved] Kategorisierung der Genres (Bug?) Allgemeines Support- und Diskussionsforum 13
joecrow 3 Bugs in MP 1.21 1.21 5
dcapslock TV Server xmltv IWakeupHandler Bug Television (MyTV frontend and TV-Server) 6
rsbrux Various bugs, some Zombies ;-) 1.20 6
J [solved] Mp 2.2 future bugs General 7
S [MP2-768] Installation Setup Failed - Error 0x80070666 - VC++ 2015/2017 Redist bug 2.2 Archive 19
D MP2.2: Possible bugs 2.2 Archive 20
R Jira bug exposed private server keys at major companies Developer Discussions 1
R Minor bug in recorded TV list Watch / Listen Media 0
P MP2 - V2.1 Bug - Onlinevideos U.S. Amazon Prime Fails to Connect Older releases 5
F 1.25.0 Display corruption Bugreports 0
M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
D Display Day of week in TV Guide? Feature Requests 0
CyberSimian [Proposal] Tool to display time of next recording MediaPortal 1 0
X [solved] Display needs to be turned on for TV services to function General 1
M 2nd (Touch-)Display Support on MediaPortal 2 such MPDisplay++? General 2
S Mini Display MP 1.24 no Volume OSD no action for keys Mini Display 0
M [Suche] Display Futaba mdm166a Marktplatz 0
N [fixed] [MP2-822] Folder View is not displaying individual media share elements Submit: Bug Reports 4
HTPCSourcer Special (foreign) characters don't display correctly in EPG MediaPortal 2 4
P Recommendations for Spectrum Analyzer/VU Metre/Graphical EQ for second display General 0
Similar threads

























Top Bottom