OnlineVideos 2.3.1.0 [2017/05/15] | Page 40

Discussion in 'OnlineVideos' started by offbyone, March 26, 2015.

  1. joecrow
    • Team MediaPortal

    joecrow Test Group

    Joined:
    August 9, 2012
    Messages:
    1,482
    Likes Received:
    716
    Ratings:
    +1,198 / 2
    Home Country:
    Germany Germany
    Show System Specs
    Keeping my fingers crossed but ZDF was working for me last night and is still OK this morning.:) All live, except Arte, and catchup content are looking good.
    It would be good to know if someone worked on it and fixed it, there are only broken reports in the "Creater and User Report", rather than some variable or change by ZDF.
    Creator/maintainer please let us know.;)

    For those located outside Germany with my DNS service turned on I cannot get any Live TV in OV,(no URL) but catchup is OK, no problem via Firefox (even Arte).
    This may just be my DNS service, it has been that way for some months, or maybe some form of Geo-blocking, don't know.

    UPDATE;- After re-reading this to clarify it should say....." with my DNS service turned on I cannot get any Live ZDF TV in OV,(no URL)"


     
    Last edited: October 11, 2017
    • Like Like x 1
    • Thank You! Thank You! x 1
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. datfreak
    • Premium Supporter

    datfreak MP Donator

    Joined:
    March 19, 2006
    Messages:
    157
    Likes Received:
    9
    Ratings:
    +10 / 0
    When selecting youtube subscription "Might car mods", i get 'error getting dynamic categories'.
    All my other YT channels work ok, and this chanel did work in previous versions.

    I have tried clean uninstalling and reinstalling OV. Unsubscripting might car mods and re subscriipting.

    I'll get logs soon, but anyone else have this problem on 1 channel?
     
    • Like Like x 1
    • Agree Agree x 1
  4. ms.fox

    ms.fox Portal Member

    Joined:
    October 15, 2017
    Messages:
    9
    Likes Received:
    0
    Gender:
    Male
    Ratings:
    +2 / 0
    Home Country:
    Germany Germany
    MP dumps, if i call "MDR":
    Code (Text):
    1. [2017-12-27 17:32:53,457] [Log    ] [OVLoad   ] [DEBUG] - WindowManager: unroute to MediaPortal.Dialogs.GUIDialogProgress:101->OnlineVideos.MediaPortal1.GUIOnlineVideos:4755
    2. [2017-12-27 17:32:53,488] [Log    ] [OVLoad   ] [DEBUG] - SendThreadCallbackAndWait - Waitone
    3. [2017-12-27 17:32:57,001] [Log    ] [OnlineVideos] [DEBUG] - SendThreadCallbackAndWait - Waitone
    4. [2017-12-27 17:33:00,752] [Error  ] [26       ] [ERROR] - MediaPortal: Unhandled exception occured
    5. [2017-12-27 17:33:00,752] [Log    ] [26       ] [ERROR] - Exception: System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
    6.    bei OnlineVideos.Sites.MdrUtil.<>c__DisplayClass1_0.<DiscoverDynamicCategories>b__1(Object o)
    7.    bei System.Threading.ThreadHelper.ThreadStart_Context(Object state)
    8.    bei System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    9.    bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    10.    bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    11.    bei System.Threading.ThreadHelper.ThreadStart(Object obj)  Message: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.  Site   :   Source : OnlineVideos.Sites.offbyone  Stack Trace:     bei OnlineVideos.Sites.MdrUtil.<>c__DisplayClass1_0.<DiscoverDynamicCategories>b__1(Object o)
    12.    bei System.Threading.ThreadHelper.ThreadStart_Context(Object state)
    13.    bei System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    14.    bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
    15.    bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
    16.    bei System.Threading.ThreadHelper.ThreadStart(Object obj)
    MediaPortal 1.18.0 with OnlineVideos 2.3.1.0
     
  5. wjw

    wjw Portal Pro

    Joined:
    July 13, 2008
    Messages:
    322
    Likes Received:
    20
    Ratings:
    +34 / 0
    Home Country:
    United Kingdom United Kingdom
    Is anyone successfully using Online Videos to access Amazon Prime UK these days? Until recently I had no problems but now it no longer works. I know that the login process is working successfully as I can get as far as seeing the Watchlist set up in my Amazon account - but nothing will then play. I make the selection. get the rotating dots image and then just revert back to the item list.

    I'm not aware of having made any changes so am curious to know whether this behaviour is happening elsewhere (i.e. have Amazon changed something again) or whether it's just something on my system.
     
  6. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    11,017
    Likes Received:
    4,750
    Ratings:
    +6,796 / 11
    Home Country:
    Germany Germany
    Show System Specs
    Unfortunately there is no known reason nor solution to this behavior. Amazon requests randomly an additional login when this happens. And as there is the loading indicator overlaying the browser, users can't see this screen.

    This can be only solved by editing file C:\Program Files (x86)\Team MediaPortal\MP2-Client\Plugins\OnlineVideos\iexplore.exe.config. (MP2 path, for MP1 please search for this file)
    Set
    <add key="DebugMode" value="true" />
    <add key="BrowserHostWaitTimeout" value="30"/>
    (the timeout setting gives your more time to type in your passwort and login)

    Once you logged in successful, it should work (for a while)...
     
    • Like Like x 2
  7. wjw

    wjw Portal Pro

    Joined:
    July 13, 2008
    Messages:
    322
    Likes Received:
    20
    Ratings:
    +34 / 0
    Home Country:
    United Kingdom United Kingdom
    Thanks for the quick reply and advice. Unfortunately, having looked in the logfile to make sure, that's not the problem. Login is sucessful - here are the lines from the OnlineVideos log:

    [01-15 12:25:12,184] [MPMain ] [INFO ] Search category restored to All
    [01-15 12:25:18,841] [OnlineVideos] [INFO ] Looking for dynamic categories for site 'Amazon Prime Uk'
    [01-15 12:25:18,872] [OnlineVideos] [INFO ] Found 3 dynamic categories for site 'Amazon Prime Uk'
    [01-15 12:25:21,185] [OnlineVideos] [INFO ] Looking for subcategories in 'Watchlist' on site 'Amazon Prime Uk'
    [01-15 12:25:21,201] [OnlineVideos] [INFO ] Login to Amazon Amazon.co.uk: Low Prices in Electronics, Books, Sports Equipment & more
    [01-15 12:25:23,967] [OnlineVideos] [INFO ] Login complete
    [01-15 12:25:23,967] [OnlineVideos] [INFO ] Found 2 subcategories in 'Watchlist' on site 'Amazon Prime Uk'
    [01-15 12:25:26,065] [OnlineVideos] [INFO ] Looking for subcategories in 'TV Watchlist' on site 'Amazon Prime Uk'
    [01-15 12:25:26,425] [OnlineVideos] [INFO ] Found 3 subcategories in 'TV Watchlist' on site 'Amazon Prime Uk'

    However, looking the MP logfile I see this:

    [2018-01-15 12:26:16,147] [Error ] [33 ] [ERROR] - [OnlineVideos] log4net:ERROR XmlHierarchyConfigurator: Cannot find Property [encoding] to set object on [log4net.Appender.ConsoleAppender]
    log4net:ERROR XmlHierarchyConfigurator: Cannot find Property [lockingModel] to set object on [log4net.Layout.PatternLayout]
    log4net:ERROR XmlHierarchyConfigurator: Cannot find Property [encoding] to set object on [log4net.Appender.BufferingForwardingAppender]
    log4net:ERROR XmlHierarchyConfigurator: Cannot find Property [lockingModel] to set object on [log4net.Appender.BufferingForwardingAppender]

    Sadly this means nothing to me. Hopefully it might to you?
     
  8. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    11,017
    Likes Received:
    4,750
    Ratings:
    +6,796 / 11
    Home Country:
    Germany Germany
    Show System Specs
    This error looks related to the logging component itself. This is not related to OV plugin or Amazon site. If it is specific to MP1 I'm unable to assist, sorry.
     
  9. Freuli

    Freuli Portal Pro

    Joined:
    October 31, 2007
    Messages:
    391
    Likes Received:
    33
    Ratings:
    +77 / 0
    Hi,

    I had the same problem. For me, I found a workaround. During the running dots, I type in my password and press enter. After that, the video is starting.

    Hopefully I will run at your side as well.

    regards
    markus
     
  10. morpheus_xx
    • Team MediaPortal

    morpheus_xx Lead Dev MP2

    Joined:
    March 24, 2007
    Messages:
    11,017
    Likes Received:
    4,750
    Ratings:
    +6,796 / 11
    Home Country:
    Germany Germany
    Show System Specs
    Ah yes, this is a kind of "blind input" of the password. Good to know :)
     
  11. wjw

    wjw Portal Pro

    Joined:
    July 13, 2008
    Messages:
    322
    Likes Received:
    20
    Ratings:
    +34 / 0
    Home Country:
    United Kingdom United Kingdom
    @Freuli

    Thanks for the suggestion, but unfortunately doesn't work for me.

    @morpheus_xx

    So I tried on MP2 with the same lack of success. I can't see a separate OnlineVideos log file as there was for MP1, but in the MP2 Client Log file I see the following:


    [2018-01-15 15:11:22,621] [107462 ] [AMQ 'ScreenManager'] [WARN ] - Cannot open texture: LanguageFlags\Amazon Prime Uk.png
    [2018-01-15 15:11:27,927] [112769 ] [Thread29 ] [INFO ] - [OnlineVideos] Login to Amazon Amazon.co.uk: Low Prices in Electronics, Books, Sports Equipment & more
    [2018-01-15 15:11:31,560] [116401 ] [Thread29 ] [INFO ] - [OnlineVideos] Login complete
    [2018-01-15 15:11:31,586] [116427 ] [Thread111] [INFO ] - WorkflowManager: Pushing workflow state 'OnlineVideosCategories' (id='517dd2c8-27c4-4ae1-abdc-b8001bfc95da') onto the navigation stack...
    [2018-01-15 15:11:31,594] [116435 ] [Thread111] [INFO ] - WorkflowManager: Trying to show screen 'categories'...
    [2018-01-15 15:11:31,680] [116521 ] [Thread111] [INFO ] - WorkflowManager: Screen 'categories' successfully shown
    [2018-01-15 15:11:35,948] [120789 ] [Thread111] [INFO ] - WorkflowManager: Pushing workflow state 'OnlineVideosCategories' (id='517dd2c8-27c4-4ae1-abdc-b8001bfc95da') onto the navigation stack...
    [2018-01-15 15:11:35,959] [120800 ] [Thread111] [INFO ] - WorkflowManager: Trying to show screen 'categories'...
    [2018-01-15 15:11:36,015] [120856 ] [Thread111] [INFO ] - WorkflowManager: Screen 'categories' successfully shown
    [2018-01-15 15:11:42,318] [127159 ] [Thread111] [INFO ] - WorkflowManager: Pushing workflow state 'OnlineVideosVideos' (id='ff474a1a-ca39-4247-bfea-4e7b578f482b') onto the navigation stack...
    [2018-01-15 15:11:42,324] [127165 ] [Thread111] [INFO ] - WorkflowManager: Trying to show screen 'videos'...
    [2018-01-15 15:11:42,745] [127587 ] [Thread111] [INFO ] - WorkflowManager: Screen 'videos' successfully shown
    [2018-01-15 15:11:46,729] [131571 ] [Thread29 ] [INFO ] - WorkflowManager: Pushing workflow state 'CheckQueryPlayActionSingleItem' (id='b79e395b-2276-4cde-b4cc-bb4f3e201eff') onto the navigation stack...
    [2018-01-15 15:11:46,890] [131732 ] [Thread29 ] [INFO ] - WorkflowManager: Screen was updated by workflow model
    [2018-01-15 15:11:46,898] [131740 ] [Thread111] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
    [2018-01-15 15:11:46,908] [131750 ] [Thread111] [INFO ] - WorkflowManager: Trying to show screen 'videos'...
    [2018-01-15 15:11:46,915] [131757 ] [Thread111] [INFO ] - WorkflowManager: Screen 'videos' successfully shown
    [2018-01-15 15:11:46,921] [131763 ] [Thread111] [INFO ] - WorkflowManager: Pushing workflow state 'CheckResumePlayback' (id='04138763-42e6-49f1-ba51-ee3a9baa835d') onto the navigation stack...
    [2018-01-15 15:11:46,944] [131786 ] [Thread111] [INFO ] - WorkflowManager: Screen was updated by workflow model
    [2018-01-15 15:11:46,958] [131799 ] [Thread29 ] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
    [2018-01-15 15:11:46,962] [131803 ] [Thread29 ] [INFO ] - WorkflowManager: Trying to show screen 'videos'...
    [2018-01-15 15:11:46,969] [131810 ] [Thread29 ] [INFO ] - WorkflowManager: Screen 'videos' successfully shown
    [2018-01-15 15:11:54,741] [139582 ] [Thread26 ] [INFO ] - WorkflowManager: Pushing workflow state 'VideoFullscreenContent' (id='882c1142-8028-4112-a67d-370e6e483a33') onto the navigation stack...
    [2018-01-15 15:11:55,418] [140259 ] [Thread26 ] [INFO ] - WorkflowManager: Screen was updated by workflow model
    [2018-01-15 15:11:55,508] [140350 ] [AMQ 'ScreenManager'] [INFO ] - OVP: Transformed BBOX: X:990 Y:220 Width:820 Height:606
    [2018-01-15 15:12:13,052] [157893 ] [Thread29 ] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
    [2018-01-15 15:12:13,057] [157898 ] [Thread29 ] [INFO ] - WorkflowManager: Trying to show screen 'videos'...
    [2018-01-15 15:12:13,140] [157982 ] [Thread29 ] [INFO ] - WorkflowManager: Screen 'videos' successfully shown
    [2018-01-15 15:12:35,734] [180575 ] [InputMgr ] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
    [2018-01-15 15:12:35,823] [180664 ] [InputMgr ] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
    [2018-01-15 15:12:35,883] [180725 ] [InputMgr ] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
    [2018-01-15 15:12:35,958] [180800 ] [InputMgr ] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
    [2018-01-15 15:12:35,974] [180815 ] [InputMgr ] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
    [2018-01-15 15:12:35,982] [180824 ] [InputMgr ] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
    [2018-01-15 15:12:35,988] [180829 ] [InputMgr ] [INFO ] - WorkflowManager: Trying to show screen 'home'...
    [2018-01-15 15:12:38,269] [183110 ] [InputMgr ] [INFO ] - WorkflowManager: Screen 'home' successfully shown
    [2018-01-15 15:12:49,588] [194429 ] [InputMgr ] [INFO ] - WorkflowManager: Pushing workflow state 'dialogSystemState' (id='bbfa7db7-5055-48d5-a904-0f0c79849369') onto the navigation stack...
    [2018-01-15 15:12:49,594] [194435 ] [InputMgr ] [INFO ] - WorkflowManager: Trying to open dialog screen 'dialogSystemState'...
    [2018-01-15 15:12:49,725] [194567 ] [InputMgr ] [INFO ] - WorkflowManager: Screen 'dialogSystemState' successfully shown
    [2018-01-15 15:12:54,149] [198990 ] [Thread29 ] [INFO ] - WorkflowManager: Trying to remove 1 workflow states from navigation stack...
    [2018-01-15 15:12:54,156] [198997 ] [Thread29 ] [INFO ] - WorkflowManager: Trying to show screen 'home'...
    [2018-01-15 15:12:54,160] [199001 ] [Thread29 ] [INFO ] - WorkflowManager: Screen 'home' successfully shown
    [2018-01-15 15:12:54,217] [199058 ] [Main ] [INFO ] - UPnPServerController: GENA disabled for IP endpoint '127.0.0.1'
    [2018-01-15 15:12:54,363] [199204 ] [Main ] [INFO ] - ImporterWorker: Suspension requested...
    [2018-01-15 15:12:54,380] [199222 ] [115 ] [INFO ] - ImporterWorker: Suspended (0 ImportJobs pending)
    [2018-01-15 15:12:54,463] [199304 ] [Main ] [INFO ] - ImporterWorker: Suspension requested...
    [2018-01-15 15:12:54,523] [199365 ] [Main ] [INFO ] - WorkflowManager: Shutdown
    [2018-01-15 15:12:54,528] [199369 ] [Main ] [INFO ] - ImporterWorker: Shutdown requested...
    [2018-01-15 15:12:54,550] [199391 ] [81 ] [INFO ] - ImporterWorker: Shutdown
    [2018-01-15 15:12:54,696] [199537 ] [Main ] [INFO ] - PluginManager: Shutdown
    [2018-01-15 15:12:54,709] [199550 ] [Main ] [INFO ] - MceRemote: Stopping MCE remote
    [2018-01-15 15:12:54,783] [199624 ] [Main ] [INFO ] - Dokan: Successfully unmounted resource 'C:\ProgramData\Team MediaPortal\MP2-Client\RemoteResources'
    [2018-01-15 15:12:54,786] [199627 ] [Main ] [INFO ] - ResourceServer: Shutting down HTTP servers
    [2018-01-15 15:12:56,795] [201636 ] [Main ] [WARN ] - ThreadPool: Not all worker threads terminated
    [2018-01-15 15:12:57,277] [202119 ] [Main ] [INFO ] - UPnPServerController: SSDP disabled for IP endpoint '127.0.0.1'
    [2018-01-15 15:12:57,282] [202124 ] [Main ] [INFO ] - UPnPServerController: SSDP disabled for IP endpoint 'fe80::65ff:4107:acaa:7f37'
    [2018-01-15 15:12:57,287] [202129 ] [Main ] [INFO ] - UPnPServerController: SSDP disabled for IP endpoint 'fe80::14ad:767:a962:f9d3'
    [2018-01-15 15:12:57,292] [202134 ] [Main ] [INFO ] - UPnPServerController: SSDP disabled for IP endpoint '192.168.1.100'
    [2018-01-15 15:12:57,297] [202139 ] [Main ] [INFO ] - UPnPServerController: SSDP disabled for IP endpoint '2001:0:4137:9e76:14ad:767:a962:f9d3'
    [2018-01-15 15:12:58,520] [203361 ] [Dokan ] [INFO ] - Dokan: DokanMain returned successfully!

    However things now get really curious! In the While in MP2 I selected one item to play - failed. Then selected the second episode from the same list and while the dots were whirling I tried the enter password thing again - which worked! Except that a second window opened alongside the first. Thesecond window played the item while the first was still showing a blank.

    Just added the full set of MP2 logs from this session.
     

    Attached Files:

    Last edited: January 15, 2018
Loading...

Users Viewing Thread (Users: 2, Guests: 0)

  1. joecrow,
  2. Lehmden
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!