OnlineVideos 2.3.1.0 [2017/05/15] (1 Viewer)

2BitSculptor

Super Moderator
  • Team MediaPortal
  • January 23, 2008
    1,838
    403
    South Central Wisconsin
    United States of America United States of America
    Country flag
    I'm blushing here. only a couple adult sites play. many don't list videos, some that show a video list cannot find urls. on one, media player has an error to start playing. I don't know the workings or not-workings behind the scene. I don't know if the sites are in operation any longer.
     

    greybox

    MP Donator
  • Premium Supporter
  • January 23, 2009
    576
    93
    Canada Canada
    Country flag
    YouTube no longer works for me. I am getting: "Error. Unable to play video. No URL.". Anybody else can
    confirm?
     

    greybox

    MP Donator
  • Premium Supporter
  • January 23, 2009
    576
    93
    Canada Canada
    Country flag
    Thank you, but this might also be related to excessive downloads of about 50 files within about 30 minutes recently. It is possible that YouTube has banned my IP address? It appears that I can still watch and download YouTube videos from another PC at another location.

    When trying to watch videos with web browsers, I am offered to go though reCAPCHA, and then I can watch. Or I can login to my YouTube account and reCAPCHA will not appear. But when I added my YouTube login credentials to Online Videos, that did not help. I still cannot download or watch, so there must be something else involved, not just the IP address and YouTube login. Is it possible to mimic reCAPCHA response in Online Videos?

    I can confirm that. Will try to fix it soon
     
    Last edited:

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,524
    1,724
    Nuenen
    Netherlands Netherlands
    Country flag
    Thank you, but this might also be related to excessive downloads of about 50 files within about 30 minutes recently. It is possible that YouTube has banned my IP address? It appears that I can still watch and download YouTube videos from another PC at another location.

    When trying to watch videos with web browsers, I am offered to go though reCAPCHA, and then I can watch. Or I can login to my YouTube account and reCAPCHA will not appear. But when I added my YouTube login credentials to Online Videos, that did not help. I still cannot download or watch, so there must be something else involved, not just the IP address and YouTube login. Is it possible to mimic reCAPCHA response in Online Videos?
    Just tested with some problematic videos, and they are all working (despite me confirming broken).
    So indeed it must be something on your end. Doing a captcha in Onlinevideos is not possible but putting your youtube credentials there should work.
    Can you send me (privately because I don't know if there's going to be any sensitive info in there) the onlinevideos.log of a failed attempt of playing a video when you have your youtube credentials set?
     

    greybox

    MP Donator
  • Premium Supporter
  • January 23, 2009
    576
    93
    Canada Canada
    Country flag
    I have looked at the log file generated with log verbosity set to Debug. This part of the log seems the most interesting and does not look sensitive:

    Code:
    [10-13 17:01:46,863] [OnlineVideos] [INFO ] Looking for dynamic categories for site 'YouTube'
    [10-13 17:01:47,524] [OnlineVideos] [INFO ] Found 6 dynamic categories for site 'YouTube'
    [10-13 17:02:14,638] [OnlineVideos] [INFO ] Searching for chreyl cole live tonight in all categories
    [10-13 17:02:15,953] [MPMain      ] [INFO ] restoring search category...
    [10-13 17:02:15,953] [MPMain      ] [INFO ] Search category restored to All
    [10-13 17:02:20,397] [OnlineVideos] [DEBUG] GetWebData-GET: 'https://www.youtube.com/get_video_info?video_id=_fmhYSLX4GQ&has_verified=1'
    [10-13 17:02:20,525] [OnlineVideos] [DEBUG] The remote server returned an error: (429) Too Many Requests.
    [10-13 17:02:20,527] [OnlineVideos] [DEBUG] GetWebData-GET: 'https://www.youtube.com/watch?v=_fmhYSLX4GQ&has_verified=1'
    I can see my YouTube subscriptions and playlists from MediaPortal OnlineVideos correctly, which means to me that I was authenticated properly by YouTube from MediaPortal. Only Watch History and Watch Later show "No video found" which is probably different story.

    I can send you complete log if you want, but error 429 seems to be the only thing that stands out.

    Can you send me (privately because I don't know if there's going to be any sensitive info in there) the onlinevideos.log of a failed attempt of playing a video when you have your youtube credentials set?
     

    doskabouter

    Development Group
  • Team MediaPortal
  • September 27, 2009
    3,524
    1,724
    Nuenen
    Netherlands Netherlands
    Country flag
    Just learned that there's indeed not much to be done to prevent or workaround the 429's other than being patient and behaving better next time...
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom