Ошибка при сканировании каналов (тюнер - AverMedia H788 PCIe Hybrid Analog/DVBT) (1 Viewer)

david_off

Portal Member
January 12, 2013
7
0
35
Ukraine Ukraine
ОС: Windows 8 (x64)
MP: 1.3.0.0 (beta)

При попытке сканировать каналы вылетает ошибка:



Стоят только драйвера от тюнера. Aver Media Center удалён.
Карта гибридная и настройка произведена согласно вики:

Такое же поведение наблюдается на версии MP 1.2.3.
 
Last edited:

renault

Portal Pro
November 20, 2008
804
18
Russian Federation Russian Federation
Судя по логу не находит энкодер,и видео пины,насколько помню энкодер есть в Aver Media Center,плюс еще наверно не хватает файлов в восьмерке как и в серверных платформах,про серверы можно посмотреть здесь http://www.beholder.ru/bb/viewtopic.php?f=1&t=8379&p=76948&hilit=server#p76948
PS:Восьмерка пока не заявлена в системах поддерживающих портал.Еще про энкодер-советую лучше поставить intervideo (поставить и снести intervideo winDVR,энкодеры останутся в системе).
 
Last edited:

Vasilich

Test Group
  • Team MediaPortal
  • August 30, 2009
    3,393
    1,170
    Germany, Mayence
    Russian Federation Russian Federation
    Country flag
    +1 к @renault - надо установить и настроить энкодеры
    http://wiki.team-mediaportal.com/1_...rs/7_Scan_Analog/Software_Encoding_Card_Setup

    http://wiki.team-mediaportal.com/1_...onfiguration/06_General#Software_Encoders_Tab

    ну и на всякий случай проверить, не блокирует ли запросы файрвол:
    2013-01-12 06:50:06.936493 [SetupTv(1)]: Exception :confused:ystem.Net.Sockets.SocketException: Подключение не установлено, т.к. конечный компьютер отверг запрос на подключение 192.168.1.102:31456
     
    Last edited:

    david_off

    Portal Member
    January 12, 2013
    7
    0
    35
    Ukraine Ukraine
    Судя по логу не находит энкодер,и видео пины,насколько помню энкодер есть в Aver Media Center,плюс еще наверно не хватает файлов в восьмерке как и в серверных платформах,про серверы можно посмотреть здесь http://www.beholder.ru/bb/viewtopic.php?f=1&t=8379&p=76948&hilit=server#p76948
    PS:Восьмерка пока не заявлена в системах поддерживающих портал.Еще про энкодер-советую лучше поставить intervideo (поставить и снести intervideo winDVR,энкодеры останутся в системе).
    Проверил, есть ли файлы, оказалось, что все файлы из выше приведённой ссылки уже есть в системе. Так что думаю, что проблема не в этом.
    +1 к @renault - надо установить и настроить энкодеры
    http://wiki.team-mediaportal.com/1_...rs/7_Scan_Analog/Software_Encoding_Card_Setup

    http://wiki.team-mediaportal.com/1_...onfiguration/06_General#Software_Encoders_Tab

    ну и на всякий случай проверить, не блокирует ли запросы файрвол:
    2013-01-12 06:50:06.936493 [SetupTv(1)]: Exception :confused:ystem.Net.Sockets.SocketException: Подключение не установлено, т.к. конечный компьютер отверг запрос на подключение 192.168.1.102:31456
    фаервол отключил - не помогло



    энкодер поставил intervideo по методу поставить-снести.
    Тоже не помогло.

    Просьба к Vasilich и renault. Вы не могли бы подсказать, на основании каких строчек логов видно что проблема в энкодере? Я сколько не смотрел в них так ничего и не нашёл, говорящее о проблема экодера или фаервола.

    Прилагаю ещё раз логи, может там что-то новое появилось. Хотя поведение TV-Server Configuration осталось прежнее, выкидывает тоже сообщение об ошибке.



     

    renault

    Portal Pro
    November 20, 2008
    804
    18
    Russian Federation Russian Federation
    В tv.log не найден энкодер-2013-01-17 02:15:52.566601 [(5)]: analog: AddTvEncoderFilter no encoder devices found,плюс еще пишет,что не найдены пины Capture и multiplexer-2013-01-17 02:15:52.571605 [(5)]: analog: FinCapturePin - no filter???
    2013-01-17 02:15:52.575607 [(5)]: analog: AddTvMultiPlexer no multiplexer devices found.Скачайте GraphEdit и из папки c:\Users\All Users\Team MediaPortal\MediaPortal TV Server\ запустите analog.grf посмотрите,что рисует.
     
    Last edited:

    david_off

    Portal Member
    January 12, 2013
    7
    0
    35
    Ukraine Ukraine
    В tv.log не найден энкодер-2013-01-17 02:15:52.566601 [(5)]: analog: AddTvEncoderFilter no encoder devices found,плюс еще пишет,что не найдены пины Capture и multiplexer-2013-01-17 02:15:52.571605 [(5)]: analog: FinCapturePin - no filter???
    2013-01-17 02:15:52.575607 [(5)]: analog: AddTvMultiPlexer no multiplexer devices found.Скачайте GraphEdit и из папки c:\Users\All Users\Team MediaPortal\MediaPortal TV Server\ запустите analog.grf посмотрите,что рисует.
    Спасибо за ответ.


    Попробывал установить другие encoders. Но это не помогло.
    Поставил:
    - MainConcept MPEG Video Encoder (через ссылку в wiki на MCE Encoder 1.5 Demo ),
    - CyberLink MPEG Video Encoder (честно ворованный-хакнутый CyberLink PowerDirector 11 Ultra v11.0.0.2418 Final)
    - Corel WinDVD Pro 11 x64 (вроде после того как InverVideo купил Corel это пришло на замену Inter DVR)
    Но ничего не изменилось. В логах по прежнему не находится энкодер.

    Попробовал юзать GraphEdit (поставил полный Microsoft Windows Software Development Kit).
    Ниже скрины.
    graphedt.exe из папки x86 выдает:


    graphedt.exe из папки x64 выдает:


    А вот раздел установленных энкодеров в TV Server Config показывает следующее:


    Из этого следует пару вопросов:
    Почему TV Server Config не видит установленные энкодеры?
    И почему их не видит GraphEdit_x64?
    Для нормальной работы нужно что бы GraphEdit_x64 видел их или достаточно только GraphEdit_x86?

    Как обычно логи во вложении
     
    Last edited:

    Vasilich

    Test Group
  • Team MediaPortal
  • August 30, 2009
    3,393
    1,170
    Germany, Mayence
    Russian Federation Russian Federation
    Country flag
    медиапортал -32битный, соотв, надо ставить кодеки 32битные. и графэдит надо брать 32.
    я юзаю http://code.google.com/p/graph-studio-next/ ибо оригинальный графэдит имеет ограничение на 100 поддерживаемых форматов и валится, если кодек умеет больше.
    Renault сказал, что надо открыть граф (и сказал какой) и запостить картинку графа сюда.
     
    Last edited:

    Vasilich

    Test Group
  • Team MediaPortal
  • August 30, 2009
    3,393
    1,170
    Germany, Mayence
    Russian Federation Russian Federation
    Country flag
    и на твоём скриншоте TVSetup не видно Intervideo Video Encoder, который у тебя установлен в 32битной версии.
     

    david_off

    Portal Member
    January 12, 2013
    7
    0
    35
    Ukraine Ukraine
    медиапортал -32битный, соотв, надо ставить кодеки 32битные. и графэдит надо брать 32.
    я юзаю http://code.google.com/p/graph-studio-next/ ибо оригинальный графэдит имеет ограничение на 100 поддерживаемых форматов и валится, если кодек умеет больше.
    Renault сказал, что надо открыть граф (и сказал какой) и запостить картинку графа сюда.
    Извиняюсь, что забыл отписать про открытие графа. Я пытался найти его но не обнаружил на компе. Пути, как был указан - нет. А поиск по диску С: (там и винда и MP) не дал результатов. Можно где-то этот файл скачать?
    и на твоём скриншоте TVSetup не видно Intervideo Video Encoder, который у тебя установлен в 32битной версии.
    Сейчас не возле компа на котором проблема. Буду в понедельник и сразу скину ещё один скрин с отрытым узлом InverVideo Video Encoder.
     

    Vasilich

    Test Group
  • Team MediaPortal
  • August 30, 2009
    3,393
    1,170
    Germany, Mayence
    Russian Federation Russian Federation
    Country flag
    граф *.grf лежит в папке на уровень выше той, где ты логи ТВ сервера берёшь
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom