Pb avec WebEpg (1 Viewer)

David LIGHTMAN

Portal Member
November 26, 2009
23
0
Bonjour à tous,

je reviens sur le sujet que j'ai déjà posté concernant le plugin WebEpg. En fait après avoir installé ce plugin, celui-ci fonctionne bien en mode "config"; le bouton passe bien au vert, que j'utilise Kazer ou Zguide. Par contre dans MP, dans le guide, voilà ce qui se passe :

les programmes sont affichés pour 1h00 environ
seule la chaine Canal+ déroule sans encombre

Est ce que quelqu'un a une idée ?

Merci d'avance.
 

Jean-Marc

Portal Pro
February 28, 2007
377
28
France France
Country flag
Bonjour à tous,

Je suis sous MP 1.0.2
Ai installé WedepgFr
Ai installé le plugin Xmltv dans TV serveur
Les chemins sont bien configurés, tout pointe au même endroit (Programs file/ teamMP/MP/xmltv) avec fichier dtd inclus
Si je choisi ZguideTNT, la config passe au vert, je fais mappage des chaines, parfait.
Je retourne dans xmltv dans config TV serveur, impossible de faire mappage et de charger les données ("fichier TVguide.xml introuvable")

En effet, dans mon fichier xmltv, après configuration du plug WebepgFr et test (passe bien au vert) absolument rien n'est téléchargé, le fichier reste vide excepté la création de ZgudeTvintegrator.ini

Maintenant si je choisi l'option TV guide complet de Zguide, il se télécharge un unique fichier "complet.xml" (à condition que l'option "delete old program before import" ne soit pas cochée dans xmltv de TV serveur, sinon il ne télécharge rien)
Si je renomme ce fichier TVguide.xml tout est absolument ok, je peux faire un import manuel depuis le plugin xmltv et le guide s'affiche bien dans MP et est très complet.

Mais c'est du bidouillage et il n'y aura pas de mise à jour automatique et j'aimerais bien que tout fonctionne parfaitement avant que je ne reparte chez moi car après je serai trop loin pour mettre à jour le MP français de mes parents...c'est pourquoi j'ai besoin de votre aide et vous remercie beaucoup par avance. (Pb de version du plugin (j'ai le 1.1)? de MP? du fichier dtd? J'avoue que je sèche même après avoir lu absolument tous les posts sur le sujet dans ce forum et avoir passé 2 jours à essayer...)

Merci encore et bon réveillon, excellente nouvelle année!!
 

lopez.tuparles

Retired Team Member
  • Premium Supporter
  • July 20, 2006
    396
    54
    45
    Mimet
    Bonjour à tous,

    Je suis sous MP 1.0.2
    Ai installé WedepgFr
    Ai installé le plugin Xmltv dans TV serveur
    Les chemins sont bien configurés, tout pointe au même endroit (Programs file/ teamMP/MP/xmltv) avec fichier dtd inclus
    Si je choisi ZguideTNT, la config passe au vert, je fais mappage des chaines, parfait.
    Je retourne dans xmltv dans config TV serveur, impossible de faire mappage et de charger les données ("fichier TVguide.xml introuvable")
    Salut,
    Avant de retourner dans xmltv, lance MP et fait un import via Webepgfr, puis une fois le téléchargement fini, ferme MP et fais ta tambouille dans xmltv. Ca devrait faire l'affaire.
    ;)
     

    Jean-Marc

    Portal Pro
    February 28, 2007
    377
    28
    France France
    Country flag
    Merci de ta réponse rapide!

    En effet, en suivant tes conseils ça fonctionne!

    Mais j'ai un doute quant à la mise à jour automatique de Zguide via Webepgfr: j'ai bien programmé la partie "planification" (par exemple il était 19h, j'ai mis lundi 19h05 pour voir) et à l'heure dite il n'y a pas eu de connexion à internet. (J'ai fait plusieurs essais bien entendu)

    xmltv par contre récupère bien tout seul le TVguide.xml

    En utilisant webepgfr à partir de son skin dans MP, en manuel, tout fonctionne (téléchargement et mise à jour). La date et l'heure de mise à jour ne s'affichent dans le skin qu'après un import manuel ou je me trompe? Car ces valeurs ne changent pas après la MAJ automatique par xmltv

    Donc en résumé ça fonctionne bien en manuel mais pas en automatique et donc j'ai encore besoin de tes lumières....

    PS: j'utilise le skin black glass: le MPEI permet bien d'accepter ce skin mais en fait il ne contient aucun fichier pour black glass, j'ai donc fait des essais avec Blue3 et ai installé manuellement Zguide.xml manuellement dans /skin/black glass (le look ne correspond pas au skin mais c'est bon pour les essais et comme normalement tout se passe en automatique il ne sera jamais affiché dans MP)
     

    framug

    Super Moderator
  • Team MediaPortal
  • January 31, 2005
    4,554
    569
    South of France
    France France
    Country flag
    Re : Re: Pb avec WebEpg

    Mais j'ai un doute quant à la mise à jour automatique de Zguide via Webepgfr: j'ai bien programmé la partie "planification" (par exemple il était 19h, j'ai mis lundi 19h05 pour voir) et à l'heure dite il n'y a pas eu de connexion à internet. (J'ai fait plusieurs essais bien entendu)
    Bonjour,
    Pour éviter trop de connexions et, pour soulager les sites de Kazer/ZguideTV aussi, il y a un blocage sur la partie planification.
    Tu n'as droit à effectuer le téléchargement planifié qu'une seule fois par jour.
     

    Jean-Marc

    Portal Pro
    February 28, 2007
    377
    28
    France France
    Country flag
    Désolé de ne pas avoir pu poster plus tôt pour vous remercier pour ces explications.
    Tout devrait rouler comme il se doit maintenant...
    :D encore et bonne année à tous!
     

    Xantios

    Portal Pro
    November 16, 2005
    80
    0
    Bonjour


    Suite à la disparition de plusieurs chaines TV, j'ai upgradé mon ancienne version de MP pour la dernière 1.1.0 en repartant de zéro (au passage, bravo pour le boulot, jamais installation de MP n'a été aussi simple)
    là où cela bug, c'est pour l'EPG.


    J'ai essayé de suivre les indication précédentes.


    Dans TV serveur config
    plugin WebEPG
    j'ai mis le chemin suivant :
    C:\Program Files\Team MediaPortal\MediaPortal\xmltv
    j'ai coché :
    delete old programs before import
    but only if new programs overlap
    Dans le répertoire xmltv j'ai mis le fichier xmltv.dtd


    Quand je fait « Grab now » il créé u fichier TVguide.xml qui ne contient que l'ID des chaines :
    début du fichier :
    %%%%%%%%%%%%%%%%%%%%%%%%%%%
    <?xml version="1.0" encoding="utf-8"?>
    <!DOCTYPE tv SYSTEM "xmltv.dtd">
    <tv generator-info-name="WebEPG">
    <channel id="TF1-tf1.fr">
    <display-name>TF1</display-name>
    </channel>
    §§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§§
    à la fin de l'opération il met :
    total chaine imported : 15
    total programs imported : 0
    Dans l'onglet TV mapping, tout est OK sauf les chaines i> TV et Virgin 17


    Dans le Plugin XmlTV
    j'ai mis le chemin suivant :
    C:\Program Files\Team MediaPortal\MediaPortal\xmltv
    j'ai coché :
    import new TVguide.xml
    import file in new tvguide.xml
    je clique sur le bouton force import, j'attends :
    total chaine imported : 68
    total programs imported : 0


    Dans l'onglet mapping, quand j'appuie sur l'onglet Load/Refresh, que je choisisse ou non le groupe all channel, j'ai le message : tvguide.lst non trouvé.


    J'ai voulu aller configurer WepEPG dans MP (skin Xface) dans plugin il n'y est pas alors qu'il est bien coché dans la liste plugin de TV serveur configuration.


    Donc je suis bloqué, je ne sais plus quoi faire, quelle étape j'ai zappé.


    D'avance merci
     

    lopez.tuparles

    Retired Team Member
  • Premium Supporter
  • July 20, 2006
    396
    54
    45
    Mimet
    Dans l'onglet mapping, quand j'appuie sur l'onglet Load/Refresh, que je choisisse ou non le groupe all channel, j'ai le message : tvguide.lst non trouvé.
    ca doit venir du fait que tu as l'option d'utilisation du lst de coché: décoche la ;)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Similar threads


    Top Bottom