Передача многоканального звука через S/PDIF в MEDIAPORTAL 1.2 final (1 Viewer)

mnikifor

New Member
September 25, 2009
12
2
После переустановки МЕДИАПОРТАЛА 1.2, не могу добиться воспроизведения многоканального звука на ресивере подключенного по оптике (в WMP тоже нет если это поможет), только стерео! Может кодеки не те поставил или не так настроил. ПОМОГИТЕ ПЛИЗ :)


P.S. Windows 7 x64 proffesional
ПРОЦ - АМД 2Х, ЧИПСЕТ - AMD 790G, SAUND - REALTEK ALC 1200.
Установил МАТРЁШКУ-СПЛИТЕР, FFShow x64, HD-Pack
 

Bomberman

Portal Pro
June 19, 2009
157
8
Russia, Moscow
Russian Federation Russian Federation
100500 раз обсуждалось на ... туче форумов.
Так "после переустановки Медиапортала" или "кодеки не те поставил"?
Что было сделано, чтобы попробовать получить "многоканальный звук"?
Кстати, это PCM или DD - DTS?
 

mnikifor

New Member
September 25, 2009
12
2
Чего только не делал :) . после работы до часу ночи игрался настройками. Никакого результата! Поставил KMplayer, всё играет нормально, только DTS тише, но там настроить можно бегунки и тогда уровень выравнивается. А МР любой выводит только стерео, и WMP тоже, я так понимаю они используют одни и те-же кодеки. Раз KMplayer (у него вроде свои кодеки), может передавать многоканальный звук, значит дело не в ресивере.
 

Bomberman

Portal Pro
June 19, 2009
157
8
Russia, Moscow
Russian Federation Russian Federation
Запустить МП в оконном режиме, скачать Graphstudio http://blog.monogram.sk/janos/tools/monogram-graphstudio/
Запустить портал, запустить ГС, посмотреть что за кодеки цепляются.
У меня, лично, в качестве аудеодекодера ффдшоу MSVC2010 http://www.xvidvideo.ru/ffdshow-tryouts-project-x86-x64/ffdshow-tryouts-project-svn-3984-x86-x64.html

Указать это кодек в Портале как звуковой (в видео, ТВ, ДВД)
В винде в свойствах звука должно стоять дефолтным устроство с HD в названии
например: AMD HDMI Output или Realtek HD Audio Output
В ффдшоу настраиваем битстрим: на вкладке Output ставим галки Pass-through на Dolby Digital, DTS.
Если битстримим через HDMI, то и на TrueHD, DTS-HD (они через S/P-DIF не пролезают)
 

mnikifor

New Member
September 25, 2009
12
2
Уважаемый Bomeranger, спасибо что "нянчитесь" со мной. По поводу устройства вывода, в аудиодрайверах оно называется Realtek Digital Output(Optical), так-что HD в названии там нет :( !
Запустить МП в оконном режиме, скачать Graphstudio http://blog.monogram.sk/janos/tools/mon ... aphstudio/
Запустить портал, запустить ГС, посмотреть что за кодеки цепляются.
Сделал, только не понял как посмотреть в этой программе хоть чего-нибудь, просто окно пустое и ничего не меняется, хоть включай кино хоть нет!
Галки стоят как вы советовали, но звук всё равно только СТЕРЕО.
 

mnikifor

New Member
September 25, 2009
12
2
Ещё раз спасибо Bomeranger, хоть я и не разобрался с ГРАФСТУДИО (таких картинак как на примере я так и не добился, просто голое окно!), но Вы навели меня на мысль поковырять звуковые кодеки с помощью конфигуратора. Сначала я попытался добиться объёмного звука от WMP (прочёл, что МР использует его для воспроизведения видео), ничего не получилось. Почитал форумы, нашёл статью про настройку AC3Filtr, и не нашёл где это настраивается, хотя в конфигураторе такой вариант кодека есть. Скачал отдельно и установил. Появился настройщик AC3Filtr, там выставил галки для воспроизведения через S/PDIF DD & DTS и на поддерживаемых рессивером форматах ( 16 и 24 бит). И о чудо через WMP "полился" объёмный звук ;D ! Но.....через МР опять стерео :eek: . Дальше зашёл в конфигуратор портала, и обнаружил в Videos - Videos Post Processing окно в которое можно отправлять фильтры для активации,после того как я поставил галочку напротив AC3Filtr, стала активна кнопка его настроек, открылось окно с настройками в котором я проделал тоже, что и для WMP и всё зазвучало!!!!!!!!!!!
Как стало всё сложно :) .
 

mnikifor

New Member
September 25, 2009
12
2
Всё равно проблемы со звуком, часть фильмов без звука идёт :(
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom