Перестала играть музыка :(

Discussion in 'Помощь по MediaPortal' started by ajs, September 18, 2014.

  1. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,581
    Likes Received:
    2,623
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,569 / 29
    Home Country:
    Ukraine Ukraine
    Show System Specs
    Mediaportal 1.7.1 подключен через HDMI к Pioneer VSX-828, системные звуки Windows слышно и все работает, фильмы и видеоклипы так же, а вот музыку (MP3, FLAC, DTS) никак, вроде перепроверил все, но куда б еще копнуть даже не знаю :(



    Логи в аттаче, но там на первый взгляд все хорошо:
    Code (Text):
    1. [2014-09-18 22:37:54,246] [Log    ] [MPMain   ] [INFO ] - g_Player.Play(M:\Music\Loseless\Jean Michel Jarre\2004 - Aero\Jean Michel Jarre - AERO.cue.fake.track.01.dts Music)
    2. [2014-09-18 22:37:54,246] [Log    ] [MPMain   ] [DEBUG] - PlayerFactory: Successfully created player instance for file - M:\Music\Loseless\Jean Michel Jarre\2004 - Aero\Jean Michel Jarre - AERO.cue.fake.track.01.dts
    3. [2014-09-18 22:37:54,247] [Log    ] [MPMain   ] [DEBUG] - BASS: Playing CUE Track: M:\Music\Loseless\Jean Michel Jarre\2004 - Aero\Jean Michel Jarre - AERO.cue.fake.track.01.dts
    4. [2014-09-18 22:37:54,253] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
    5. [2014-09-18 22:37:54,253] [Log    ] [MPMain   ] [INFO ] - BASS: Creating BASS audio stream
    6. [2014-09-18 22:37:54,266] [Log    ] [MPMain   ] [INFO ] - BASS: Stream Information
    7. [2014-09-18 22:37:54,266] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
    8. [2014-09-18 22:37:54,266] [Log    ] [MPMain   ] [INFO ] - BASS: File: M:\Music\Loseless\Jean Michel Jarre\2004 - Aero\Jean Michel Jarre - AERO.dts
    9. [2014-09-18 22:37:54,266] [Log    ] [MPMain   ] [DEBUG] - BASS: Type of Stream: BASS_CTYPE_STREAM_WAV_PCM
    10. [2014-09-18 22:37:54,267] [Log    ] [MPMain   ] [INFO ] - BASS: Number of Channels: 2
    11. [2014-09-18 22:37:54,267] [Log    ] [MPMain   ] [INFO ] - BASS: Stream Samplerate: 44100
    12. [2014-09-18 22:37:54,267] [Log    ] [MPMain   ] [DEBUG] - BASS: Stream Flags: BASS_MUSIC_FLOAT, BASS_MUSIC_DECODE, BASS_UNICODE
    13. [2014-09-18 22:37:54,267] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
    14. [2014-09-18 22:37:54,267] [Log    ] [MPMain   ] [DEBUG] - BASS: Registering stream playback events
    15. [2014-09-18 22:37:54,267] [Log    ] [MPMain   ] [INFO ] - BASS: Successfully created BASS audio stream
    16. [2014-09-18 22:37:54,268] [Log    ] [MPMain   ] [INFO ] - BASS: ---------------------------------------------
    17. [2014-09-18 22:37:54,268] [Log    ] [MPMain   ] [DEBUG] - BASS: ---------------------------------------------
    18. [2014-09-18 22:37:54,268] [Log    ] [MPMain   ] [DEBUG] - BASS: Creating BASS mixer stream
    19. [2014-09-18 22:37:54,268] [Log    ] [MPMain   ] [DEBUG] - BASS: Found more output channels (6) than input channels (2). Check for upmixing.
    20. [2014-09-18 22:37:54,268] [Log    ] [MPMain   ] [INFO ] - BASS: No upmixing of Stereo selected
    21. [2014-09-18 22:37:54,268] [Log    ] [MPMain   ] [DEBUG] - BASS: Creating 2 channel mixer with sample rate of 44100
    22. [2014-09-18 22:37:54,269] [Log    ] [MPMain   ] [INFO ] - BASS: Initialising WASAPI device
    23. [2014-09-18 22:37:54,269] [Log    ] [MPMain   ] [DEBUG] - BASS: Freed WASAPI device
    24. [2014-09-18 22:37:54,270] [Log    ] [MPMain   ] [DEBUG] - BASS: Try to init WASAPI with a Frequency of 44100 and 2 channels
    25. [2014-09-18 22:37:54,279] [Log    ] [MPMain   ] [DEBUG] - BASS: ---------------------------------------------
    26. [2014-09-18 22:37:54,279] [Log    ] [MPMain   ] [DEBUG] - BASS: Buffer Length: 143360
    27. [2014-09-18 22:37:54,279] [Log    ] [MPMain   ] [DEBUG] - BASS: Channels: 2
    28. [2014-09-18 22:37:54,279] [Log    ] [MPMain   ] [DEBUG] - BASS: Frequency: 44100
    29. [2014-09-18 22:37:54,279] [Log    ] [MPMain   ] [DEBUG] - BASS: Format: BASS_WASAPI_FORMAT_24BIT
    30. [2014-09-18 22:37:54,280] [Log    ] [MPMain   ] [DEBUG] - BASS: InitFlags: BASS_WASAPI_EXCLUSIVE, BASS_WASAPI_AUTOFORMAT, BASS_WASAPI_BUFFER
    31. [2014-09-18 22:37:54,280] [Log    ] [MPMain   ] [DEBUG] - BASS: Exclusive: True
    32. [2014-09-18 22:37:54,280] [Log    ] [MPMain   ] [DEBUG] - BASS: ---------------------------------------------
    33. [2014-09-18 22:37:54,280] [Log    ] [MPMain   ] [INFO ] - BASS: WASAPI Device successfully initialised
    34. [2014-09-18 22:37:54,281] [Log    ] [MPMain   ] [DEBUG] - BASS: Successfully created BASS Mixer stream
    35. [2014-09-18 22:37:54,281] [Log    ] [MPMain   ] [INFO ] - BASS: playback started
    36. [2014-09-18 22:37:54,282] [Log    ] [MPMain   ] [INFO ] - g_Player.OnStarted() M:\Music\Loseless\Jean Michel Jarre\2004 - Aero\Jean Michel Jarre - AERO.cue.fake.track.01.dts media:Music
    37.  
    Куда копать?
     

    Attached Files:

  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. dj_saw

    dj_saw Portal Pro

    Joined:
    January 27, 2010
    Messages:
    102
    Likes Received:
    0
    Location:
    Екатеринбург
    Ratings:
    +7 / 0
    Системные звуки - это вывод звука в кодировке PCM... АС3, DTS - тут по разному у всех - например у меня вывод без декодирования в режиме как есть - выгоняется на оптику....А судя по куску лога в окне спойлера - у тебя включено декодирование AC3 и DTS средствами портала, а зачем, если рессивер сам раскодировать умеет?
     
  4. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,581
    Likes Received:
    2,623
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,569 / 29
    Home Country:
    Ukraine Ukraine
    Show System Specs
    У меня ресивер подключен по HDMI, и в медиапортале настроен WASAPI Exclusive который выкидывает напрямую на ресивер звук в том формате в котором записан, по другому я как не знаю как это настроить. Звук починился через 3 дня после того как пропал, :coffee: теперь опять работает :cool:
     
  5. dj_saw

    dj_saw Portal Pro

    Joined:
    January 27, 2010
    Messages:
    102
    Likes Received:
    0
    Location:
    Екатеринбург
    Ratings:
    +7 / 0
    Полтергейсты шалят? :confused: Судя по логу вывод был с декодированием, поэтому может и не было звука...
     
  6. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,581
    Likes Received:
    2,623
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,569 / 29
    Home Country:
    Ukraine Ukraine
    Show System Specs
    Сам в шоке :D

    С тех пор ничего не поменялось, звук есть. Ну и лог говорит что таки вроде и не декодирован:
    1. Number of Channels: 2
    2. BASS: Stream Samplerate: 44100
    3. BASS: Stream Flags: BASS_MUSIC_FLOAT, BASS_MUSIC_DECODE, BASS_UNICODE
    4. BASS: InitFlags: BASS_WASAPI_EXCLUSIVE, BASS_WASAPI_AUTOFORMAT, BASS_WASAPI_BUFFER
    Хотя я не знаю как заставить МП не декодировать звук, везде советуют настроить т.к. у меня и говорят что именно тут будет битсрим. И судя по ресиверу оно так и есть ...
     
  7. dj_saw

    dj_saw Portal Pro

    Joined:
    January 27, 2010
    Messages:
    102
    Likes Received:
    0
    Location:
    Екатеринбург
    Ratings:
    +7 / 0
    Не я конечно понимаю, что могло слететь декодирование AC3, DTS и т.п.
    Но в фильмах с AC3 и DTS говоришь нормально... А музыка не воспроизводится.

    Ну тут можно только на предположениях только пытаться понять что к чему... и первое глюк портала.. И именно во вкладке настройка вывода музыки... Причем кажись у тебя уже не первый раз такой слет....

    А случаем, никаких обновлений (ни системных виндовых? - проверить журнал системных событий) или для плугинов портала не происходило? Может что то и поломало на время
    У меня иногда также не предсказуемо пульт ДУ на USB отваливается... Под системой (Виндой) все нормально -а в портале может в любой момент отключиться, а потом также заработать... И как я выяснил, так как пульт онли USB2.0 по скорости (на USB1 - не работает) - что то в портале его загоняет в режим USB1 и он отваливается ... Вначале напрягало, а потом решил, что это косяк Мастер-китовцев (пульт ихняя поделка) и забил....
     
    Last edited: October 5, 2014
  8. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,581
    Likes Received:
    2,623
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,569 / 29
    Home Country:
    Ukraine Ukraine
    Show System Specs
    Насколько помню не было ...
     
  9. dj_saw

    dj_saw Portal Pro

    Joined:
    January 27, 2010
    Messages:
    102
    Likes Received:
    0
    Location:
    Екатеринбург
    Ratings:
    +7 / 0
    тогда точно полтергейст...:confused::(
     
    • Funny Funny x 1
  10. ajs
    • Team MediaPortal

    ajs Development Group

    Joined:
    February 29, 2008
    Messages:
    8,581
    Likes Received:
    2,623
    Gender:
    Male
    Occupation:
    IT
    Location:
    Kyiv
    Ratings:
    +4,569 / 29
    Home Country:
    Ukraine Ukraine
    Show System Specs
    А можно скриншотики как у вас это настроено, может у меня так же а может что то себе перестрою :) ?
     
  11. dj_saw

    dj_saw Portal Pro

    Joined:
    January 27, 2010
    Messages:
    102
    Likes Received:
    0
    Location:
    Екатеринбург
    Ratings:
    +7 / 0
    ок сделаю
     
    • Thank You! Thank You! x 1
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!