[fixed] - Play DVD Dialog Not Always Working

Discussion in 'MediaPortal 1.1.0 RC 1 & 2' started by kjd01, March 3, 2010.

  1. kjd01
    • Premium Supporter

    kjd01 MP Donator

    Joined:
    April 24, 2009
    Messages:
    159
    Likes Received:
    19
    Ratings:
    +19 / 0
    MediaPortal Version: 1.1.0 RC1
    MediaPortal Skin: Monochrome
    Windows Version: Vista SP1 32bit
    CPU Type: Intel E5200 2.5GHz
    HDD: Samsung 1TB & WDC 160GB
    Memory: 4GB
    Motherboard: ASUS KPL/C1600
    Video Card: Nvidia GeForce 8400 GS
    Video Card Driver: 8.16.11.9107
    Sound Card: VIA Onboard Sound
    Sound Card AC3: Optical
    Sound Card Driver: 6.0.1.7400
    1. TV Card: DigitalNow USB TinyTwin
    1. TV Card Type: DVB-T
    1. TV Card Driver: 8.6.24.1
    2. TV Card: DigitalNow TinyTwin USB
    2. TV Card Type: DVB-T
    2. TV Card Driver: 8.6.24.1
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: MPC-MPEG-2 Video Decoder
    MPEG2 Audio Codec: MPC-MPA Decoder Filter
    h.264 Video Codec: ffdshow Video Decoder
    Satelite/CableTV Provider:
    HTPC Case: Thermaltake Mozart
    Cooling:
    Power Supply:
    Remote:
    TV:
    TV - HTPC Connection:




    If I insert a DVD in the drive whilst the TV is stopped then the Play DVD dialog works fine. But if the TV is running then the dialog does not pop up. I have attached a log when it works and when it doesn't.:D
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. riksmith

    riksmith Portal Pro

    Joined:
    April 18, 2009
    Messages:
    1,856
    Likes Received:
    321
    Gender:
    Male
    Ratings:
    +321 / 0
    Home Country:
    Netherlands Netherlands
    Show System Specs
    I don't think this is a bug. I remember seeing something for this in the code, it seemed this was done on purpose. Anyone who can comment on this?
     
  4. tompa
    • Premium Supporter

    tompa MP Donator

    Joined:
    October 3, 2005
    Messages:
    665
    Likes Received:
    35
    Gender:
    Male
    Location:
    Stockholm
    Ratings:
    +35 / 0
    Home Country:
    Sweden Sweden
    Show System Specs
    Noticed this too.

    The dialog pops up if playing DVD under "My Films" though.

    /tompa
     
  5. kjd01
    • Premium Supporter

    kjd01 MP Donator

    Joined:
    April 24, 2009
    Messages:
    159
    Likes Received:
    19
    Ratings:
    +19 / 0
    Can someone please confirm if this is an issue or a feature.

    If it is a feature can you explain why it was changed.:D
     
  6. dhasselqvist

    dhasselqvist Member

    Joined:
    November 20, 2007
    Messages:
    75
    Likes Received:
    8
    Ratings:
    +8 / 0
    Home Country:
    Sweden Sweden
    I can add that DVDs aren't even started when using the "Play disc" menu item if TV is running. If I stop TV then select "Play Disc" it works every time. Perhaps also this is the intended behaviour. It is not the prefferd behaviour imo, hard for users to understand.
     
  7. kjd01
    • Premium Supporter

    kjd01 MP Donator

    Joined:
    April 24, 2009
    Messages:
    159
    Likes Received:
    19
    Ratings:
    +19 / 0
    Sorry to keep raising this but I would like to get an answer to whether this is a bug or a feature.
     
  8. Ragendorf

    Ragendorf Portal Pro

    Joined:
    March 24, 2008
    Messages:
    531
    Likes Received:
    21
    Occupation:
    Starverkäufer
    Location:
    Braunschweig
    Ratings:
    +22 / 0
    Home Country:
    Germany Germany
  9. kjd01
    • Premium Supporter

    kjd01 MP Donator

    Joined:
    April 24, 2009
    Messages:
    159
    Likes Received:
    19
    Ratings:
    +19 / 0
    I have recently upgraded with a fresh install of RC2 and this problem still exists. Tests and log files follow:

    Test1:
    -Configure the option to ask everytime a DVD is inserted
    -Start MP
    -Start TV
    -Put DVD in
    -Nothing Happens

    Test2:
    -Configure the option to Autoplay, never ask
    -Start MP
    -Start TV
    -Put DVD in
    -Nothing Happens

    Test3:
    -Configure the option to Autoplay, never ask
    -Start MP
    -Do not start TV
    -Put DVD in
    -DVD starts to play

    Test4:
    -Configure the option to ask everytime a DVD is inserted
    -Start MP
    -Do not start TV
    -Put DVD in
    -Dialog Box appears asking if I want to play the DVD

    With the setting to 'ask everytime a DVD is inserted' on I assume that no matter what MP is doing if a DVD is inserted it will ask me if I want to play it. This does not happen and I find it not very user friendly to either have to remember to stop the TV before putting a DVD in or returning to the main menu to start the DVD manually.

    Having a quick look at the logs, it seems to detect the DVD is inserted but just ignores it.
     
  10. kjd01
    • Premium Supporter

    kjd01 MP Donator

    Joined:
    April 24, 2009
    Messages:
    159
    Likes Received:
    19
    Ratings:
    +19 / 0
    Any chance of getting this added to mantis. I reported this problem on RC1 and now on RC2. I am hoping it gets fixed in RC3.
     
  11. cooper2k4

    cooper2k4 Portal Pro

    Joined:
    February 2, 2009
    Messages:
    51
    Likes Received:
    13
    Ratings:
    +13 / 0
    Home Country:
    Germany Germany
    Maybe it is related to the My Videos plugin:

    From: https://forum.team-mediaportal.com/...ts-mp-1-1-0-rc2-79351/index10.html#post607260
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!