Play ongoing recording from beginning doesn't work with mpeg as format (1 Viewer)

johnzered

Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    TV-Server Version: RC 1 + usually latest SVN
    MediaPortal Version: RC 1 + usually latest SVN
    MediaPortal Skin: BlueTwo wide
    Windows Version: Vista Home Premium SP1
    CPU Type: Intel C2D E8200
    HDD: Seagate 7200.11 500 GB
    Memory: 2 GB DDR2 667 Mhz
    Motherboard: Gigabyte GA-73PVM-S2H
    Video Card:
    Video Card Driver:
    Sound Card:
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: Digital everywhere FloppyDTV HW Version 1.26.01, FW Version 1.4.0 - B52030
    1. TV Card Type: DVB-C
    1. TV Card Driver: 4.5.N
    2. TV Card:
    2. TV Card Type:
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec:
    MPEG2 Audio Codec:
    h.264 Video Codec:
    Satelite/CableTV Provider:
    HTPC Case: Antec Fusion V2
    Cooling:
    Power Supply:
    Remote:
    TV:
    TV - HTPC Connection: Sub-D


    While we are on the subject of Recorded TV I tried to record with mpeg as the format instead of ts and the problem from RC1 discussed here: https://forum.team-mediaportal.com/...start-while-still-recording-39722/index2.html is still not working in RC2

    Steps to reproduce:
    Goto TV Server Configuration/Recording settings/Recording format
    Set mpeg as recording
    Start MediaPortal
    Start a recording
    Wait some minutes
    Goto Recorded TV
    Try to watch the recording
    You get the usual question if you want to watch from live point or beginning:
    first I tried live point (works)
    I then stopped and tried to watch the recording again this time i chose start from beginning
    the screen becomes black for a second and nothing more happens it just returns to recorded tv screen

    When the recording has finished I'm able to watch it, it's just while still recording when it doesn't work.


    //johnzered
     

    SciDoctor

    Retired Team Member
  • Premium Supporter
  • February 2, 2005
    1,465
    139
    England
    Country flag
    MPEG reording is still broken for many. i have always used TS format as it offers much more from within the broadcasts.

    Live point starts a new stream so isn't a real test of abilities/bug.


    Does the recording when accessed from MYVIDEOS play at all or does it suffer the same problem while recording.
     

    johnzered

    Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    Does the recording when accessed from MYVIDEOS play at all or does it suffer the same problem while recording.
    I'm not sure I really undestand what you mean but as I wrote earlier I can watch the recording from Recorded TV once it has finished recording.

    //johnzered
     

    SciDoctor

    Retired Team Member
  • Premium Supporter
  • February 2, 2005
    1,465
    139
    England
    Country flag
    Your recording folder for tvserver can be mapped as a folder for MYVIDEOS from MP config.

    You can then access recordings from there aswell as from MYTV/recrodings.

    MP seems to handle the file access differently from within MYVIDEOS (not via the TVserver PLUGIN) and can help with bug hunting and log comparison.

    The bug exists from both access points. My logs ar attached .

    I'll try and add to mantis if not already there.

    2008-07-23 13:55:18.619172 [Info.][MPMain]: DirectShowUtils: Found audio renderer
    2008-07-23 13:55:18.621125 [Debug][MPMain]: DirectShowUtils: added filter:Default DirectSound Device to graph
    2008-07-23 13:55:18.628937 [Info.][MPMain]: VideoPlayerVMR9: add normal vob sub filter
    2008-07-23 13:55:18.630890 [Warn.][MPMain]: VMR9: Pin: 0 not connected: 80040209
    2008-07-23 13:55:18.639679 [Warn.][MPMain]: VMR9: Pin: 1 not connected: 80040209
    2008-07-23 13:55:18.650420 [Warn.][MPMain]: VMR9: Pin: 2 not connected: 80040209
    2008-07-23 13:55:18.651397 [Info.][MPMain]: VideoPlayer9:cleanup DShow graph
    2008-07-23 13:55:18.652373 [Debug][MPMain]: VMR9: Dispose
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    One possible (and most likely) cause for the failure for ongoing mpeg recording playback is that the MS file source filter is not allowing to open a file when its being opened by another process with write flags.

    If its that then there is not that much we can do on MP side.
     

    johnzered

    Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    One possible (and most likely) cause for the failure for ongoing mpeg recording playback is that the MS file source filter is not allowing to open a file when its being opened by another process with write flags.

    If its that then there is not that much we can do on MP side.
    Yes, that's probably it. I tried to open the file in Windows Media Player 11 and PowerDVD 8 while still recording and the error message in both programs were similar to this:

    "The file is already in use. Close other programs that might be using the file or stop playing the file, and then try again."

    I then did a copy of the file being recorded and tried to open it in the same two programs and that did work so yes the cause must be as you said.

    But that's okay for me I can use ts format instead, and as SciDoctor said it offers more within the broadcast. I'm just trying all possibilites here to find the best working solution for me.

    EDIT: just a quick question in the thread I was refering to in my first post user sogge(currently the last post) said that this wasn't an issue in version 0.2.3 without the server. Could this be that back then it was the same process writing to the file andalso displaying it so then it worked?

    Thanks for helping (and developing a great software)!

    //johnzered
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    EDIT: just a quick question in the thread I was refering to in my first post user sogge(currently the last post) said that this wasn't an issue in version 0.2.3 without the server. Could this be that back then it was the same process writing to the file andalso displaying it so then it worked?
    The old internal recording process used microsoft components for TV, and produced dvr-ms files, which are pretty much redundant, as the new standard is TS.

    So microsoft have a bit of catching up to do :)
     

    SciDoctor

    Retired Team Member
  • Premium Supporter
  • February 2, 2005
    1,465
    139
    England
    Country flag
    From testing VLC could handle the MPEG file while was still open but VLC does have the ability to ignore 'problems' and continue when other players are less 'flexible' and stay rigid to MS DS requirements.

    Out of interest though I had no problems with any UK DVB-T channel being recorded into MPEG format other than the restriction when file is actively been written to and hence open.
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    One possible (and most likely) cause for the failure for ongoing mpeg recording playback is that the MS file source filter is not allowing to open a file when its being opened by another process with write flags.

    If its that then there is not that much we can do on MP side.
    Yes, that's probably it. I tried to open the file in Windows Media Player 11 and PowerDVD 8 while still recording and the error message in both programs were similar to this:

    "The file is already in use. Close other programs that might be using the file or stop playing the file, and then try again."
    Yep, definately an issue that we cannot solve on MP side. previously we had used TSFileSource to play .mpeg content and that source filter is able to open the file when its opened already for writing. Unfortunately that filter is a little bit buggy on other aspects.

    I think we should just state that using .mpeg as recording format will disable that ongoing recording playback feature. Unless MS wants to solve the issue :) (The issue is not a big one, just would require file open to have different parameters, but as the code is on MS binary...).

    TVE2 works also as its most likely using a different source filter for those (ugly) .dvr-ms files.


    Update: forgot that the MS mpeg2 source filter is most likely not able to update the duration (as its not designed most likely for that use case in mind). So the file open mode might not be the only issue the filter is having.
     

    johnzered

    Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    I think we should just state that using .mpeg as recording format will disable that ongoing recording playback feature. Unless MS wants to solve the issue :) (The issue is not a big one, just would require file open to have different parameters, but as the code is on MS binary...).
    Yes that sounds as a good solution. Also when you choose recording format in the configuratin there's already a helptext under the dropdownlist telling you something like "use .ts files if you get issues with the recorded .mpg files"

    But maybe for future reference there also should be a wiki page or something which could list known limitations of mpg as recording format.

    //johnzered
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    M WTV Files does not play on client, MPEG files works well General 0
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    Z Error when attempting to play Blu Ray General 1
    Rob Hexenmeister Playing with hyperlinkParameter and List Control indexes General Support 2
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    2BitSculptor MP 1.23.. music stops playing General Support 6
    C Attempt to play DVD locks up MediaPortal watch/edit Videos 0
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    L [solved] MP2 doesnt play anything - player missing? General 1
    badboyxx MP 1.22 final is crashing when jumping forward while playing DVD-Iso watch/edit Videos 26
    S [solved] Live TV playing stopped General 13
    Ralph Holmes [solved] MP2.2.1 can't play TV General 10
    T [solved] "Unable To Play" (Videos) rears it's head again. Logs not possible... WatchDog error attached!! :( General Support 1
    Terra Videos do not start playing on first attempt, always have to press play twice General Support 9
    G [fixed] [MP2-786] Party Music Player can only play playlists with less than 1000 items 2.2 Archive 7
    P [solved] TV server no longer saving to NAS - (can still play from NAS) General Support 2
    Similar threads

























    Top Bottom