Playing in MP all black is grey: Brightness is too high (1 Viewer)


Portal Member
February 10, 2008
MediaPortal Version: v. 1.0.1
MediaPortal Skin: Blue wide
Windows Version: Vista 64 Bit
CPU Type: Phenom X3 720
HDD: Samsung f1 spinpoint 1TB
Memory: 2x 2048 OCZ
Motherboard: MSI 790GX-G65
Video Card: ATI Radeon HD330
Video Card Driver: CCC ATI v9.4
Sound Card: Realtek ALC 889
Sound Card AC3: ALC 889
Sound Card Driver: realtek HD audio driver v 2.22
MPEG2 Video Codec: MPV video decoder
MPEG2 Audio Codec: MPA audio decoder
h.264 Video Codec: CoreAVC v.1.9.5
[HTPC Case: Silverstone SST-LC10E
Cooling: case 2x 8cm
Power Supply: 450 watt Silverstone
Remote: Logitech Harmony 555
TV: Samsung LE-46A856
TV - HTPC Connection: HDMI


Since I have installed Vista 64Bit and mediaportal v 1.0.1 i've got the following problem: when using mediaportal all black is grey. It looks like brightness is way too high. When i am using WMP or WMP classic black is black! Does anyone have a solution for this major problem?!!:confused:

Hope someone can help me!


Portal Member
January 5, 2006

I know that this is a frustrating problem because I suffered from it also. Have you tried the registry fix that I am posting below (which is the same fix contained in the ATI registry tweaks?

I am pretty sure that the problem is in how the VMR9 or EVR renderers are interacting with the video drivers. In this thread, I posted a quick test that will demonstrate whether or not this is the issue.

I strongly suggest that you (1) make sure that you go to ATI's support site and make sure you have the latest version of the drivers and (2) try the registry fix.

I have use NVidea instead of ATI, and the suggested NVidea registry hack did not work for me. However, when I installed the latest driver (released on May, 8) - my problem was fixed.

Hi guys,

I have recently installed MP and had terrible problems concerning the brightness of movies. The problem had to do with VMR9 Renderer and SD colour levels (BT.601) where black was 16 instead of 0, white 235 instead of 255. For ATI graphics card owners, I have found a registry hack that solves the problem.

Go to: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Video\{GUID}\0000

where GUID is the long string in which the folder 0000 contains a lot of registry entries.

Add the string (or what is it called in English) "UseBT601CSC" and set it to "1".

Reboot your system afterwards.

For a more detailed description, have a look at:
AVS Forum - View Single Post - ATI Radeon HD 2X00 (2400,2600,2900) series owners thread

I hope this helps you. It worked for me!


Users who are viewing this thread

Top Bottom