Powerscheduler shuts down PC too early during WEB EPG grabbing (1 Viewer)

Fredd_1001

Portal Pro
October 28, 2007
79
0
Almere
Netherlands Netherlands
MediaPortal Version: 1.1.0 Beta
MediaPortal Skin: Blue3 Wide
Windows Version: Windows 7 32bit
CPU Type: Core2duo 6750
HDD: 160GB IBM +1TB Samsung
Memory: 2 gig
Motherboard: Gigabyte
Video Card: ATI2600XT 512
Video Card Driver: Catalist 10.1
Sound Card: Onboard
Sound Card AC3: 2/1/1
Sound Card Driver:
1. TV Card: Floppy-DTV-S2
1. TV Card Type: DVB-S2
1. TV Card Driver: 5.07
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: Power DVD9
MPEG2 Audio Codec: MPC A
h.264 Video Codec: PowerDVD 9 / Core AVC
Satelite/CableTV Provider: Canal+ astra 19.2°E/23.5°E
HTPC Case:
Cooling: Arctic
Power Supply: Earthwatts
Remote: Logitec Harmony
TV: Philips 42pfl9703
TV - HTPC Connection: HDMI


Hi All,

I'm having troubles getting WEBEPG via power scheduer with Beta 1.1 and this SVN, single seat.
I have setup powerschuduler to get the EPG data at night. I found that data is loaded, but randomly stopped. So the list is incomplete. So tried another moment (in the morning) ,but more or less the same result (I don't think it stops always exactly at the same moment)
So PC starts up, MP is collecting EPG data, but after a certain amount of time PC is switched of during grabbing, alltough TV server is set not to switch of during EPG grabbing.
I'v allso setup the EPG scheduler at another moment, to grab data when PC allready is swithed on. Then EPG grabbing works fine!
So for some (for me :) ) unclear reason Powerscheduler cuts off to quick.

Arion_p replied:

From your logs it appears that some 3rd party app or Windows itself is trying to suspend the system. Are you using TVServer's PowerScheduler to put the system to sleep? Have you set Windows' suspend/hibernate to never in Control Panel->Power Options->PowerSchemes?

Also from your logs it appears as if TVService is starting up/initializing each time the system wakes up without first shutting down/deinitializing. Is it possible that some 3rd party app forcibly terminates TVService before suspend?

PS: If you do not have "Enable extensive logging" checked in PowerScheduler->Advanced, please tick it and post new logs
Did a clean install with Windows 7 and MP 1.1.0 Beta again and SVN24699. Before I used Windows XP.
Still having the same Issue. Powerscheduler starts PC for EPG grabbing. EPG grabbing is busy, but still the system shuts down to early. So EPG data is incomplete.
For the record: Only WEB epg grabbing fails, recording is ok.
Arion_P, I will test again with extensive logging, but maybe you can allready help me with these new logfiles? :D
 

arion_p

Retired Team Member
  • Premium Supporter
  • February 7, 2007
    3,373
    1,626
    Athens
    Greece Greece
    Country flag
    Please check your System Log in Windows Event Viewer at 8/2/2010 00:03, event source Microsoft-Windows-Kernel-Power, what is the reason of the sleep?
     

    Fredd_1001

    Portal Pro
    October 28, 2007
    79
    0
    Almere
    Netherlands Netherlands
    I have checked windows eventviewer:
    The reason of the sleep really comes from TVserver!
    In systemlog I find: action 42 Kernel Power, reason: system inactive.
    In applicationlog I find PowerEvent handled successfully by the service.

    When I set the system idle in the startpage of MP, then the system allso goes to suspend after 2 minutes (as it should, as it is configured that way!). Then I get exactly the same logging.
    So for some reason ticking prevent standby when grabbing EPG doesn't work. Powerscheduler sees the system as Idle and goes to suspend after the configured time. :eek:
    I allso had the exact same issue with WinXP instead of Win7.
    But there is more...... In Win7 the system allso goes to suspend (controlled by Powerscheduler) when using the system for other things than MP, lets say browsing with explorer.
    Only when using MP (eg watching TV) or having the TVserver config screen open, powerscheduler sees the system as active, and the system stays alive.

    In the mean time I did a new test with extended logging checked. And removed the schedule from the WebEPG plugin and only use the EPG schedular from Powerschedular at 00:01 every day..
    I manupulated the time from my system to just before midnight,so epg grabbing started on februari 9 at 00:01. So don't let the date fool you. :D
    But sadly the same fault :mad:
    Maybe the extended logging tells more...............? :D
     

    arion_p

    Retired Team Member
  • Premium Supporter
  • February 7, 2007
    3,373
    1,626
    Athens
    Greece Greece
    Country flag
    I have checked windows eventviewer:
    The reason of the sleep really comes from TVserver!
    In systemlog I find: action 42 Kernel Power, reason: system inactive.
    This means that Windows is putting the system to sleep, not PowerScheduler. You have to set Windows' power scheme to "Always on" (or whatever it is called in Win7). In Vista/Win7 MP cannot prevent the system from going to sleep if the sleep is initiated by Windows itself.

    But there is more...... In Win7 the system allso goes to suspend (controlled by Powerscheduler) when using the system for other things than MP, lets say browsing with explorer.
    Only when using MP (eg watching TV) or having the TVserver config screen open, powerscheduler sees the system as active, and the system stays alive.
    This is normal. If you need to prevent the PowerScheduler from putting the system to sleep when running other apps you need to add those in PowerScheduler/Processes (see TV-Server/Configuration/Plugins/PowerScheduler - MediaPortal Manual Documentation). Don't add "explorer" in there, the system will never go to sleep as explorer is always running. Remember that MediaPortal is not a media player, it is an HTPC system and is designed to run on a dedicated HTPC.
     

    Fredd_1001

    Portal Pro
    October 28, 2007
    79
    0
    Almere
    Netherlands Netherlands
    I have checked windows eventviewer:
    The reason of the sleep really comes from TVserver!
    In systemlog I find: action 42 Kernel Power, reason: system inactive.
    This means that Windows is putting the system to sleep, not PowerScheduler. You have to set Windows' power scheme to "Always on" (or whatever it is called in Win7). In Vista/Win7 MP cannot prevent the system from going to sleep if the sleep is initiated by Windows itself.

    But there is more...... In Win7 the system allso goes to suspend (controlled by Powerscheduler) when using the system for other things than MP, lets say browsing with explorer.
    Only when using MP (eg watching TV) or having the TVserver config screen open, powerscheduler sees the system as active, and the system stays alive.
    This is normal. If you need to prevent the PowerScheduler from putting the system to sleep when running other apps you need to add those in PowerScheduler/Processes (see TV-Server/Configuration/Plugins/PowerScheduler - MediaPortal Manual Documentation). Don't add "explorer" in there, the system will never go to sleep as explorer is always running. Remember that MediaPortal is not a media player, it is an HTPC system and is designed to run on a dedicated HTPC.
    Arion, I've added extended loggings after you posted your reply.
    Windows powerscheme is at allways on (I've checked it several times!) :)
    Please have a look at these logs, I'm very shure Powerscheduler is the bad gay :D But I really can't figure out why! :D

    Why am I so sure? Because when I remove the check on Shutdown server after being Idle in powerscheduler (in my case 2 minutes) the systems stays on forever. So no windows powerschedule is active!
     

    arion_p

    Retired Team Member
  • Premium Supporter
  • February 7, 2007
    3,373
    1,626
    Athens
    Greece Greece
    Country flag
    I can confirm that this is a bug. Normally you would not have a problem since you have set Windows' power scheme to "always on". But in Win7 (and Vista IIRC) after an automatic resume (e.g. scheduled) if there is no system activity within 1 minute 2 minutes since the resume, the system will be put back to sleep even if you have Windows configured to never sleep! This is done AFAIK to guard against false resumes (e.g by random network traffic)

    The problem here is that PowerScheduler does not inform Windows that it busy in time and Windows puts the system back to sleep.

    I will post a patch for you to test, once I find an acceptable solution.

    :D for your report.
     

    Fredd_1001

    Portal Pro
    October 28, 2007
    79
    0
    Almere
    Netherlands Netherlands
    Ok Arion, thanks for the reply.

    Be aware that the problem allso existed in my XP-SP3 setup!
    The behaviour was exactly the same. Resume at 00:01 and unwanted suspend a few minutes later. :D
     

    arion_p

    Retired Team Member
  • Premium Supporter
  • February 7, 2007
    3,373
    1,626
    Athens
    Greece Greece
    Country flag
    Sorry for the delay, I was waiting for RC1 to be out since I could not build binaries that would work on the latest public SVN.

    Exit MediaPortal and stop TVService. Replace TVService.exe in your MediaPortal TV Server directory and PowerScheduler.Interfaces.dll in both your TV Server's plugin directory and MediaPortal's process plugin directory. Keep a backup copy of the original files before replacing.

    For XP the default directories are:
    C:\Program Files\Team MediaPortal\MediaPortal TV Server\TVService.exe
    C:\Program Files\Team MediaPortal\MediaPortal TV Server\Plugins\PowerScheduler.Interfaces.dll
    C:\Program Files\Team MediaPortal\MediaPortal\Plugins\Process\PowerScheduler.Interfaces.dll
     

    Attachments

    Fredd_1001

    Portal Pro
    October 28, 2007
    79
    0
    Almere
    Netherlands Netherlands
    Hi Arion,

    Thanks for your reply.
    Just got back from a small holiday. :D

    I've tried your soulution and it's working fine now.
    Set my HTPC (win7 MP 1.01 Beta SVN 24669) to wakeup at 00:01. System stays alive correct now until WebEPG data is collected.

    :D
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom