[solved] Problem: Bei Start von MePo werden Datenbanken nicht geladen (MovingPictures und MP-TV-Series) (1 Viewer)

beckersbest

Portal Member
July 3, 2011
25
2
Home Country
Germany Germany
... nach dem Start von Windows auf dem Klienten. Der Server läuft durchgängig 24/7 und sämtliche DBs liegen ausschließlich auf dem Server. Normalerweise ist der Server auch kaum ausgelastet, da überwiegend für Datenhaltung / Sicherung verwendet und halt MP ...
 

mrbonsen

Super User
  • Team MediaPortal
  • Super User
  • December 6, 2008
    6,553
    881
    Brensbach (HE) ehemals Görlitz
    Home Country
    Germany Germany
    sorry, wenn ich zu viel frage ;)
    die musikdatabase und andere aus dem database ordner werden sofort erkannt ?
    schonmal über junction link für den clienten nachgedacht ? <- falls kein trigger möglich.
     

    larry_S

    MP Donator
  • Premium Supporter
  • December 11, 2008
    1,430
    157
    Home Country
    Germany Germany
    Ein Trigger macht erst dann Sinn, wenn man das Problem kennt.
    Dann kann man sich auf die Suche nach einem passenden Ereignis machen und/oder ggf. einen notwendige zusätzlich Aktion definieren.
     

    beckersbest

    Portal Member
    July 3, 2011
    25
    2
    Home Country
    Germany Germany
    @mrbonsen: Fragen ausdrücklich erlaubt ;) ... vielmehr danke meinerseits für die Unterstützung ...

    Bzgl. Musik-DB und Video-DB muss ich mal schauen, das nutze ich nicht so häufig, daher werde ich mir das heute Abend oder morgen mal anschauen und berichten.

    @Larry: Stimme ich voll und ganz zu, innerlich hatte ich das Problem für mich schon erkannt (Zugriff auf DB funktioniert zum Startzeitpunkt von MP noch nicht, also warten, bis DB-Zugriff bereit) :cool: ... daher hatte ich mich bisher auf die Suche nach dem passenden Trigger gemacht ... aber bin natürlich offen für andere Lösungsansätze!

    @mrbonsen: mit Junction-Link meinst du die Laufwerkbuchstaben-Einbindung z.B. D:\mediaportl-verzeichnis anstatt \\server\verzeichnis? Da hab ich bisher eher nicht so gute Erfahrungen mit gemacht, da doch kurzzeitig die Meldung "Netzlaufwerk kann nicht verbunden werden" kommt, bis die Netzwerkverbindung steht ... deshalb habe ich den bisherigen Trigger auf das Ergebnis "Netzwerkverbindung steht" gesetzt, für Teile des MP Starts funktioniert das ja auch, aber eben nicht für die DB, die Verbindung scheint da noch einen Tick länger zu dauern ... und das bereitet mir eben Probleme ...
     

    beckersbest

    Portal Member
    July 3, 2011
    25
    2
    Home Country
    Germany Germany
    So, hab gestern mal geschaut, wie das
    1. einerseits mit einer Startverzögerung von bis zu 40 Sek. ausschaut und
    2. Wie es mit den Musik- und Bild-DBs ausschaut

    zu 1) Bringt keine Besserung, d.h. auch bei 40 Sekunden Startverzögerung werden die DBs (Moving Pictures, TV-Series, Musik-DB, Bild-DB) nicht geladen ...
    zu 2) Musik- und Bild-DB werden ebenso nicht geladen wie auch Moving Pictures und TV-Series

    Schon komisch, hat dazu jemand noch eine Idee, was ist beim automatischen Start von MP anders als wenn ich MP manuell starte? Verbindungen scheinen ja zu bestehen, ansonsten würde ja ggf. auch die TV-Database nicht geladen ... ich bin ein wenig ratlos ...

    Thorsten
     

    barney13

    Portal Pro
    April 14, 2010
    507
    68
    Osnabrück
    Home Country
    Germany Germany
    Also wenn ich bisher richtig gelesen habe, liegen Deine Datenbanken auf einem zentralen Server.
    Besteht unter Umständen die Möglichkeit, dass die Platte auf dem Server noch pennt und deshalb kein Zugriff möglich ist.

    Versuch mal vorm MePo Start die Platte auf dem Server zu "wecken" indem du über Windows-Explorer auf eine Datei.Freigabe zugreifst.

    Anschliessend mal MePo starten.


    Gruß

    Barney
     

    beckersbest

    Portal Member
    July 3, 2011
    25
    2
    Home Country
    Germany Germany
    Hi Barney,

    das hab ich auch gedacht, aber folgende Feststellung gemacht (nachdem der HPTC gestartet wurde und die DB-Verbindung fehlgeschlagen ist):

    1. Fahre ich den HPTC herunter und starte ich ihn neu (Gesamtdauer: ca. 30 Sekunden), fehlt die Verbindung wieder, die HDDs vom Server sollten in der Zwischenzeit noch nicht wieder eingeschlafen sein ...
    2. Starte ich den PC über die Funktion "Neu starten", wird die Verbindung zu den DBs korrekt hergestellt

    Daher scheint es nicht am Standby von HDDs oder ähnlichem zu liegen ... außerdem ist für den Server das Standby für die HDDs explizit deaktiviert in den Energieeinstellungen ...

    Gruß
    Thorsten
     

    mrbonsen

    Super User
  • Team MediaPortal
  • Super User
  • December 6, 2008
    6,553
    881
    Brensbach (HE) ehemals Görlitz
    Home Country
    Germany Germany
    beim herunterfahren des pc wird der arbeitsspeicher auf die hd zurrück geschrieben und geleert.
    (vermute hier det übel) ;)

    beim neustart nur ein teil auf die hd zurrückgeschrieben.
    dadurch startet der pc auch schneller, weil der Post On Self Test und einige andere systemabfragen wegfallen.
    änderungsdaten befinden sich noch im ram und werden somit übernommen.

    beim späteren herunterfahren werden die geänderten daten auf die hd geschrieben und beim nächsten neustart mitgeladen.
     
    Last edited:

    beckersbest

    Portal Member
    July 3, 2011
    25
    2
    Home Country
    Germany Germany
    so, war die letzte Woche unterwegs und konnte mich nicht um mein heiß geliebtes MP kümmern :rolleyes: ...

    Hat denn noch jemand eine Idee, wie ich das DB Problem in den Griff bekommen kann? Kann ich noch mit irgendwelchen Tests / Logs dienen zur Eingrenzung des Problems?

    Danke nochmals ...
     

    beckersbest

    Portal Member
    July 3, 2011
    25
    2
    Home Country
    Germany Germany
    So, nachdem ich mich noch einmal intensiv mit dem Startvorgang von Windows beschäftigt habe, folgende Erkenntnis und Lösung:

    1. Die Zugriffsrechte auf Netzwerkresourcen scheinen erst später im Laufe des Windows-Start-Vorganges geladen zu werden
    2. MediaPortal startet und versucht auf die Datenbanken per UNC-Pfad (\\server\verzeichnis) zu einem Zeitpunkt zuzugreifen, zu dem die Benutzerrechte noch nicht aktiviert sind. Somit kann kein Zugriff auf die Netzwerkresource stattfinden.

    Abhilfe schafft ein Skript,welches das MP-Netzwerkverzeichnis mit den entsprechenden Credentials verbindet und erst nach erfolgreicher Verbindung MP startet. Folgender Code wird mittels "Windows Aufgabenplanung" bei Systemstart ausgeführt:

    Code:
    @echo off
    
    SET server=192.168.100.100
    SET password=xxx
    SET username=server\user
      
    :loop
    ping -n 1 %server%|find "TTL=" > nul
      
    IF %errorlevel%==1 GOTO nein
      
    echo %server% ist online
    if exist m: net use m: /DELETE
    REM echo %username%
    REM echo %password%
    net use m: \\192.168.100.100\MediaPortal /user:%username% %password% /persistent:no
    "C:\Program Files (x86)\Team MediaPortal\MediaPortal\MediaPortal.exe"
    exit
    
    :nein
    echo %server% ist nicht online
    rem wait 10000
    GOTO loop

    Was macht der Code:
    Prüft zunächst, ob der Server verfügbar ist, dann wird geschaut, ob das Laufwerk M bereits verbunden ist, wenn ja, wird die Verbindung gelöscht, da auch das Wiederverbinden einige Zeit dauern kann und somit nicht sichergestellt ist, dass sofort auf die DBs zugegriffen werden kann. Zu guter Letzt wird mit entsprechenden Credentials unmittelbar auf Basis der Server-IP das Netzlaufwerk erstellt.

    Vielleicht hilft es ja anderen, MP in einer MultiSeat-Windows 8-Konfiguration zu betreiben mit zentralen DB auf dem Server. Sollte es eine einfachere Lösung geben, bin ich sehr offen für, aber bisher läuft alles einwandfrei ...

    Viele Grüße
    Thorsten
     

    Users who are viewing this thread

    Similar threads

    Ja, das kann Probleme verursachen, der Datendurchsatz ist sehr hoch und einige Webseiten blocken einen auch temporär, wenn zu viele Anfragen kommen. Deswegen scrappe ich immer offline und bin danach nicht mehr auf online Daten angewiesen. Anderer Vorteil ist, dass tMM nur auf das Scrappen spezialisiert ist und natürlich mehr Potential...
    Ja, das kann Probleme verursachen, der Datendurchsatz ist sehr hoch und einige Webseiten blocken einen auch temporär, wenn zu viele...
    Hallo Leute. Ich bin zur Zeit sehr frustriert. Vielleicht kann mir jemand helfen! Aufgrund von Fehlern beim Import von Serien...
    Replies
    6
    Views
    127
    Hallo, leider komme ich selber nicht weiter deshalb hoffe ich das jemand einen Tipp für mich hat. Bei meinem TV Server habe ich derzeit 2 TV Karten im Einsatz. DigitalDevices DVB-S Hauppauge Colossus 2 Die Colossus benutze ich um die Sky Sender von dem Wunderbaren Sky-Receiver ins MP zu bekommen. Soweit so gut das funktioniert...
    Hallo, leider komme ich selber nicht weiter deshalb hoffe ich das jemand einen Tipp für mich hat. Bei meinem TV Server habe ich...
    Hallo, leider komme ich selber nicht weiter deshalb hoffe ich das jemand einen Tipp für mich hat. Bei meinem TV Server habe ich...
    Replies
    0
    Views
    276
    Ja, sind alle korrekt gemappt.
    Ja, sind alle korrekt gemappt.
    Hallo zusammen, seit vielen Jahren nutzen wir MediaPortal bei uns im Haushalt ohne Probleme. Jetzt musste nach über 10 Jahren...
    Replies
    4
    Views
    595
    Danke für die berechtigte Anmerkung. Ein aktuelles Log des Clients von heute morgen hänge ich in die Attachments. Dabei habe ich zunächst ARD in HD angesehen, was einwandfrei funktionierte, danach RTL in SD. Dabei hatte ich lediglich den Ton, kein Bild.
    Danke für die berechtigte Anmerkung. Ein aktuelles Log des Clients von heute morgen hänge ich in die Attachments. Dabei habe ich...
    Guten Abend, heute wollte ich im Sommerwohnzimmer den Laptop zum Einsatz bringen. Leider kann ich keine Sendungen in SD...
    Replies
    2
    Views
    418
    Thank you for your patience describing what possibilities there are for me. I think time will tell what is important for me and I have to weigh all the options [emoji4] Gesendet von meinem BlackBerry KEYone mit Tapatalk
    Thank you for your patience describing what possibilities there are for me. I think time will tell what is important for me and I...
    Früher hat MP innerhalb kürzester Zeit bei der Wiedergabe eines Films Tonformat, Bildauflösung und den Stream angezeigt. Seit...
    Replies
    108
    Views
    5K
    Top Bottom