Problem with DTS, mpa decoder filter and switching audio filters (1 Viewer)

chadamir

New Member
December 22, 2006
4
0
MediaPortal Version: 0.2.1.0
MediaPortal Skin: Blue
Windows Version: Windows XP sp2
CPU Type: Pentium 4 3.0ghz
HDD: Western Digital 40gb
Memory: 512
Motherboard:
Motherboard Chipset: Intel 915
Motherboard Bios:
Video Card: Intel 82915G
Video Card Driver:
Sound Card: Sound Blaster Audigy nx 2
Sound Card AC3: Optical Out
Sound Card Driver: newest

MPEG2 Video Codec: mpv decoder filter
MPEG2 Audio Codec: mpa decoder filter

TV - HTPC Connection: VGA

The file is a matroska container with an x264 and dts 6.1-es audio file. I use spdif pass to my receiver. DD ac3 works fine, but dts seems to be problematic. Even in media player classic, using the mpa filter, I get a weird problem with the audio offset sync and jitter. The file plays, but then seems to skip a frame or pause for around 1/3 of a second to readjust the sync. If I switch to ac3filter, this problem goes away. The same problem occurs with ffdshow. I've tried switching media portal to ac3filter but it ignores this request. It will not use dscaler either (or ffdshow for that matter). Ive done this both in the software and in the configuration program. Most movie backups I make do not have dts audio, but I think there's more going on here than just that.
 

chadamir

New Member
December 22, 2006
4
0
I seem to have fixed it by unregistering and/or changing the priority using radlight. All's well that ends well, but maybe this can be looked into.
 

ronilse

Retired Team Member
  • Premium Supporter
  • July 19, 2005
    4,422
    282
    Moss
    Norway Norway
    Country flag
    Hi,
    Codec problems like this, it's because of "merits" settings which the codec add to registry when they install / regged & not something MP controls.. Some codec's sets this to high & it's then used as prefered from "windows XP".
    As you have found out using radlight & changing this yourself solve this until the "problem" codec(s) it's installed again, not much the devs can do about it.....

    Regards
    Roy
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Cowboy [solved] MP1.20 issue with HD audio stream (not all media) watch/edit Videos 6
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 1
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    C strange tuner(?) problem TV-Cards 0
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    nominefi Problem scanning channels. General Support 0
    E Swedish subtitles problem General 2
    G Newb trying MP2, trouble with guide data General 5
    G MP1 TV Server "failed to upgrade the database" using MS Sql Server Installation, configuration support 3
    Top Bottom