[TV] Random Late Night Crashings (1 Viewer)

Brianonymous

Portal Member
September 7, 2009
7
0
United States of America United States of America
TV-Server Version:
MediaPortal Version:

Whatever is contained in the 1.1.0.0 beta (wife watching TV, cant check, she'll kill me)

MediaPortal Skin: BlackGlass 1.1.2

Windows Version: XP Media Center

CPU Type: Sempron
HDD: 2 SATA 160s
Memory: 2 gigs

Motherboard: Crummy

Video Card: ATI Radeon 9600SE
Video Card Driver: Catalyst

Sound Card: Junk

1. TV Card: Hauppage 1600

MPEG2 Video Codec: the Gabest one
MPEG2 Audio Codec: default

Satelite/CableTV Provider: Billy Joe Bob's Cable Company (Centre TV)

HTPC Case: Open
Cooling: Open Breeze
Power Supply: 350w
Remote: Hauppage

TV: 65" Mitsubishi HDTV

TV - HTPC Connection: DVI to HDMI

Greetings guys. Love MediaPortal.. One issue though - sometimes my kids will turn off the TV, but leave MP running all night long (in fullscreen TV mode). Randomly, during the night, we will wake up to a black screen, with the End Process dialog box (for MediaPortal) up.. Is there anything that I can do to help you guys debug?
Ive verified that there are no late night applications scheduled to run.. Except WebEPG of course.

Any logs that you would like me to provide? It is typically a trooper during the daytime. Runs great.

Thanks,

Brian
 

tourettes

Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    Posting all logs would be a good starting point. Maybe some of those shows some odd activity when the crash happens.
     

    Brianonymous

    Portal Member
    September 7, 2009
    7
    0
    United States of America United States of America
    Back again! - Ok, this time it just happened while I was watching it... What happened was the video froze up (full screen TV) and then the HD just sounded like it was really chewing on something. UI was still relatively responsive.

    Here is the last few hours in TV.log:

    2009-09-08 12:06:38.609375 [4]: card: CardTune 2 53 stubbypoot:2:-1
    2009-09-08 12:06:38.609375 [4]: card: Tune 2 to 53
    2009-09-08 12:06:38.625000 [4]: card: user: stubbypoot:2:0 tune tv:53 Freq:0 Channel:53 Country:United States Tuner:Cable Video:Tuner Audio:Automatic
    2009-09-08 12:06:38.640625 [4]: card: to different transponder
    2009-09-08 12:06:38.640625 [4]: analog: Tune:tv:53 Freq:0 Channel:53 Country:United States Tuner:Cable Video:Tuner Audio:Automatic
    2009-09-08 12:06:38.640625 [4]: analog subch:0 OnBeforeTune
    2009-09-08 12:06:39.312500 [4]: Analog: Tuned to country:1 video:397250000 Hz audio:401750000 Hz locked:True
    2009-09-08 12:06:39.375000 [4]: analog subch:0 OnAfterTune
    2009-09-08 12:06:39.421875 [4]: analog: LockedInOnSignal ok
    2009-09-08 12:06:39.421875 [4]: analog subch:0 OnGraphStart
    2009-09-08 12:06:39.468750 [4]: card: Tuner locked: True
    2009-09-08 12:06:39.468750 [4]: **************************************************
    2009-09-08 12:06:39.578125 [4]: ***** SIGNAL LEVEL: 100, SIGNAL QUALITY: 100 *****
    2009-09-08 12:06:39.578125 [4]: **************************************************
    2009-09-08 12:06:39.578125 [4]: card: tuned user: stubbypoot subchannel: 0
    2009-09-08 12:06:39.578125 [4]: user:stubbypoot add
    2009-09-08 12:06:39.578125 [4]: card2:stubbypoot 2 0
    2009-09-08 12:06:39.593750 [4]: Controller: stubbypoot 2 0
    2009-09-08 12:06:39.593750 [4]: control2:stubbypoot 2 0
    2009-09-08 12:06:39.593750 [4]: card: StartTimeShifting 2 C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live2-0.ts
    2009-09-08 12:06:39.609375 [4]: card: CAM enabled : False
    2009-09-08 12:06:39.609375 [4]: card: WaitForTimeShiftFile - waiting _eventAudio & _eventVideo
    2009-09-08 12:06:39.968750 [12]: PID seen - type = Audio
    2009-09-08 12:06:39.968750 [12]: audioVideoEventHandler Audio
    2009-09-08 12:06:39.968750 [12]: PID seen - type = Video
    2009-09-08 12:06:39.968750 [12]: audioVideoEventHandler Video
    2009-09-08 12:06:39.984375 [4]: card: WaitForTimeShiftFile - video and audio are seen after 0.375 seconds
    2009-09-08 12:06:39.984375 [4]: Controller: StartTimeShifting started on card:2 to C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live2-0.ts
    2009-09-08 12:06:39.984375 [Channel state thread]: Controller: DoSetChannelStates for 10 channels
    2009-09-08 13:41:15.625000 [11]: Controller: StopTimeShifting 2
    2009-09-08 13:41:15.671875 [11]: card Hauppauge WinTV 418 Tuner: StopTimeShifting user:stubbypoot sub:0
    2009-09-08 13:41:15.671875 [11]: card: StopTimeShifting user:stubbypoot sub:0
    2009-09-08 13:41:15.671875 [11]: card not IDLE - freeing subch: 0
    2009-09-08 13:41:15.687500 [11]: analog: StopTimeShifting()
    2009-09-08 13:41:15.718750 [11]: tvcard:FreeSubChannel: subchannels count 1 subch#0 keep graph=False
    2009-09-08 13:41:15.750000 [11]: analog subch:0 Decompose()
    2009-09-08 13:41:15.750000 [11]: tvcard:FreeSubChannel : no subchannels present, stopping graph
    2009-09-08 13:41:15.796875 [11]: tvcard:FreeAllSubChannels:
    2009-09-08 13:41:15.796875 [11]: analog: StopGraph state:Running
    2009-09-08 13:41:16.250000 [11]: analog: Graph stopped
    2009-09-08 13:41:16.343750 [11]: user:stubbypoot remove
    2009-09-08 13:41:16.375000 [11]: Controller:Timeshifting stopped on card:2
    2009-09-08 13:41:16.375000 [11]: RTSP: remove stream stream2.0
    2009-09-08 13:41:16.484375 [Channel state thread]: Controller: DoSetChannelStates for 10 channels
    2009-09-08 13:41:46.812500 [PowerEventThread]: TV service PowerEventThread 537
    2009-09-08 13:41:46.875000 [PowerEventThread]: TV service PowerEventThread 537
    2009-09-08 13:56:23.781250 [PowerEventThread]: TV service PowerEventThread 49382
    2009-09-08 13:56:23.781250 [PowerEventThread]: TV service PowerEventThread 49382
    2009-09-08 13:56:28.890625 [PowerEventThread]: TV service PowerEventThread 537
    2009-09-08 13:56:28.890625 [PowerEventThread]: TV service PowerEventThread 537
    2009-09-08 13:56:28.937500 [PowerEventThread]: TV service PowerEventThread 537
    2009-09-08 13:56:28.937500 [PowerEventThread]: TV service PowerEventThread 537

    ===============================================================
    There is actually nothing in error.log...

    Here is today from streaming server.log:
    08-09-2009 13:41:15 MPEG1or2DemuxedElementaryStream:dtor:62120a8
    08-09-2009 13:41:16 Stream server:confused:tream server: remove stream stream2.0
    08-09-2009 13:41:16 RTSPServer::removeServerMediaSession reference count==0, remove session
    08-09-2009 13:41:16 ServerMediaSession dtor:stream2.0
    08-09-2009 13:41:16 ServerMediaSubsession:dtor
    08-09-2009 13:41:17 CMemoryBuffer::dtor
    08-09-2009 13:41:17 memorybuffer: Clear() 0
    08-09-2009 13:41:17 memorybuffer: Clear() done
    =======================================================================

    And a snippet from the media write log:
    08-09-2009 13:29:06.593 MultiFileWriter: reuse old file
    08-09-2009 13:36:00.406 MultiFileWriter: PrepareTSFile()
    08-09-2009 13:36:00.406 MultiFileWriter: reuse old file
    08-09-2009 13:41:15.703 CSubChannel::confused:etVideoAudioObserver() - (0)
    08-09-2009 13:41:15.703 CProgramToTransportStream::confused:etVideoAudioObserver - 0
    08-09-2009 13:41:15.703 CSubChannel::confused:topTimeShifting() - (0) - Filename:'C:\Documents and Settings\All Users\Application Data\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live2-0.ts.tsbuffer'
    08-09-2009 13:41:15.703 CTeletextGrabber::confused:top()
    08-09-2009 13:41:15.703 CProgramToTransportStream::Close()
    08-09-2009 13:41:15.703 CMemoryBuffer::confused:top()
    08-09-2009 13:41:15.703 CProgramToTransportStream::confused:topBufferThread()
    08-09-2009 13:41:15.703 CMultiWriterFileSink::dtor
    08-09-2009 13:41:15.703 CMemoryStreamSource::dtor()
    08-09-2009 13:41:15.718 CProgramToTransportStream::Thread stopped()
    08-09-2009 13:41:15.750 CMPFileWriter::DeleteChannel() - ID: 0
    08-09-2009 13:41:15.750 CSubChannel::dtor() - (0)
    08-09-2009 13:41:15.750 CProgramToTransportStreamRecorder::dtor
    08-09-2009 13:41:15.750 CProgramToTransportStreamRecorder::dtor() completed - (0)
    08-09-2009 13:41:15.750 CProgramToTransportStream::dtor
    08-09-2009 13:41:15.750 CProgramToTransportStream::dtor() completed - (0)
    08-09-2009 13:41:15.750 CTeletextGrabber::dtor()
    08-09-2009 13:41:15.750 CTeletextGrabber::dtor() completed - (0)
    08-09-2009 13:41:15.796 CMPFileWriterFilter::pause()
    08-09-2009 13:41:16.171 CMPFileWriterFilter::confused:top()
    08-09-2009 13:41:16.171 CMPFileWriter::DeleteAllChannels()
    08-09-2009 13:41:16.171 CMPFileWriterFilter::confused:top() completed
    =====================================================================
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    08-09-2009 13:39:51.703 [4dc]Abnormal start PCR, endPcr 304004, startPcr 8383146790
    08-09-2009 13:39:51.734 [4dc]Abnormal start PCR, endPcr 304004, startPcr 8383146790
    08-09-2009 13:39:51.750 [4dc]PCR rollover normally found ! endPcr 304004, startPcr 8383146790
    08-09-2009 13:39:51.984 [4d8]DeMultiplexer::FillVideo pts jump found : 95439.984375 3.725245, 95443.703125
    I would say there is something wrong in the timestamps that the TV writes to the TS buffer files. How long the TV had been on?
     

    Brianonymous

    Portal Member
    September 7, 2009
    7
    0
    United States of America United States of America
    Probably for a very long time.. At least 2 days. ... That log timestamp would definitely correspond to around the time it happened.

    Brian
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    07-09-2009 11:09:12.375 [7dc]-------------- v1.0.8 ----------------
    ...
    08-09-2009 13:41:17.156 [7dc]demux:set hold subtitle:0

    So, tv was on for 26 hours? Most likely TsReader (or even TVE3 side) is not able to cope such situation. PCR rollover happens with 26+ hours and we are basing our timestamps TS buffers on the DVB standard (uses 26 hour clock). Not an easy thing to fix.

    Unfortunately there is no plans to make TVE3 more robust on this area :(
     

    Brianonymous

    Portal Member
    September 7, 2009
    7
    0
    United States of America United States of America
    Ahhh, gotcha.. Ill have to take a peek.. Maybe I can brew up an autoreset on rollover detection or something.. One of the main reasons we also keep it running all the time is because my little guys cant navigate the menus, so all they have to do is power up the TV..
    Interesting tho, so thank you for that information..

    Brian
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom