RC4 h264 tsreader.ax - coreavc v1.6.0.0 cannot connect video pins (workaround found) (1 Viewer)

joss

MP Donator
  • Premium Supporter
  • December 18, 2008
    2
    0
    Norway Norway
    TV-Server Version: RC4
    MediaPortal Version: RC4
    MediaPortal Skin: Blue3Wide Xmasaddon
    Windows Version: Windows XP SP3
    CPU Type: Intel dualcore 2,8GHz
    HDD: 2x Samsung 250GB SATA
    Memory: 2GB
    Motherboard: MSI
    Video Card: Ati Radeon X700 PRO
    Video Card Driver: Catalyst 8.4
    Sound Card: Realtek 5.1 HD
    Sound Card AC3: Optical out
    Sound Card Driver:
    1. TV Card: Hauppage NOVA T 500 HD
    1. TV Card Type: DVB-T
    1. TV Card Driver: 4.3.25080.0
    2. TV Card: Hauppage PVR 500 (not in use)
    2. TV Card Type: analog
    2. TV Card Driver: 2.0.48.25037
    MPEG2 Video Codec: MPV
    MPEG2 Audio Codec: MPA
    h.264 Video Codec: CoreAVC v1.6.0.0
    Satelite/CableTV Provider:
    TV - HTPC Connection: VGA - Scart


    Hi everyone, first I would just like to say thanks to all the good people making Mediaportal. It's become an amazing piece of software.

    My reason for this post is this:
    After upgrading from RC1 to RC4 my ts files and live tv would no longer play. The format is Norwegian DVB-T (H.264 video).

    Workaround:
    I found that the video pin from Mediaportal file reader would no longer connect to my coreavc decoder input video pin. I worked around this by reverting to the tsreader.ax file from Mediaportal RC1 release. Then everything works flawlessly as far as I've seen.

    Today I started thinking more about this, and found that there was a new CoreAVC version out (1.8.5), so I installed that one and put back tsreader.ax, RC4 version. Now the video pins in the graph connect and I can play the recorded ts files from graphedit, but when I try to start MP, it hangs with the text "initializing directx" on the splash screen. If I press Ctrl + Alt + Delete a couple of times it continues loading and TV playing works fine. I assume this is related to the issue reported in this thread, so I don't blame Mediaportal for this.

    Anyway I've gone back to using my workaround with old tsreader.ax, so this is no biggie for me, just thought I might post it here in case anyone else has the same problem, or some developer wants to look into it.

    I've attached the log files from when the file reader from RC4 and CoreAVC version 1.6.0.0 would not connect. If anyone is interested I can provide log files from the "directx hang" too.
     

    nanoflower

    Portal Member
    January 21, 2007
    31
    0
    Denmark Denmark
    Hi,

    Just ordered the Nova-t 500 HD myself and Im wondering if you have upgraded to MP1 and if so did this sove the issue?

    Could you attatch the old tsreader.ax file to a post perhaps, as this could come in really handy for me in the near future?



    /Nanoflower
     

    joss

    MP Donator
  • Premium Supporter
  • December 18, 2008
    2
    0
    Norway Norway
    I haven't upgraded to 1.0 release yet, but I'm in the process of building a new HTPC so will try MP 1.0 there. It's probably not relevant though, since it will be running Vista x64 on different hardware.

    I would think Paranoid Delusion is correct also, the issue is probably fixed. But in case you encounter problems let me know and I'll try to post the file for you.

    As a sidenote, this url contains invaluable information for me, it cured a really annoying bug after my upgrade to Win XP SP3:

    BSOD: Driver_IRQL_less_than_or_equal - USBEHCI.SYS - Page 33 - Hauppauge UK Forum.

    It might be useful incase you get random crashes wil watching TV running windows XP SP3.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    HTPCSourcer [solved] Sometimes persistent issues when playing specific h264 mkv files MediaPortal 2 18
    Top Bottom