Really frustration audio problem (1 Viewer)

Would you like to see VLC replace the internal player?


  • Total voters
    411
N

nefox

Guest
When I try to watch some xvid movies I get the background sounds perfectly but the dialog is almost muted. I have tried using every selectable audio codec in config to no avail. If I use VLC I can hear everything like normal.

Is there any way to either fix this or use VLC as an internal player. VLC will play anything in any format .rar, .vob, .cue any format at all.

Thanks
 

FlipGer

Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    47
    Leipzig, Germany
    Home Country
    Germany Germany
    Hi,

    muted audio is mostly because of an AC3 audio stream in the avi movies. Within the AC3Filter codec or FFDshow codec you can adjust the volume of the different channels of the AC3 stream. Perhaps this helps!

    Flip.
     
    A

    Anonymous

    Guest
    I had this exact same problem and adjusting the voice channel in the AC3 Filter or the FFD Audio Settings did help a bit, but I think I didn't solve my problem till after I installed new audio drivers and configured them to use "Surround Sound 5.1" and rebooted. I remember having to set something to "wave out" instead of "directx sound" too.
     
    N

    nefox

    Guest
    I tried that. It didn't work. It is not that all audio is muted just the dialog. The most important part. I gave up watched the movie with VLC but I would like to resolve this for the future.
     

    TXTiger73

    New Member
    July 4, 2008
    1
    0
    K-Lite Codec Tweak Tool

    I had a similar problem with MediaPortal 1.0.2 running on an old school Dell Optiplex GX620. The problem occurred in AC3-encoded movies played through MediaPortal. VideoLAN Client (VLC) played them fine and MPEG2 files with MP3-encoded audio didn't have the problem.

    I have the default sound drivers loaded for SoundMAX, so no "3-D Sound" option to change. It's a simple stereo setup, so I suspect the AC-3 codec somehow became incorrectly configured for surround sound.

    What solved the problem for me was the K-Lite Codec Tweak Tool:
    Download K-Lite Codec Pack
    Download K-Lite Codec Tweak Tool 3.0.0 - Scans your system for broken filters and remove the ones that were found. - Softpedia

    Some basic instructions:
    • Quit the MediaPortal application.
    • Launch the KLite Codec Tweak Tool (Codecs -> Tools -> Codec Tweak Tool).
    • Scroll down until you see Speaker Setup and click its checkbox.
    • Select the speaker option that matches your configuration -- e.g., 2.0 (stereo).
    • Click the Next > button, then click the Finish button.
    • Relaunch the MediaPortal application.

    Hope this helps!
     

    Users who are viewing this thread

    Top Bottom