RemoteDesktoptricks (2 Viewers)

frankenmatze

MP Donator
  • Premium Supporter
  • December 28, 2008
    365
    4
    Mittelfranken
    Germany Germany
    Hallo Zusammen...

    wie schafft ihr es eigentlich eine Remotedesktop zu Eurem MediaPortal PC herzustellen. Ich sehe dann immer nur ein schwarzes Bild und kann nichts machen .-(
     

    scanlin

    Portal Member
    December 23, 2008
    35
    3
    Germany Germany
    Das Problem hab ich auch.
    Musst mit Alt+F4 MediaPortal beenden. Dann kommste ganz normal auf den Desktop. Liegt möglichweise an verschiedenen Betriebssystemen und der Grafik. Hatte zumindest früher den Eindruck, das mein Remotedesktop bei zwei XP Rechnern besser funktionierte als bei einem Vista und einem XP Rechner.

    Grüße und Gutes Neues

    scanlin
     

    frankenmatze

    MP Donator
  • Premium Supporter
  • December 28, 2008
    365
    4
    Mittelfranken
    Germany Germany
    Also Alt-F4 war die Lösung. Jetzt komme ich aber zum nächsten Problem:

    Wenn ich dann mit meiner Sitzung fertig bin, dann kann ich diese entweder normal trennen, sehe dann aber am Fernseher nur den Windows-Desktop, oder ich starte MP noch und muss dann die Verbindung auf die harte Tour beenden (x). Danach sehe ich aber erstmal schwarz auf dem Fernseher für lange Zeit (sehr lange!).

    Die eleganteste Methode ist bisher noch ein Neustart oder machst du das noch eleganter?
     

    Maschine

    Retired Team Member
  • Premium Supporter
  • June 15, 2004
    768
    86
    Germany
    Germany Germany
    Du kannst für den Remotezugriff einen anderen User einrichten und dann über dies Konto die Verbindung zum HTPC aufbauen und die laufende Sitzung (mit MP) wird nicht berührt. Dann kannst du zwar MP nicht steuern, aber so wie ich dein Posting verstehe, hast du das ja eh nicht vor ;)

    Die Einrichtung ist allerdings nicht ganz simpel, man muss da ein bisschen mit modifizierten dll-Dateien tricksen... Google ist dein Freund ;-)
     

    zz5

    Portal Pro
    November 29, 2008
    86
    1
    VS
    Germany Germany
    If you have ever used a real remote computer system like Citrix, then you have probably been craving multiple Remote Desktop sessions since you first fired up Windows XP Professional and/or Media Center Edition. Here is a HACK (translated: USE AT YOUR OWN RISK), to enable multiple Remote Desktop sessions on your XP Pro or MCE 2005 box:

    NOTE: You will have to have knowledge of the Windows operating system and more specifically the Windows Registry. If you have no experience with the registry, then I would recommend you find someone who does or leave these alone. I do not make any kind of warranty that this will work for you or your friends. This is provided for entertainment purposes only. Don’t call me if your computer stops working. Got it?

    Print these directions so that you have them to work from.
    Restart your computer in Safe Mode - Follow this link to learn how to restart Windows XP in Safe Mode
    Turn off/disable Remote Desktop Connection (RDC) and Terminal Services
    Right click My Computer
    Select Properties
    Click on the Remote tab at the top of the window
    UNCHECK the box next to, “Allow users to connect remotely to this computer“
    Click OK
    Go to Start -> Control Panel -> Administrative Tools -> Services
    Find Terminal Services in the list
    Right click on Terminal Services and click Properties
    In the Startup Type box, select Disabled
    Click OK to close the window
    Next you will replace the current version of the Terminal Services DLL (termsrv.dll) with an unrestricted version from a previous release of Terminal Services.
    Here is a copy of the Terminal Services DLL - Save it to your Desktop or other suitable location
    Using a file manager like Windows Explorer open C:\Windows\system32\dllcache
    Rename the file termsrv.dll to termsrv_dll.bak or whatever you would like.
    Copy the downloaded termsrv.dll file (the one you just downloaded from the web) to C:\Windows\system32\dllcache
    Open the C:\Windows\system32 folder
    Delete the file termsrv.dll in C:\Windows\system32
    Now we can edit the Windows Registry to enable more than one RDP connection. Go to Start -> Run and type regedit - Hopefully you knew that already
    Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Licensing Core
    Add a DWORD Key named EnableConcurrentSessions and give it a value of 1
    Close the Registry Editor window
    Go to Start -> Run and type gpedit.msc to run the Group Policy Editor
    Browse to Computer Configuration -> Administrative Templates -> Windows Components -> Terminal Services and double click Limit number of connections
    Select the Enabled button and enter the number of connections you would like to enable….at least 2.
    Restart Windows
    Right click My Computer and select Properties.
    Click on the Remote tab at the top of the window
    CHECK the box next to, “Allow users to connect remotely to this computer“
    Click OK
    Go to Start -> Control Panel ->Administrative Tools -> Services. Select Terminal Services from the list and double click it or right-click -> Properties. Set the Startup Type to Manual.

    Restart Windows/Computer
    You should be good to go.


    Enabling Multiple Remote Desktop Sessions in Windows XP Professional and Media Center Edition 2005 -> -> Jason Golod Blogs
     

    larry_S

    MP Donator
  • Premium Supporter
  • December 11, 2008
    1,424
    152
    Germany Germany
    Country flag
    Ich nutze für die Remoteverbindung RealVNC anstelle des Windowseigenen Remotedesktops.
    Hier habe ich nur beim abspielen eines Videos einen schwarzen Schirm. Ansonsten funktioniert alles.

    Gruß
    Larry
     

    scanlin

    Portal Member
    December 23, 2008
    35
    3
    Germany Germany
    Also Alt-F4 war die Lösung. Jetzt komme ich aber zum nächsten Problem:

    Wenn ich dann mit meiner Sitzung fertig bin, dann kann ich diese entweder normal trennen, sehe dann aber am Fernseher nur den Windows-Desktop, oder ich starte MP noch und muss dann die Verbindung auf die harte Tour beenden (x). Danach sehe ich aber erstmal schwarz auf dem Fernseher für lange Zeit (sehr lange!).

    Die eleganteste Methode ist bisher noch ein Neustart oder machst du das noch eleganter?
    versteh den Post nicht so ganz. Wenn ich meine Sitzung beende sehe ich am TV den Windows Anmeldebildschirm.
    Nachdem ich aber keine Tastatur hab um mich erneut anzumelden, mach ich auch immer nen Neustart. Auch nicht besonders elegant, aber funktioniert.

    Der Tipp von Maschine hört sich aber sehr interessant an, werd´s mal googlen :)

    mfg scanlin
     

    cerberus

    Portal Pro
    October 18, 2008
    371
    12
    BW
    Germany Germany
    Country flag
    (der Bildschirm ist schwarz weil RDP keine DirectX Applikationen übertragen kann, MP Prozess zuvor am TV beenden und dann erst verbinden)

    Ohne Server-System wie 2003 kannst du nur -eine- Verbindung zur Konsole aufbauen. Sprich der Benutzer "am TV" wird immer abgemeldet. Die Terminaldienste würde ich in Ruhe lassen und nicht modifizieren. Eher nach der Arbeit "shutdown -r" und dann trennen, dank autologon hast du dann schnell wieder alles auf dem TV.

    Auch wenn man dem RD-Benutzer lokal Adminrechte gibt, kann dieser den Rechner nicht über das Startmenu ausschalten oder neu starten, warum kann ich auch nicht sagen - über die shell gehts ja.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 2)

    Top Bottom