RTP Stream Freezes After a Few Minutes (1 Viewer)

Alex@Avenview

Portal Member
October 19, 2017
13
2
31
Home Country
Canada Canada
I'm noticing an option in the Client config: TsReader Options 'Don't drop discontinued packets...'

Could that change anything?

What about the advanced option "force RTSP usage"? The streaming appliance also supports RTSP.
 

Alex@Avenview

Portal Member
October 19, 2017
13
2
31
Home Country
Canada Canada
So, I've heard back from our software engineers and they think that MediaPortal is the problem. This is what they sent me:
------------------------------------------------------------------------------------------------------------
Hi, Alex
We recreated the issue on our end and the conclusion is that:
1. It's not the stream box that's the issue, we used VLC to play the video stream, and it's smooth.
2. After deeper research to the MediaPortal software, we found it has a service and client. The service get the stream from outside via RTP protocol (stream box), and turn it to RTSP stream to it client.
3. The issue happen on the client. While the client got some error packets, it couldn't handle it. The fault-tolerant machanism in it is not so perfect. As I do the experiment, you can find the log in path: C:\ProgramData\Team MediaPortal\MediaPortal TV Server\tvserver_streamingserver.log
4. When I use VLC to play the MediaPortal service stream: rtsp://192.168.2.123/stream2.0, it can totally work. (192.163.2.123 is my PC IP)
So please contact the developer of this software, and consult what they can do .
------------------------------------------------------------------------------------------------------------
Reupload of my logs: Wikisend: free file sharing service

So my software team is convinced that MP is the issue. Any thoughts or comments I can fire back at them is appreciated because frankly, I don't think the stream box isn't the issue. If you watch the stream in VLC, it's very choppy with many artifacts so it's possible that the error handling in MP can't handle the choppiness of the stream.
 

VoB

Portal Member
November 3, 2017
10
2
50
Home Country
Germany Germany
TV Server's standard IPTV filter doesn't send keep-alive messages [because they're not standard for RTSP]. I may be able to dig up a version that does.

Hi mm1352000,

it would be very nice to have "still alive messages" on the servers IPTV-filter.

I'm currently trying to use the xoro SAT>IP Server 8100 (almost the same as the megasat). The problem is that the xoro-firmware has an option called "SAT> IP-Session-Timeout-Periode" which cannot be deactivated. Only the time can be switched between 30s and 3600s.


UPDATE: I'm currently testing a workaround: on the xoro I've exported the server-settings, edited the Timeout to 32000 seconds (=almost 9 hours) and imported the manipulated file into the xoro. --> the new value is correctly displayed. Now I have to test, if it works with the new value ...
 
Last edited:

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,223
    Home Country
    New Zealand New Zealand
    I sent you a PM.
    I personally haven't received any PM, but either way, I don't think there's much more that I can offer you. Owlsroost is the expert when it comes to problems with client-side playback.

    1. It's not the stream box that's the issue, we used VLC to play the video stream, and it's smooth.
    As I've previously said, I don't read too much into this.

    2. After deeper research to the MediaPortal software, we found it has a service and client. The service get the stream from outside via RTP protocol (stream box), and turn it to RTSP stream to it client.
    This is partially right and partially wrong.

    Yes, MediaPortal has a service ("TV Server" / "TVService") and a client ("MediaPortal").
    Yes, the service is capable of receiving RTSP, RTP, HTTP and UDP streams.

    No
    , the service does not normally use RTSP between client and server unless the client and server are on different machines (ie. what we call a multi-seat installation). Normally when the client and server are installed on the same machine the server writes the stream to files on disk (timeshift files / buffer), the client reads those files, and RTSP is not involved.

    3. The issue happen on the client. While the client got some error packets, it couldn't handle it. The fault-tolerant machanism in it is not so perfect. As I do the experiment, you can find the log in path: C:\ProgramData\Team MediaPortal\MediaPortal TV Server\tvserver_streamingserver.log
    This makes zero sense. Streaming server is a server component, not a client component. Furthermore, if the appliance were producing a good stream, the "fault-tolerant machanism" would be irrelevant.

    4. When I use VLC to play the MediaPortal service stream: rtsp://192.168.2.123/stream2.0, it can totally work. (192.163.2.123 is my PC IP)
    Again, I don't read much into this. The stream from TV Server is almost a simple proxy of the stream from your appliance. If VLC can play the stream directly from the appliance then it's no surprise that it can also play TV Server's stream.


    In my opinion the focus should be squarely on the ability of MediaPortal [client] to play the stream. Only the client has to demux and decode the video and audio content, so only the client will be able to determine whether the appliance is producing a reasonable stream.

    I'm noticing an option in the Client config: TsReader Options 'Don't drop discontinued packets...'

    Could that change anything?
    Doubt it. You're welcome to try it though.

    What about the advanced option "force RTSP usage"?
    This forces MP client to use the server's RTSP stream rather than reading directly from the time-shift files. It's more error prone and therefore I do not recommend it.
     

    Users who are viewing this thread

    Similar threads

    I get the error below when I exit mediaportal after I've minimized MP to the taskbar and then right clicked the icon to select Exit. I've used SMP for years with no real problems until this issue. My two other clients do not have this issue. It is a new install on my TV server, about 2 weeks old. Titan and DefaultWide skins texit...
    I get the error below when I exit mediaportal after I've minimized MP to the taskbar and then right clicked the icon to select...
    I get the error below when I exit mediaportal after I've minimized MP to the taskbar and then right clicked the icon to select...
    Replies
    0
    Views
    686
    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes 1 to 2 minutes to write the data to disk. To speed up the EPG stuff (not only writing but also reading the EPG guide in MediaPortal), I changed the program table (and only that table) from InnoDB to...
    Sorry for the late response. In my experience, the EPG grabbing of a single transponder takes 2 to 3 minutes. Afterwards it takes...
    I get a few "Continuity error..." after the EPG scan finished: [2021-01-30 18:56:10,278] [4c45530] [18c8] - mhw reset [2021-01-30...
    Replies
    2
    Views
    1K
    MP1 MP2 Iptv hickups DE
    Hi all, Since a while I'm using iptv to watch tv-content, most of the time it works like a charm except (who would've thought) when it doesn't. The thing is, the connection to (or my iptvprovider itself) drops out on me (MPUrlSourceSplitter_Protocol_Http: instance 'Main': CurlDebug(): CURL message: 'Closing connection 2011') and...
    Hi all, Since a while I'm using iptv to watch tv-content, most of the time it works like a charm except (who would've thought)...
    Hi all, Since a while I'm using iptv to watch tv-content, most of the time it works like a charm except (who would've thought)...
    Replies
    0
    Views
    785
    What is the status of the fix? I seem to be hitting this exact problem at channel 24 (in Seattle it is KUNS-DT).
    What is the status of the fix? I seem to be hitting this exact problem at channel 24 (in Seattle it is KUNS-DT).
    MediaPortal 2 Version: 2.2.2 Description I am setting up a new Windows 10 Pro system to replace my old Windows 7 WMC server to be...
    Replies
    33
    Views
    2K
    Guys, I have added a bin here: MP hangs after suspend or TV off based on 1.20Final to try to see if it's not related to a wrong GUI SUSPENDING call not resumed by a RUNNING call. So you need to reproduce it with debug level :)
    Guys, I have added a bin here: MP hangs after suspend or TV off based on 1.20Final to try to see if it's not related to a wrong GUI...
    I have been running 1.12 for many years. Thought I would give a newer version a try. Basic functions all work and not issue tuning...
    Replies
    21
    Views
    3K
    Top Bottom