Scraper error in MovPic v1.0.0 (1 Viewer)

RoChess

Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,348
    1,828
    Country flag
    • Thread starter
    • Moderator
    • #1
    I notice on quite a few movies I'm getting:

    03-Dec-2009 12:47:10 Error [ ScraperNode]: Scraper Script XPATH parsing failed: Root element is missing.

    I'm presuming it is because the 'IMDbEnglishTitle.1.0.2.xml' scraper can't match up certain aspects, such as missing plot, or something. I tried to look at the SVN on news regarding updates, but failed to see anything related to this part.

    If I adjust error logging to debug mode, will it show me more info then? It would be nice to know exactly what failed.

    Or has a new update of the scraper been released and I've been looking in the wrong place for it?
     

    fforde

    Community Plugin Dev
    June 7, 2007
    2,666
    1,699
    39
    Texas
    United States of America United States of America
    Basically this means that a scraper script tried to use XPath to parse some XML but the block of text the scraper was using as an input was not in fact XML. This is mostly harmless but indicates a flaw in one of the scraper scripts (most likely the XBMC script. Would you mind posting your full logs on a Google Code bug report?
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,348
    1,828
    Country flag
    • Thread starter
    • Moderator
    • #3
    It doesn't happen on every movie, but it happens enough.

    Unfortunatly I was testing something else and had cleared the log files, but I'll focus on just this issue on the next import (most likely later today). Then you have extremly clean log files to examine.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,348
    1,828
    Country flag
    • Thread starter
    • Moderator
    • #4
    My log files are a mess still if I would give them as a whole (still busy adapting my collection), so I waited a few hours till Moving Picture plugin was done modifying the log file and then re-added a movie that I previously deleted. The result is small enough that I figured I just post it right in here.

    Code:
    04-Dec-2009 12:27:44  Info [       MovieImporter]: Watcher queued Freddy VS Ghostbusters (2004, Director's Cut) - 480x258 WMV @ 96k.wmv for processing. 
    04-Dec-2009 12:27:46 Debug [VideoFormatExtension]: Identifier: Path='E:\Fantasy\Freddy VS Ghostbusters (2004, Director's Cut) - 480x258 WMV @ 96k.wmv', Format='File', Hash='91ca026a09568dd3'  
    04-Dec-2009 12:27:49 Debug [ DataProviderManager]: SEARCH: Title='Freddy VS Ghostbusters', Provider='imdb.com', Version=1.3.2, Number of Results=1 
    04-Dec-2009 12:27:50 Debug [ DataProviderManager]: SEARCH: Title='Freddy VS Ghostbusters', Provider='themoviedb.org', Version=Internal, Number of Results=0 
    04-Dec-2009 12:27:50 Error [         ScraperNode]: Scraper Script XPATH parsing failed: Root element is missing. 
    04-Dec-2009 12:27:50 Debug [ DataProviderManager]: SEARCH: Title='Freddy VS Ghostbusters', Provider='mymovies.xml (Local)', Version=0.9.0, Number of Results=0 
    04-Dec-2009 12:27:50 Debug [ DataProviderManager]: SEARCH: Title='Freddy VS Ghostbusters', Provider='XBMC', Version=1.0.0, Number of Results=0 
    04-Dec-2009 12:27:50 Debug [ DataProviderManager]: SEARCH: Title='Freddy VS Ghostbusters', Provider='MyVideos (Local)', Version=Internal, Number of Results=0 
    04-Dec-2009 12:27:50 Debug [      MovieSignature]: MATCHING: 'freddy vs ghostbusters' WITH: 'Freddy VS Ghostbusters' RESULT: TitleScore=0, YearScore=0, ImdbMatch=False, AlternateTitleUsed=False, AlternateTitle='', AutoApprove=True 
    04-Dec-2009 12:27:50 Debug [       MovieImporter]: Built MediaSignature: Path= "E:\Fantasy", Folder= "Fantasy", File= "Freddy VS Ghostbusters (2004, Director's Cut) - 480x258 WMV @ 96k.wmv", Keywords= "Freddy VS Ghostbusters", Title= "Freddy VS Ghostbusters", Year= 2004, DiscId= "", MovieHash= "91ca026a09568dd3", ImdbId= "" 
    04-Dec-2009 12:27:50  Info [       MovieImporter]: Auto-approved Freddy VS Ghostbusters (2004, Director's Cut) - 480x258 WMV @ 96k.wmv as Freddy VS Ghostbusters 
    04-Dec-2009 12:27:50  Info [       MovieImporter]: Retrieving details for "Freddy VS Ghostbusters" 
    04-Dec-2009 12:27:50 Debug [     DatabaseManager]: INSERTING: Freddy VS Ghostbusters (2004, Director's Cut) - 480x258 WMV @ 96k.wmv 
    04-Dec-2009 12:27:52 Debug [ DataProviderManager]: UPDATE: Title='Freddy VS Ghostbusters', Provider='imdb.com', Version=1.3.2, Result=SUCCESS 
    04-Dec-2009 12:27:53 Debug [ DataProviderManager]: UPDATE: Title='Freddy VS Ghostbusters', Provider='themoviedb.org', Version=Internal, Result=FAILED_NEED_ID 
    04-Dec-2009 12:27:53 Debug [ DataProviderManager]: UPDATE: Title='Freddy VS Ghostbusters', Provider='mymovies.xml (Local)', Version=0.9.0, Result=FAILED_NEED_ID 
    04-Dec-2009 12:27:56 Debug [         DBMovieInfo]: Added cover art for 'Freddy VS Ghostbusters' [] from http://ia.media-imdb.com/images/M/MV5BMTc3OTY5MTE0NV5BMl5BanBnXkFtZTcwNTc5OTcyMQ@@._V1._SX257_SY400_.jpg. 
    04-Dec-2009 12:27:57 Debug [     DatabaseManager]: INSERTING: DBUserMovieSettings () 
    04-Dec-2009 12:27:57 Debug [     DatabaseManager]: INSERTING: Freddy VS Ghostbusters 
    04-Dec-2009 12:27:57 Debug [     DatabaseManager]: INSERTING: DBSourceMovieInfo: Freddy VS Ghostbusters (tt0439576) from imdb.com 
    04-Dec-2009 12:27:57 Debug [     DatabaseManager]: INSERTING: DBSourceMovieInfo: Freddy VS Ghostbusters () from themoviedb.org 
    04-Dec-2009 12:27:57 Debug [     DatabaseManager]: INSERTING: DBSourceMovieInfo: Freddy VS Ghostbusters () from mymovies.xml (Local) 
    04-Dec-2009 12:27:57 Debug [     DatabaseManager]: INSERTING: DBSourceMovieInfo: Freddy VS Ghostbusters () from movieposterdb.com 
    04-Dec-2009 12:27:57 Debug [     DatabaseManager]: INSERTING: DBSourceMovieInfo: Freddy VS Ghostbusters () from XBMC 
    04-Dec-2009 12:27:57 Debug [     DatabaseManager]: UPDATING: Freddy VS Ghostbusters 
    04-Dec-2009 12:27:57  Info [       MovieImporter]: Retrieving media information for: Freddy VS Ghostbusters 
    04-Dec-2009 12:27:57 Debug [        DBLocalMedia]: Updating media info for 'E:\Fantasy\Freddy VS Ghostbusters (2004, Director's Cut) - 480x258 WMV @ 96k.wmv' 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: inspecting media : E:\Fantasy\Freddy VS Ghostbusters (2004, Director's Cut) - 480x258 WMV @ 96k.wmv 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: FrameRate : 29.97 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: VideoCodec : wmv3 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: IsWMV: True 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: HasSubtitles : False 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: NumSubtitles : 0 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: Scan type : progressive 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: IsInterlaced: False 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: Width : 480 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: Height : 258 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: Audiochannels : 2 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: Audiorate : 44100 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: AspectRatio : widescreen 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: AudioCodec : wma2 
    04-Dec-2009 12:27:57 Debug [    MediaInfoWrapper]: MediaInfoWrapper: IsWMA: True 
    04-Dec-2009 12:27:57 Debug [     DatabaseManager]: UPDATING: Freddy VS Ghostbusters (2004, Director's Cut) - 480x258 WMV @ 96k.wmv 
    04-Dec-2009 12:27:57  Info [       MovieImporter]: Added "Freddy VS Ghostbusters".
    I was unable to locate the Scraper debug setting as per your link: "Moving Pictures" -> "About" -> "Advanced Settings" -> "Data Source Manager Enhanced Debug Mode"

    Did that get removed in v1.0.0? To be on the safe side I did enable the "Internal" -> "Skinners Debug Mode", but doesn't seem to have made any difference on this.
     

    fforde

    Community Plugin Dev
    June 7, 2007
    2,666
    1,699
    39
    Texas
    United States of America United States of America
    Sorry the wiki is out of data, to turn on debug mode for the scraper engine goto the Importer Settings tab, click "Manually Manage Data Sources", click the "Movie Details Sources" button. Then click the gear toolbar icon and click "Enable Debug Mode". The log file you have posted is not of much use as is, so it will be necesary to enable the Scraper Engine debug mode.

    And please do not post raw logs like that in the forum, all logs need to be posted as an attachment. And as I asked above, please
    attach your logs to a new Google Code bug report.
     

    RoChess

    Extension Developer
  • Premium Supporter
  • March 10, 2006
    4,348
    1,828
    Country flag
    • Thread starter
    • Moderator
    • #6
    Darn, I can see why that option is hidden, I had to let MovingPicture do it's job for a bit there, the log file was growing over 300MB. So I filtered it down to just the action of moving the folder, which still resulted in over a megabyte.

    I don't have a Google Code account, so I hope you don't mind me attaching it here. I wasn't sure if you have 7-zip which resulted in a 24kB compressed file, so I went the safe route with ZIP format.
     

    Attachments

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    joEhSuper Issues with FilmInfo+ scraper script during import Moving Pictures 5
    Terra IMDB Scraper issue? HTML Tags in results Moving Pictures 2
    F MediaPortal 1.16 server crashing due to user error? General Support 5
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    M 1.25.0 Tv Server Configuration Italian Dvb-t2 test channel preview error Television (MyTV frontend and TV-Server) 7
    G [solved] timeshift error Newcomers Forum 2
    C Can't install any extensions - DLL error Installation, configuration support 19
    horned_reaper Errors in FH log ... Fanart Handler 1
    joecrow 1.25.0 5031: Error on Install. Bugreports 24
    M MediaPortal2 TV Config Error on Install (0x80004005) General 7
    J Blue Screen Error Submit: Bug Reports 0
    G Q about scheduling weekly series when epg lists duplicate back to back episodes each week General Support 2
    Rob Hexenmeister Dependency error on install v2.3.2.0 OnlineVideos 28
    catavolt [WiP] When changing theme in my skins, I always get this error message in logs MediaPortal 1 9
    F Error invoking action 'GetNowNextProgramForGroup' Submit: Bug Reports 3
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    vvulture UNKNOWN ERROR when starting live TV General Support 6
    doskabouter Build errors MediaPortal 1 9
    ajs Trakt error when start with MP crash Trakt 1
    horned_reaper MediaPortal configuration error log message General Support 1
    horned_reaper MiniDisplayStatus error log messages General Support 7
    horned_reaper [solved] GUITextureManager Load2 log error messages Fanart Handler 1
    horned_reaper MediaPortal.LastFM.LastFMException error log message General Support 1
    R [solved] No Response from Home Page - Error Newcomers Forum 0
    globaldonkey Music Database Error Listen Music 1
    Similar threads

























    Top Bottom