Second Audio Channel (1 Viewer)

A

Anonymous

Guest
I like to record my dvd's to AVI's with two audio channels generally the main audio and then the director's comments. In Media Player Classic I can switch between audio channels, is there a way to do this in the MP movie player?
 

ssubo

Portal Member
January 15, 2005
37
0
Movie with 2 audio channels? How can I play just 1?

I have a movie with 2 audio streams, and MP plays both of them at the same time. In WMP I can select one or the other. How can I do this in MP?

Thanks,

Ssubo
 

Brainscanner

Portal Member
September 8, 2005
24
0
I don't know if your question is still up to date, but I just found a way to switch the audio channel.
In the mce skin press the yellow button on your Hauppauge remote (or the button to display the lower status bar where you can see the length of your movie, your position and the different buttons). Take the last of these buttons with the speaker on it. There you can change the language.
 

moh

Portal Member
February 12, 2006
49
1
Home Country
Germany Germany
Hi *,
I have the same problem.
When trying to play an .avi containing two mp3-streams, _both_ of them are played (in my case: german + english). I didn't find a way to switch between the audio channels - the 'button with the speaker on it' doesn't provide this functionality.
I think the default should be that if there is more then one audio channel, only the first one should be played. And a way to switch to the others would be a nice option.
Is it possible to implement or does the latest cvs already contain this features?

thanks and regards,
moh
 

FlipGer

Retired Team Member
  • Premium Supporter
  • April 27, 2004
    2,658
    115
    48
    Leipzig, Germany
    Home Country
    Germany Germany
    Hi,

    you have to install the Haali Media Splitter:
    http://haali.cs.msu.ru/mkv/

    Then only one stream is played and in the MCE skin youn can switch the streams as Brainscanner described. Do not know, why this has been taken out of the BlueTwo skin.

    Works on my machine without problems. :)

    HTH, Flip.
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 [solved] Basic audio question... DE
    Yes, works, thanks. Deselecting "Prefer multichannel audio streams" under "Video Player" (under "Players") gives me the stereo stream, by default, in television also. Thanks for your help. N.
    Yes, works, thanks. Deselecting "Prefer multichannel audio streams" under "Video Player" (under "Players") gives me the stereo...
    Is there a way to set the default audio stream for live TV? The default default, so to speak, for me seems to be English...
    Replies
    4
    Views
    871
    MP has adjustable audio delay. I don't know whether this works for all video formats, but it certainly works for TS files, and may work for MP4 files. There is a slider that allows you to adjust the audio delay while playing a video. Press the INFO button on the remote control to display the OSD, select the "Audio" icon, and then...
    MP has adjustable audio delay. I don't know whether this works for all video formats, but it certainly works for TS files, and may...
    This is not an audio/video out of sync issue but a delay in audio in playback I have been using MP for years and noticed their...
    Replies
    1
    Views
    525
    That's great. Glad there is no issue.
    That's great. Glad there is no issue.
    I am in the process of moving my media portal installation to a new PC running Windows 11. I open TV-Server configuration go to TV...
    Replies
    65
    Views
    6K
    When attempting to play live TV from a Client Only install of Media Portal back to my Media Portal Server I get an error of "There is no player registered to play media item stream X.Y". I've tried version 2.4.1 and 2.5. I've also tried setting a static IP on both the client and the server. In 2.5 I get this error in the logs...
    When attempting to play live TV from a Client Only install of Media Portal back to my Media Portal Server I get an error of "There...
    When attempting to play live TV from a Client Only install of Media Portal back to my Media Portal Server I get an error of "There...
    Replies
    0
    Views
    372
    Well, there is nothing wrong in the log. I have personaly tested the bitstreaming after DVD resume, and I can confirm that the LAV audiodecoder shows status 'bistreaming' on the output. What is your LAV status?
    Well, there is nothing wrong in the log. I have personaly tested the bitstreaming after DVD resume, and I can confirm that the LAV...
    My apologies for posting two separate issues in one posting, however, the logs I have cover both. 1. Resume playback of...
    Replies
    13
    Views
    2K
    Top Bottom