[TV] - Slow channel view (first time only) on clients only

Discussion in 'MediaPortal 1.1.0 BETA 1' started by JacobJust, August 31, 2009.

  1. JacobJust
    • Premium Supporter

    JacobJust MP Donator

    Joined:
    September 23, 2006
    Messages:
    131
    Likes Received:
    23
    Gender:
    Male
    Occupation:
    Key Account Manager
    Location:
    Aarhus
    Ratings:
    +24 / 0
    Home Country:
    Denmark Denmark
    Hi all

    using the new Beta 1 and i like the changes.

    But im having one isue with this (and others since 1.0.2)...

    On the first channel view from clients, there is about 40-50 seconds of waiting time before the image is viewed.

    It worked great with 1.0.2 but 1.1.0 it takes a long time to view first channel.

    After the first channel is viewed, the changing of channels is very fast.

    Could anyone help with this issue ?

    Tried with wireless clients and Gb ethernet clients, all with same result.



    On the main computer with TV Server and Client there are no problems.

    Best regards
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. infinite.loop
    • Premium Supporter

    infinite.loop Retired Team Member

    Joined:
    December 26, 2004
    Messages:
    16,163
    Likes Received:
    3,861
    Gender:
    Male
    Location:
    127.0.0.1
    Ratings:
    +4,154 / 7
    Home Country:
    Austria Austria
    Show System Specs
    I did had simmilar issues and there it was caused by the used audio and video codecs.

    There is no info in MP.log what happens during these 42 seconds. :(

    Also evr log just starts after the 42seconds waittime.

    Same for TsReader.log.


    So what i need are your severlogs + clientlogs.
    Which is in fact the reason why the guideline about how the report bugs says that you must include _all logs_ ;)
     
  4. JacobJust
    • Premium Supporter

    JacobJust MP Donator

    Joined:
    September 23, 2006
    Messages:
    131
    Likes Received:
    23
    Gender:
    Male
    Occupation:
    Key Account Manager
    Location:
    Aarhus
    Ratings:
    +24 / 0
    Home Country:
    Denmark Denmark
    Hi infinityloop

    Sorry, thought this was a client only error ... :)

    Here are complete logs from TV server ... let me know if you need more info ...

    Thanks for responding
     
  5. infinite.loop
    • Premium Supporter

    infinite.loop Retired Team Member

    Joined:
    December 26, 2004
    Messages:
    16,163
    Likes Received:
    3,861
    Gender:
    Male
    Location:
    127.0.0.1
    Ratings:
    +4,154 / 7
    Home Country:
    Austria Austria
    Show System Specs
    Okay, time is a bit off between client and server.
    So, TV-Server tuned your card in ~1seconds which is very good.

    The problem seems to be here. as you can see, it takes ~40 seconds to actually create the RTSP stream.
    Question is why.

    It works nicely here on my systems. Maybe one of the dev's has an idea. :)
     
  6. infinite.loop
    • Premium Supporter

    infinite.loop Retired Team Member

    Joined:
    December 26, 2004
    Messages:
    16,163
    Likes Received:
    3,861
    Gender:
    Male
    Location:
    127.0.0.1
    Ratings:
    +4,154 / 7
    Home Country:
    Austria Austria
    Show System Specs
    Oh, just noticed.

    You are using Windows7.
    We know that RTSP streaming is not fully working there yet. But our devs are allready looking into that issue.

    Next time please include the systemspecs in your first post. :)
     
  7. JacobJust
    • Premium Supporter

    JacobJust MP Donator

    Joined:
    September 23, 2006
    Messages:
    131
    Likes Received:
    23
    Gender:
    Male
    Occupation:
    Key Account Manager
    Location:
    Aarhus
    Ratings:
    +24 / 0
    Home Country:
    Denmark Denmark
    OK. Will do next time. :)

    Thank you for the answer.

    Best regards
     
  8. JacobJust
    • Premium Supporter

    JacobJust MP Donator

    Joined:
    September 23, 2006
    Messages:
    131
    Likes Received:
    23
    Gender:
    Male
    Occupation:
    Key Account Manager
    Location:
    Aarhus
    Ratings:
    +24 / 0
    Home Country:
    Denmark Denmark
    Are there any news on a fix for this one ?

    Thanks for the reponse

    Regards
     
  9. tourettes
    • Premium Supporter

    tourettes Retired Team Member

    Joined:
    January 7, 2005
    Messages:
    17,301
    Likes Received:
    4,595
    Ratings:
    +4,810 / 3
    Latest SVN build contains nupdate live555 library (that is used for streaming the video). Maybe that helps with the issue you are seeing.
     
  10. JacobJust
    • Premium Supporter

    JacobJust MP Donator

    Joined:
    September 23, 2006
    Messages:
    131
    Likes Received:
    23
    Gender:
    Male
    Occupation:
    Key Account Manager
    Location:
    Aarhus
    Ratings:
    +24 / 0
    Home Country:
    Denmark Denmark
    Hi tourettes

    Just installed latest SVN ... and same thing happens.

    It just "waits" for approx 40 seconds before showing the channel (win7 server and win7 client).

    After that channel change is quick, so only first time client is connecting to server.

    Logs submitted.

    Regards
     
  11. infinite.loop
    • Premium Supporter

    infinite.loop Retired Team Member

    Joined:
    December 26, 2004
    Messages:
    16,163
    Likes Received:
    3,861
    Gender:
    Male
    Location:
    127.0.0.1
    Ratings:
    +4,154 / 7
    Home Country:
    Austria Austria
    Show System Specs
    Seems that you are still the only one who encounters this issue. :confused:
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!