[Solved] Media Portal freezes completely on certain channels (1 Viewer)

Nicoolai

MP Donator
  • Premium Supporter
  • February 9, 2011
    84
    3
    38
    Denmark
    Denmark Denmark
    MediaPortal Version: v1.1.3.0
    MediaPortal Skin: Black Glass Nova
    Windows Version: Win 7 Ultimate x64
    CPU Type: Intel i3 2100T
    HDD: WD Green
    Memory: 4gb
    Motherboard: DH67CF

    So I'm having some problems with some of my channels.
    It's all IP-TV, but about 5 of them, will completely freeze media portal, and I'll have to kill the process. It freezes as soon as I switch to the channel. Screen goes black and nothing happens. No images or sound.
    I have tried all the different codecs I had in MP, nothing changed.
    They all play fine in VLC.
    I have attached a RAR file with logs, both from TV and TV Server (it's the same machine).
    If you need any more logs, or other info, please let me know.
     

    Nicoolai

    MP Donator
  • Premium Supporter
  • February 9, 2011
    84
    3
    38
    Denmark
    Denmark Denmark
    Re: Media Portal freezes completely on certain channels

    I'm pretty sure I've stumbled upon a thread that sounded like this, in the past. Someone posted a patch I believe, but I can't find the thread again.

    Does noone have any ideas?
    It is 4 particular channels, that does this.
    Viasat Explorer, Viasat Nature, Viasat Golf and Cartoon Network.

    They may be more, but these are the ones i've tested.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Re: Media Portal freezes completely on certain channels

    Hi Nicoolai

    First, when you post logs in the future, please use the watchdog (info -->here<--). The reason why I ask you to do that is that the watchdog disables all plugins and uses the default skin, and it also includes your MediaPortal configuration file and the system event logs (which are sometimes needed when trying to find the cause of a problem) in the zip file of logs that it creates.

    In this case, I think the cause of the issue may be related to 2 things:
    1. The skin.
    I see two exceptions, which I think are very likely related to the skin:

    2011-07-23 20:41:09.689136 [Info.][MPMain(1)]: OnMessage exception:confused:ystem.InvalidOperationException: Collection was modified; enumeration operation may not execute.

    at System.Collections.ArrayList.ArrayListEnumeratorSimple.MoveNext()

    at MediaPortal.GUI.Library.GUIWindow.HasAnimation(AnimationType animType)

    at MediaPortal.GUI.Library.GUIWindow.OnPageDestroy(Int32 new_windowId)

    at TvPlugin.TvFullScreen.OnPageDestroy(Int32 newWindowId)

    at MediaPortal.GUI.Library.GUIWindow.OnMessage(GUIMessage message)
    2011-07-23 20:42:07.215426 [Info.][MPMain(1)]: d3dapp: An error occured in OnResize - System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.

    Parameter name: index

    at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)

    at System.ThrowHelper.ThrowArgumentOutOfRangeException()

    at System.Collections.Generic.List`1.get_Item(Int32 index)

    at MediaPortal.Playlists.PlayListPlayer.Get(Int32 iSong)

    at MediaPortal.D3DApp.SavePlayerState()

    at MediaPortal.D3DApp.OnResize(EventArgs e)
    I have no idea whether they are related to the problems, but having exceptions is very rarely good.

    2. I don't think your codecs have been set somehow.
    When you attempt to view the channel, I see the following entries in the log:

    2011-07-23 20:40:56.211365 [Info.][MPMain(1)]: TSReaderPlayer: Add codecs

    2011-07-23 20:40:56.216365 [Info.][MPMain(1)]: VMR9: added EVR Renderer to graph

    2011-07-23 20:40:56.973409 [Info.][MPMain(1)]: Failed filter: not found

    2011-07-23 20:40:56.995410 [Info.][MPMain(1)]: Added filter: MediaPortal DVBSub2 to graph

    2011-07-23 20:40:56.996410 [Info.][MPMain(1)]: Failed filter: not found

    2011-07-23 20:40:56.996410 [Info.][MPMain(1)]: TSReaderPlayer: Render TsReader outputs
    Codecs should be inserted there, but they're not. Are you sure that you set the *TV* codec preferences?

    mm
     

    Nicoolai

    MP Donator
  • Premium Supporter
  • February 9, 2011
    84
    3
    38
    Denmark
    Denmark Denmark
    Re: Media Portal freezes completely on certain channels

    Hi,
    I was not aware of watchdog, I will test with it later today, when I get home.
    I'm sure I've set the TV codecs. All other channels work.

    But I will try to run watchdog when I get home, and visit the channels again.
    I shall return with more useful logs, or (hopefully) a working MP.
     

    Nicoolai

    MP Donator
  • Premium Supporter
  • February 9, 2011
    84
    3
    38
    Denmark
    Denmark Denmark
    Re: Media Portal freezes completely on certain channels

    So here's an update, with Watchdog logs.
    I started up MediaPortal on channel 3+ HD. This works fine.
    I then switched to 'Viasat Explorer', which is one of my "problem" channels, and it froze.

    I had to kill the MediaPortal.exe process after switching over.
    Codecs I have set:

     

    Nicoolai

    MP Donator
  • Premium Supporter
  • February 9, 2011
    84
    3
    38
    Denmark
    Denmark Denmark
    Re: Media Portal freezes completely on certain channels

    Well, by magic, my problem has been solved!
    Maybe not magic..
    I installed the SAF5 package, and now all channels are working.
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,571
    8,218
    New Zealand New Zealand
    Country flag
    Hi again Nicoolai

    I'm glad to hear the problem was solved. :)
    There must have been some kind of problem with your installation of FFDShow which was fixed when you installed SAF 5.

    Best regards,
    mm
     

    Nicoolai

    MP Donator
  • Premium Supporter
  • February 9, 2011
    84
    3
    38
    Denmark
    Denmark Denmark
    And thank you for trying to help me.
    I can't help but feel like I've wasted your time a little.
    Atleast everything seems to work now :)
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    Stephen O'Kane [SOLVED] TV Stream stuttering - both Video and Audio Watch / Listen Media 14
    cladinshadows85 timeshift error <solved> General 2
    F [Solved] Movies View with Thumbnail Layou General Support 4
    squidina [solved] - MediaPortal 1.22 won't start even with new install General Support 4
    J [solved] Lag on client-only PCs General 0
    joecrow [solved] (Solved) Win 10 1809 Woes General Support 4
    L [solved] MovPicNFO mit NAS? Video & DVD 1
    joecrow (Solved) EPG wrong General Support 18
    D [SOLVED] Radio issue in MediaPortal 1.20 Pre-Release 1.20 Pre Release 47
    S Kommerzielle HTPC´s mit "selbst entwickelter Media center Distribution auf Basis von Media Portal" MediaPortal Café 9
    F Media Port 1.16 to 1.25 Installation, configuration support 1
    RoChess Weird GPU crash -- possible cause: resizing media MediaPortal 1 Talk 8
    J Navigating media drive General 4
    J Will Media Portal meet my requirements? General Support 4
    C Imported media doesn't show up immediately? General 1
    J Show media item location Feature Requests 4
    HTPCSourcer Media Accessor is flooding logs with files from attached monitor MediaPortal 2 9
    N [fixed] [MP2-822] Folder View is not displaying individual media share elements Submit: Bug Reports 4
    A MP2.2.2, understanding movies/videos/tv and WTV recordings. General 16
    T I cannot get a basic media import-what is the best configuration? General 10
    Rob Hexenmeister [solved] Latest Media Handler - skinning buttons Fanart Handler 19
    J MediaPortal TV Server and Kodi media source issues General 9
    D media portal 2.2 have movies shown on genre not name General 6
    M How to Watch my videos from my Media Portal to My TV without TV Tuner Newcomers Forum 1
    D Media Portal wake schedule General Support 29
    Similar threads

























    Top Bottom