SOLVED - source for wepepg.exe?? (1 Viewer)

Khurram

Portal Pro
May 12, 2008
211
5
Home Country
Pakistan Pakistan
I have set up an svn repo for mediaportal but I cant find any source for wepepg.exe. There is an webepg.exe in xbmc/bin/debug folder but I cant find any source file for it? Can someone help please?
 

Khurram

Portal Pro
May 12, 2008
211
5
Home Country
Pakistan Pakistan
After a little snooping around in the source, I think I have found out the starting point: WebEPG-xmltv\WebEPG-xmltv.cs file.
 

Khurram

Portal Pro
May 12, 2008
211
5
Home Country
Pakistan Pakistan
Still not having too much success with WebEPG debugging. Now when I am stepping through the code, I get the following error:

The type initializer for 'SQLite.NET.SQLiteClient' threw an exception.

And then the execution stops. The error happens most of the time in the file HtmlProfiler.cs and in the function BuildProfile(). No matter what grabber I am using, I get this error. This is really frustrating.

James, can you please help me out here? Someone else?
 

James

Retired Team Member
  • Premium Supporter
  • May 6, 2005
    1,385
    67
    Switzerland
    Hi Khurram,

    Sorry for my lack of replys, I just got back from 3 weeks away.

    I have never seem this problem/error before. I will try to have a look for you this week.

    Cheers,

    /James
     

    Khurram

    Portal Pro
    May 12, 2008
    211
    5
    Home Country
    Pakistan Pakistan
    Welcome back. I hope you had a nice vacation. Sorry for bugging you with this and thanks for taking a look into it.
     

    Khurram

    Portal Pro
    May 12, 2008
    211
    5
    Home Country
    Pakistan Pakistan
    I updated to the latest 2 days ago (to build 21527 I think) and now the (same) error only shows up after the WebEPG run has finished. So I guess the problem as it was is not there anymore. At least I can debug through it till the end.
     

    James

    Retired Team Member
  • Premium Supporter
  • May 6, 2005
    1,385
    67
    Switzerland
    Ok I found the problem. The sqlite.dll (from MediaPortal.base) needs to be in the root directory where you are testing. I also noticed that the WebEPG.sln for building WebEPG by itself without MP has been removed from the SVN.
     

    Khurram

    Portal Pro
    May 12, 2008
    211
    5
    Home Country
    Pakistan Pakistan
    Thanks James. You are also right about WebEPG.exe source not being there in the SVN, but at least I can trap the call in WebEPG-xmltv\WebEPG-xmltv.cs file. It would be nice if this can be fixed in the SVN though.

    I have set the "WebEPG-xmltv" project as the startup project in the solution. So the build directory (in Debug mode) would be C:\SVN\mediaportal\WebEPG\WebEPG\bin\Debug. Do I need to copy sqlite.dll here?
     

    James

    Retired Team Member
  • Premium Supporter
  • May 6, 2005
    1,385
    67
    Switzerland
    When you build webepg-xmltv, you will get a webepg-xmltv.exe (this is renamed in the SVN builds). The directory should be ..\WebEPG\WebEPG-xmltv\bin\Debug.
     

    Users who are viewing this thread

    Similar threads

    MP1 MP2 recording video DE
    VLC has a browser add-on that allows you to start a video selected in your browser in VLC, you then can use its record button. Doesn't always work though, my guess is it won't on protected vids but it is the only thing I have found other than the excellent download capability of Online Videos when available.
    VLC has a browser add-on that allows you to start a video selected in your browser in VLC, you then can use its record button...
    so really looking for an open source program that will record streams on the computer. not really found one that works well yet...
    Replies
    2
    Views
    413
    Hello all, Recently I have been having a few problems importing movies to Moving Pictures using the IMDB+ plugin (missing fields) so I have decided to have a go at creating an XML based on the XBMC Local xml. This has not been tested with multi languages and it has been configured for my personal collection. I'm hoping it will work...
    Hello all, Recently I have been having a few problems importing movies to Moving Pictures using the IMDB+ plugin (missing fields)...
    Hello all, Recently I have been having a few problems importing movies to Moving Pictures using the IMDB+ plugin (missing fields)...
    Replies
    0
    Views
    179
    oops! here it is. Corrected xml
    oops! here it is. Corrected xml
    Before you create this bug report: Make sure that your system (windows, codecs and drivers) is up to date, matching the...
    Replies
    2
    Views
    212
    You could try using the UNC paths for the timeshift and record folders. On the client machine go to MediaPortal configuration - TV/Radio - Advanced Options tick the UNC paths tick box and put the network paths for timeshift and record folders in the appropriate lines and click OK.
    You could try using the UNC paths for the timeshift and record folders. On the client machine go to MediaPortal configuration -...
    I am not new to MediaPortal, but this is the first time I have set up a client on a PC other than the PC with the TV Server. I...
    Replies
    7
    Views
    616
    MP1 MP2 MP2 - V2.4 New 2.4 install wont show video/tv DE
    Hi ge2301 I wasnt 100% clear above - when I said everything was now working other than displaying TV, I also meant that 'videos' still didnt play. But the client attached to the server OK and can do everything except play TV programs (and videos) - the screen with the player controls loads (and fade away as normal after 10s) just...
    Hi ge2301 I wasnt 100% clear above - when I said everything was now working other than displaying TV, I also meant that 'videos'...
    Hi i just upgraded my motherboard and drive and installed a replacement copy (server and client) of MP2.4. all works perfectly...
    Replies
    6
    Views
    847
    Top Bottom