some bugs into the skinning engine (1 Viewer)

patricon

Portal Pro
June 16, 2007
543
18
Spain Spain
TV-Server Version: N/A
MediaPortal Version: 0.2.3.0 RC3 + SVN
MediaPortal Skin: Electric Lead
Windows Version: XP Pro SP2
CPU Type: PIV 3.4 Ghz
HDD: Seagate SATA 200Gb + 2 40Gb external USB drives
Memory: 2Gb DDR2 Dual Channel
Motherboard: Gigabyte GA-8I915P Duo
Motherboard Chipset: Intel
Motherboard Bios: N/A
Video Card: nVidia 6600GT PCIex
Video Card Driver: 94.24
Sound Card: C-Media CMI9880 (Onboard sound card)
Sound Card AC3: coaxial out
Sound Card Driver: Latest available
1. TV Card:
1. TV Card Type:
1. TV Card Driver:
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: ffdshow build 1320
MPEG2 Audio Codec: ffdshow build 1563
Satelite/CableTV Provider:
HTPC Case:
Cooling: Ice cubes
Power Supply: Tacens Radix 410
Remote: Genius LuxeMate 810 Media Cruiser
TV: Samsung 40" LE40R86BD
TV - HTPC Connection: VGA & HDMI

While developing my skin i've noticed that text color for selected and not selected states does not work for toggle buttons (it works fine with simple buttons). This also happens with list control.

regards,
 

spuck

Community Skin Designer
April 6, 2007
397
59
Sweden Sweden
Still ain't working for me.. Not fixed yet?
 

patricon

Portal Pro
June 16, 2007
543
18
Spain Spain
The only important thing in MP is the TV engine, and after that... the TV engine. will be this, and others, fixed at any time?

regards :)
 

and-81

Retired Team Member
  • Premium Supporter
  • March 7, 2005
    2,257
    183
    Melbourne
    Australia Australia
    I don't know why you think that the TV Engine is the only important part of MediaPortal...

    I'm just as surprised this bug hasn't been fixed as you are... I'll raise the issue in IRC and see if one of the devs can take a look ... Skin Engine is not my area of expertise.

    Cheers,
     

    tourettes

    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    17,301
    4,800
    The only important thing in MP is the TV engine, and after that... the TV engine. will be this, and others, fixed at any time?

    regards :)
    It's pretty logical to have much higher priority for fixing crashes and similar critical issues in TV side than just a small skinning bug. No users are going to miss their fafourite tv shows because of this bug :)

    But as 1.0 is getting closer and closer some dev indeed should have a look into this issue. Bavarian?
     

    cybrmage

    Portal Pro
    May 30, 2007
    498
    86
    Canada Canada
    umm... just a thought....

    The "textcolor" (selected) and "textcolorNoFocus" (not selected) properties that work with the GUIButtonControl but do not work with the GUIToggleButtonControl is probably due to the fact that the GUIToggleButtonControl does not have any suppory for the "textcoloyNoFocus" property...

    The GUIToggleButtonControl will have to be extended to support them, so it looks like it is more of an oversight than a bug...

    For the GUIListControl, these properties have different names: "selectedcolor" and "textcolor"...

    Regards,
    CybrMage
     

    chefkoch

    Retired Team Member
  • Premium Supporter
  • October 5, 2004
    3,130
    1,630
    Dresden / Munich / Maastricht
    Germany Germany
    i commited a change, can you please test the attached core.dll and check if it working like you expected it? thx

    the others will see the change with the 1.0RC1

    kind regards
    chefkoch
     

    spuck

    Community Skin Designer
    April 6, 2007
    397
    59
    Sweden Sweden
    i commited a change, can you please test the attached core.dll and check if it working like you expected it? thx

    the others will see the change with the 1.0RC1

    kind regards
    chefkoch
    Color does change when button is selected but when the group of buttons get disabled (move to the topbar for example) the toggle button is the only one stays white.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    R Bug: Video Folders disappear General Support 11
    catalpa Bug MP2-837 Allgemeines Support- und Diskussionsforum 2
    framug [Approved] Fix Irtrans config bug Submit: code patches (MediaPortal/TV-Server/etc.) 4
    ge2301 Bugs and Improvements Nereus 6
    N [Finished] Focus problems - I think I've found the bug MediaPortal 2 30
    Scheibes [solved] Kategorisierung der Genres (Bug?) Allgemeines Support- und Diskussionsforum 13
    joecrow 3 Bugs in MP 1.21 1.21 5
    dcapslock TV Server xmltv IWakeupHandler Bug Television (MyTV frontend and TV-Server) 6
    rsbrux Various bugs, some Zombies ;-) 1.20 6
    J [solved] Mp 2.2 future bugs General 7
    S [MP2-768] Installation Setup Failed - Error 0x80070666 - VC++ 2015/2017 Redist bug 2.2 Archive 19
    D MP2.2: Possible bugs 2.2 Archive 20
    R Jira bug exposed private server keys at major companies Developer Discussions 1
    R Minor bug in recorded TV list Watch / Listen Media 0
    P MP2 - V2.1 Bug - Onlinevideos U.S. Amazon Prime Fails to Connect Older releases 5
    S Stiefmütterliche Unterstützung für Maussteuerung in MP (Titan Skin) Allgemeines Supportforum 14
    Rob Hexenmeister Skin functions: What is available? General Support 7
    Rob Hexenmeister Skinning Online Videos question OnlineVideos 2
    Rob Hexenmeister Quick question - skinning MyPics General Support 7
    ajs [Info] 0.7 Beta - MPExtended, WebMP, Bootstrap skin by ajs - Hard way MPExtended 602
    S Touchscreen skin? MediaPortal 1 Talk 6
    azzuro [fixed] 5011: Version label in Splash screen - pos, size from skin MediaPortal 1 61
    catavolt [WiP] When changing theme in my skins, I always get this error message in logs MediaPortal 1 9
    joecrow MultiShortcut Plugin (Uavailable) in DWHD skin General Support 58
    V Skin With Menu Editor MediaPortal 1 Skins 13
    Top Bottom