[fixed] Sometimes search for fanart failed because double slash (1 Viewer)

ShIvADeSt

Portal Pro
May 30, 2009
71
2
MediaPortal Version: 1.2.0
MediaPortal Skin: Defaultwide

I try do search fanart for my videos. But sometimes, even if record has correct IMDB ttnumber, search is failed and in log strange URL with double slash before tt number
Code:
2011-05-09 23:02:33.159958 [ERROR][Config Main(1)]: Fanart: Error retreiving from WebPage: http://api.themoviedb.org/2.1/Movie.imdbLookup/en/xml/2ed40b5d82aa804a2b1fcedb5ca8d97a[COLOR="Red"][SIZE="3"]//[/SIZE][/COLOR]tt0166973 Encoding:utf-8 err:Удаленный сервер возвратил ошибку: (404) Не найден. stack:   в System.Net.HttpWebRequest.GetResponse()
   в MediaPortal.Util.FanArt.GetPage(String strUrl, String strEncode, String& absoluteUri)
Log are attached
 

elliottmc

Retired Team Member
  • Premium Supporter
  • August 7, 2005
    14,927
    6,061
    Cardiff, UK
    United Kingdom United Kingdom
    Country flag
    Well, the link with the double slash is not correct (copy it into a web browser to confirm), so it won't download anything.

    As to why this link is incorrect, I have no idea. Sorry.

    How are you trying to search for fanart - with the fanart handler plugin or with My Videos? You have provided incomplete logs and no steps to reproduce, so it is not easy to help you.

    https://forum.team-mediaportal.com/announcement.php?a=6

    Mark
     

    Deda

    Lead Dev MP1 Videos
  • Premium Supporter
  • March 18, 2009
    2,423
    2,385
    Zagreb
    Croatia Croatia
    Country flag
    It's not an error, this is 2nd try to search fanart (first one is regular link with one "/" and it didn't returned result) because there was some occasions when users put in TMDB database wrong IMDBttID number as /tt1234567 so API gives you result only as http://........//tt1234567, there is a more stupid problems on TMDB (two same movies entered by different users so you can get no result even that first entered movie is correct and so on.... that's the problem with open databases).

    So, in general, fanart for tt0166973 not exists (only covers) which you can see also if you try http://api.themoviedb.org/2.1/Movie.imdbLookup/en/xml/2ed40b5d82aa804a2b1fcedb5ca8d97a/tt0166973

    Agree, that error can confuse (but I need log for that to see failed search).

    What is mistake is that 2nd search in this case in not needed as 1st returned regular XML but in it's data there is no fanart, so 2nd search should be avoided. I will do that change and improve log to not to be so confusing.

    Will mark this topic as "Bug" so I can link this thread in Mantis entry.

    Mantis: http://mantis.team-mediaportal.com/view.php?id=3555

    Fixed in SVN 27897
     

    ShIvADeSt

    Portal Pro
    May 30, 2009
    71
    2
    I have some videos, that have backdrops in TMDb, but MP cannot lookup em. I provide logs where MP cannot retrieve fanart and correct links to pages with fanart by API.

    UPD. I have checked and see that TMDB nothing returns for some video TT
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    bta489 [solved] DVB-T2 Recordings: Sometimes no Audio after muxing with mkvmerge Tools and other software 2
    R [solved] Watching a record during recording stops sometimes 2.2 Archive 30
    HTPCSourcer [solved] Sometimes persistent issues when playing specific h264 mkv files MediaPortal 2 18
    Cowboy Playback Problem with CTD or sometimes BSOD watch/edit Videos 0
    CyberSimian MP 1.20: Watched percent sometimes incorrect MediaPortal 1 47
    CyberSimian My network devices sometimes go missing OffTopic 6
    horned_reaper [solved] Improved MBID Search for Artist and Album Fanart Handler 101
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    R MP 2.2.3 Search TV program only with the correct begin of show title General 7
    B How to Search MP2 for Movies only in 7 day EPG that comes from the Antenna General 3
    S search for transponder list, symbol rate 6900000 TV-Cards 0
    Terra Crash when searching movies, reproducable Moving Pictures 2
    Hotkey Search for external Graphic Card to use UHD w. 60Hz Video-Cards 0
    C Is it possible to search or filter non-movie videos in Videos plug-in? General Support 4
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    morpheus_xx [WiP] WIP 2.3 Fanart issues? MediaPortal 2 13
    Rob Hexenmeister [solved] Customising Fanart Handler settings Fanart Handler 3
    franat No funciona ni MepoTools ni DvdArt en castellano Ayuda con MediaPortal 2
    J Suggestion on fanart folder organization. Feature Requests 4
    Lehmden [Videos] More filename possibility for MyVideos local fanart. Improvement Suggestions 26
    DHosein MP-TV no longer holding fanart selections My TVSeries 2
    Edwardfc Fanart setup/configuration General 10
    S Immer gleiche Fanart Musik - CD / MP3 2
    Similar threads

























    Top Bottom