Sound only when playing 4k UHD (HEVC 265) (1 Viewer)

sheliak

Portal Member
December 30, 2020
6
0
Home Country
Poland Poland
unfortunately it does not work, CPU usage is minimum. But I will throw in logs from MPExtended.

1. DVB-T MPEG4 (h.264) program running - Works


2022-01-05 21:37:29.95145 [(20)] INFO: Starting timeshifting on channel 423 for client MPTvScheduler with identifier Mateusz
2022-01-05 21:37:29.95245 [(10)] DEBUG: Starting timeshifting with username mpextended-Mateusz on channel id 423
2022-01-05 21:37:29.95245 [(10)] DEBUG: Starting timeshifting
2022-01-05 21:37:31.84078 [(10)] DEBUG: Timeshifting succeeded
2022-01-05 21:37:33.92463 [(20)] DEBUG: Timeshifting started!
2022-01-05 21:37:33.92463 [(20)] INFO: Called InitStream with type=TV; provider=; itemId=C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live8-0.ts.tsbuffer; offset=; clientDescription=MPTvScheduler; identifier=Mateusz; idleTimeout=
2022-01-05 21:37:34.01524 [(20)] DEBUG: Called StartStreamWithStreamSelection with ident=Mateusz; profile=Android FFmpeg ultra HQ; start=0; audioId=0; subtitleId=0
2022-01-05 21:37:34.01925 [(20)] DEBUG: StartStream with identifier Mateusz for file mediatype=TV provider= id=C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live8-0.ts.tsbuffer filetype=Content offset=0 path=C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live8-0.ts.tsbuffer
2022-01-05 21:37:34.02225 [(20)] INFO: TsBuffer: Files added 1, removed 0
2022-01-05 21:37:34.02325 [(20)] DEBUG: Using path C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live8-0.ts.tsbuffer1.ts from TS buffer C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live8-0.ts.tsbuffer as source for mediatype=TV provider= id=C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live8-0.ts.tsbuffer filetype=Content offset=0 path=C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live8-0.ts.tsbuffer
2022-01-05 21:37:34.06466 [(20)] DEBUG: Using 800x448 as output size for stream Mateusz
2022-01-05 21:37:34.06666 [(20)] DEBUG: Final stream selection: audioId=, subtitleId=0
2022-01-05 21:37:34.08755 [(20)] INFO: Assembling following pipeline:
2022-01-05 21:37:34.08755 [(20)] INFO: data 1: MPExtended.Services.StreamingService.Units.InputUnit (input False, data True, log False)
2022-01-05 21:37:34.08755 [(20)] INFO: data 5: MPExtended.Services.StreamingService.Units.EncoderUnit (input True, data True, log True)
2022-01-05 21:37:34.08855 [(20)] INFO: dataconn 1 -> 5
2022-01-05 21:37:34.08855 [(20)] INFO: log 6: MPExtended.Services.StreamingService.Units.FFMpegLogParsingUnit
2022-01-05 21:37:34.08855 [(20)] INFO: logconn 5 -> 6
2022-01-05 21:37:34.08855 [(20)] INFO: Using TsBuffer to read input
2022-01-05 21:37:34.08855 [(20)] INFO: TsBuffer: Files added 1, removed 0
2022-01-05 21:37:34.08855 [(20)] DEBUG: Setup data unit 1
2022-01-05 21:37:34.08955 [(20)] INFO: Encoding: starting input named pipe \\.\pipe\2308155a-c1c1-4afd-8298-b1810a1d3f17
2022-01-05 21:37:34.09050 [(20)] INFO: Encoding: starting output named pipe \\.\pipe\f764d76b-d15c-46aa-8f4c-024c29029692
2022-01-05 21:37:34.09050 [(20)] INFO: Encoder: Transcoder configuration dump
2022-01-05 21:37:34.09050 [(20)] INFO: Encoder: hasStdin False, hasStdout False, hasStderr True
2022-01-05 21:37:34.09050 [(20)] INFO: Encoder: path C:\Program Files (x86)\MPExtended\Service\Streaming\ffmpeg.exe
2022-01-05 21:37:34.09050 [(20)] INFO: Encoder: arguments -y -i "\\.\pipe\2308155a-c1c1-4afd-8298-b1810a1d3f17" -s 800x448 -aspect 800:448 -codec:v libx264 -b:v 1024k -profile:v baseline -preset:v veryfast -coder rle -codec:a aac -b:a 256k -ac 2 -strict experimental -async 1 -sn -f mpegts "\\.\pipe\f764d76b-d15c-46aa-8f4c-024c29029692"
2022-01-05 21:37:34.10216 [(20)] DEBUG: Setup data unit 5
2022-01-05 21:37:34.10316 [(20)] DEBUG: Setup log unit 6
2022-01-05 21:37:34.10316 [(20)] INFO: Pipeline assembled
2022-01-05 21:37:34.10416 [(20)] INFO: Starting data unit 1
2022-01-05 21:37:34.10416 [(20)] INFO: Starting data unit 5
2022-01-05 21:37:34.21163 [(20)] INFO: Encoding: Copy stream of type MPExtended.Services.StreamingService.Code.TsBuffer into transcoder input stream of type MPExtended.Services.StreamingService.Code.NamedPipe
2022-01-05 21:37:34.21163 [(20)] INFO: Encoding: Waiting till output named pipe is ready
2022-01-05 21:37:39.34676 [(20)] INFO: All data units started!
2022-01-05 21:37:39.34676 [(20)] INFO: Started stream with identifier 'Mateusz'
2022-01-05 21:39:10.57904 [(17)] DEBUG: Called FinishStream with identifier=Mateusz
2022-01-05 21:39:10.57904 [(17)] DEBUG: Stopping stream with identifier Mateusz
2022-01-05 21:39:10.58004 [(17)] INFO: Stopping data unit 1
2022-01-05 21:39:10.58004 [(17)] INFO: Stopping data unit 5
2022-01-05 21:39:10.58104 [(17)] DEBUG: Encoding: Killing transcoder
2022-01-05 21:39:10.58104 [(17)] DEBUG: TranscoderProcess: Terminating process pid=6896
2022-01-05 21:39:10.58204 [(17)] DEBUG: Pipeline stopped
2022-01-05 21:39:10.58204 [(17)] DEBUG: Killed stream with identifier Mateusz
2022-01-05 21:39:10.58204 [(17)] INFO: Cancel timeshifting with identifier Mateusz
2022-01-05 21:39:10.67306 [(9)] DEBUG: Canceling timeshifting for user mpextended-Mateusz


2. The DVB-T2 HEVC (h.265) program is running - Only the sound does not work)


2022-01-05 21:39:24.06193 [(17)] INFO: Starting timeshifting on channel 3358 for client MPTvScheduler with identifier Mateusz
2022-01-05 21:39:24.06193 [(20)] DEBUG: Starting timeshifting with username mpextended-Mateusz on channel id 3358
2022-01-05 21:39:24.06193 [(20)] DEBUG: Starting timeshifting
2022-01-05 21:39:26.99857 [(20)] DEBUG: Timeshifting succeeded
2022-01-05 21:39:27.04133 [(17)] DEBUG: Timeshifting started!
2022-01-05 21:39:27.04133 [(17)] INFO: Called InitStream with type=TV; provider=; itemId=C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live8-0.ts.tsbuffer; offset=; clientDescription=MPTvScheduler; identifier=Mateusz; idleTimeout=
2022-01-05 21:39:27.15866 [(17)] DEBUG: Called StartStreamWithStreamSelection with ident=Mateusz; profile=Android FFmpeg ultra HQ; start=0; audioId=0; subtitleId=0
2022-01-05 21:39:27.15866 [(17)] DEBUG: StartStream with identifier Mateusz for file mediatype=TV provider= id=C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live8-0.ts.tsbuffer filetype=Content offset=0 path=C:\ProgramData\Team MediaPortal\MediaPortal TV Server\timeshiftbuffer\live8-0.ts.tsbuffer
2022-01-05 21:39:27.15866 [(17)] DEBUG: Using 800x448 as output size for stream Mateusz
2022-01-05 21:39:27.15866 [(17)] DEBUG: Final stream selection: audioId=, subtitleId=0
2022-01-05 21:39:27.17567 [(17)] INFO: Assembling following pipeline:
2022-01-05 21:39:27.17567 [(17)] INFO: data 1: MPExtended.Services.StreamingService.Units.InputUnit (input False, data True, log False)
2022-01-05 21:39:27.17567 [(17)] INFO: data 5: MPExtended.Services.StreamingService.Units.EncoderUnit (input True, data True, log True)
2022-01-05 21:39:27.17567 [(17)] INFO: dataconn 1 -> 5
2022-01-05 21:39:27.17567 [(17)] INFO: log 6: MPExtended.Services.StreamingService.Units.FFMpegLogParsingUnit
2022-01-05 21:39:27.17567 [(17)] INFO: logconn 5 -> 6
2022-01-05 21:39:27.17567 [(17)] INFO: Using TsBuffer to read input
2022-01-05 21:39:27.17567 [(17)] INFO: TsBuffer: Files added 1, removed 0
2022-01-05 21:39:27.17567 [(17)] DEBUG: Setup data unit 1
2022-01-05 21:39:27.17567 [(17)] INFO: Encoding: starting input named pipe \\.\pipe\49e5c960-9f8f-4a8a-b6ed-ee9e8a1919f7
2022-01-05 21:39:27.17567 [(17)] INFO: Encoding: starting output named pipe \\.\pipe\8ff63641-5c5d-4cbe-965a-e3c518b6c208
2022-01-05 21:39:27.17567 [(17)] INFO: Encoder: Transcoder configuration dump
2022-01-05 21:39:27.17567 [(17)] INFO: Encoder: hasStdin False, hasStdout False, hasStderr True
2022-01-05 21:39:27.17567 [(17)] INFO: Encoder: path C:\Program Files (x86)\MPExtended\Service\Streaming\ffmpeg.exe
2022-01-05 21:39:27.17567 [(17)] INFO: Encoder: arguments -y -i "\\.\pipe\49e5c960-9f8f-4a8a-b6ed-ee9e8a1919f7" -s 800x448 -aspect 800:448 -codec:v libx264 -b:v 1024k -profile:v baseline -preset:v veryfast -coder rle -codec:a aac -b:a 256k -ac 2 -strict experimental -async 1 -sn -f mpegts "\\.\pipe\8ff63641-5c5d-4cbe-965a-e3c518b6c208"
2022-01-05 21:39:27.19368 [(17)] DEBUG: Setup data unit 5
2022-01-05 21:39:27.19467 [(17)] DEBUG: Setup log unit 6
2022-01-05 21:39:27.19467 [(17)] INFO: Pipeline assembled
2022-01-05 21:39:27.19467 [(17)] INFO: Starting data unit 1
2022-01-05 21:39:27.19467 [(17)] INFO: Starting data unit 5
2022-01-05 21:39:27.30068 [(17)] INFO: Encoding: Copy stream of type MPExtended.Services.StreamingService.Code.TsBuffer into transcoder input stream of type MPExtended.Services.StreamingService.Code.NamedPipe
2022-01-05 21:39:27.30068 [(17)] INFO: Encoding: Waiting till output named pipe is ready
2022-01-05 21:39:52.54663 [(17)] INFO: All data units started!
2022-01-05 21:39:52.54663 [(17)] INFO: Started stream with identifier 'Mateusz'


Maybe you could decode it. It seems to me that when I try to decode HEVC he is trying to use h.264, but maybe I'm wrong ...
 

Patrik-See

MP Donator
  • Premium Supporter
  • May 12, 2009
    253
    24
    Home Country
    Germany Germany
    I myself use an AMD Ryzen 2400G CPU with integrated graphics card everywhere.
    This allows you to watch the TV perfectly 4K with MediaPortal.
    If I can provide settings to help just ask.
     

    Users who are viewing this thread

    Similar threads

    Problem fixed.:) The working implementation will be rolled out in the next release 2.3.
    Problem fixed.:) The working implementation will be rolled out in the next release 2.3.
    MediaPortal 2 Version: 2.1.3 Description With more videos coming out in 4k and using HEVC 10 bit I started looking into why MP2...
    Replies
    93
    Views
    10K
    Just for an update, my new EVGA 1060 SC 3gb plays every single 4k media file I can throw at it. Media doesn't even kick the fan on haha.
    Just for an update, my new EVGA 1060 SC 3gb plays every single 4k media file I can throw at it. Media doesn't even kick the fan on...
    Hello All, Long time MP1 user, first time poster. I Can usually figure everything out on my own but I am have some trouble with...
    Replies
    7
    Views
    1K
    To be clear: video support should already work fine with LAV. TV support is a different story.
    To be clear: video support should already work fine with LAV. TV support is a different story.
    Hi all, I have just built my first 4K capable HTPC with Intel's D54250WYK NUC with HD 5000 graphics. Armed with my first handful...
    Replies
    4
    Views
    5K
    ok guys.. i think I have sound again.. i unchecked every formats, leaving only DTS.-HD and it seems like there is sound now
    ok guys.. i think I have sound again.. i unchecked every formats, leaving only DTS.-HD and it seems like there is sound now
    System: Mini NUC intel media dedicated computer, audio and video built in motherboard. I use HDMI for sound and video as always...
    Replies
    3
    Views
    1K
    • Sticky
    Unfortunately that is not the case... In fact in some cases the old way could even be more stable than the webview way (if there's a proper api that can be used, those are more stable than parsing html or emulating clicks on a website)
    Unfortunately that is not the case... In fact in some cases the old way could even be more stable than the webview way (if there's...
    GitHub repository | Wiki | Skinning Guide | Available Sites | German Thread History I restarted development on the OnlineVideos...
    Replies
    713
    Views
    138K
    Top Bottom