Sporadic Black screen when playing video (1 Viewer)

SilentBob

Portal Pro
January 1, 2011
61
76
Home Country
Germany Germany
Country flag
When playing a video it the display gets black, sound is playing and I see these Exceptions:

Code:
[2017-10-10 21:48:22,993] [Error  ] [77       ] [ERROR] - RenderFrame exception Arithmetic operation resulted in an overflow. Core    
   at MediaPortal.Player.PlaneScene.DrawTexture(UInt32 texAddr, Int64 lColorDiffuse)
   at MediaPortal.Player.PlaneScene.RenderLayer(Single timePassed)
   at MediaPortal.GUI.Library.GUILayerManager.Render(Single timePassed, GUILayers layers)
   at MediaPortalApp.RenderFrame(Single timePassed, GUILayers layers, Boolean& uiVisible)
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,222
    Home Country
    New Zealand New Zealand
    Country flag
    Hello

    The full context is needed. Please could you collect full log files using the Watchdog option 1, then attach them in your next reply.
     

    SilentBob

    Portal Pro
    January 1, 2011
    61
    76
    Home Country
    Germany Germany
    Country flag
    As I currently do not have a TV Card connected, I am only watching via TV Series, Moving Pictures and Online Videos therefore I now created a log with option 2
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,222
    Home Country
    New Zealand New Zealand
    Country flag
    Thanks for the log files. (y)

    Your FanartHandler database file is corrupted. Please fix that first because it is likely to be the cause of the problem (system out of memory):
    [2017-10-10 23:56:38,976] [Log ] [DirectoryWorker] [INFO ] - SQLiteClient: Closing database: FanartHandler.db3
    [2017-10-10 23:56:39,031] [Log ] [TvClient-TvHome: HeartBeat transmitter thread] [INFO ] - RemoteControl - Connected
    [2017-10-10 23:56:39,103] [Log ] [DirectoryWorker] [INFO ] - SQLiteClient: Closing database:
    [2017-10-10 23:56:39,165] [Log ] [DirectoryWorker] [INFO ] - SQLiteClient: Closing database:
    [2017-10-10 23:56:39,261] [Log ] [DirectoryWorker] [INFO ] - SQLiteClient: Closing database:
    [2017-10-10 23:56:39,320] [Log ] [DirectoryWorker] [INFO ] - SQLiteClient: Closing database:
    [2017-10-10 23:56:39,382] [Log ] [DirectoryWorker] [INFO ] - SQLiteClient: Closing database:
    [2017-10-10 23:56:39,455] [Log ] [DirectoryWorker] [INFO ] - SQLiteClient: Closing database:
    [2017-10-10 23:56:39,507] [Log ] [DirectoryWorker] [INFO ] - SQLiteClient: Closing database:
    ...

    Repair SQLite Database
     

    SilentBob

    Portal Pro
    January 1, 2011
    61
    76
    Home Country
    Germany Germany
    Country flag
    Ok, normally I check this on a regular base, seems to miss that.
    nevertheless I did the described steps to repair and will continue to observe...

    although during init errors occurred
    Code:
    C:\ProgramData\Team MediaPortal\MediaPortal\database>sqlite3.exe FanartHandler.db3  -init FanartHandler.db3.good
    -- Loading resources from FanartHandler.db3.good
    Error: near line 3: table Version already exists
    Error: near line 4: PRIMARY KEY must be unique
    Error: near line 5: table "Image" already exists
    Error: near line 13661: index i_Category already exists
    Error: near line 13662: index i_CategoryTimeStamp already exists
    Error: near line 13663: index i_EnabledAvailableRandomCategory already exists
    Error: near line 13664: index i_Key1CategoryDummyItem already exists
    Error: near line 13665: index i_Key1Key2CategoryDummyItem already exists
    Error: near line 13666: index i_Key1Enabled already exists
    Error: near line 13667: index i_Key1Key2Enabled already exists
    Error: near line 13668: index i_Key1EnabledCategory already exists
    Error: near line 13669: index i_Key1Key2EnabledCategory already exists
    Error: near line 13670: index i_Key1Category already exists
    Error: near line 13671: index i_Key1Key2Category already exists
    Error: near line 13672: index i_MBID already exists
    Error: near line 13673: index i_Key1MBID already exists
    Error: near line 13674: index i_Key1Key2MBID already exists
    Error: near line 13675: index i_Key1LastAccess already exists
    Error: near line 13676: index i_Key1EnabledLastAccess already exists
    Error: near line 13677: index i_Key1CategoryLastAccess already exists
    Error: near line 13678: index i_Key1EnabledCategoryLastAccess already exists
    Error: near line 13679: index i_FullPathProtected already exists

    two remarks for the wiki? Can I Update them?

    pragma integrity_check should end with a colon
    pragma integrity_check;

    and the repair steps are stupid formatted, it should be a single line:
    Code:
    echo .dump | sqlite3.exe bad.db > FanartHandler.db3.good

    also the init command is miss formatted andwas a little bit different for me.
    Not
    Code:
    sqlite3.exe -init good.sql VideoDatabaseV5.db3

    But
    Code:
    sqlite3.exe FanartHandler.db3  -init good.sql
     

    mm1352000

    Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,222
    Home Country
    New Zealand New Zealand
    Country flag
    Can I Update them?
    Yes, sure. Anybody can edit the wiki content. Login with your forum account and you should be able to go ahead and fix the things you noticed.

    Thanks! :)
     

    Users who are viewing this thread

    Similar threads

    https://issues.team-mediaportal.com/browse/MP1-5078 and added to the next release of MediaPortal
    https://issues.team-mediaportal.com/browse/MP1-5078 and added to the next release of MediaPortal
    Hi there, Every now and then, when playing a video no image is rendered. The audio plays fine, but the screen stays black. Not...
    Replies
    49
    Views
    3K
    You were right, I have re-installed the My Anime 3 plugin and the search in MP now works again! :)
    You were right, I have re-installed the My Anime 3 plugin and the search in MP now works again! :)
    Hi, I just discovered that MediaPortal crashes when I search a movie in Moving Pictures. I enter the phrase and when I want to...
    Replies
    2
    Views
    829
    Exception: System.ArgumentException: Illegal characters in path. Check out the path, it seems the pathis a symbol that is not permitted in Windovs.
    Exception: System.ArgumentException: Illegal characters in path. Check out the path, it seems the pathis a symbol that is not...
    I have an issue where MediaPortal is crashing on a regular basis. When I run it in debug mode, it seems to work fine, but when I...
    Replies
    14
    Views
    3K
    and you may try to repair your sql database Repair SQLite Database - MediaPortal 1 - MediaPortal Wiki it looks corrupt to me
    and you may try to repair your sql database Repair SQLite Database - MediaPortal 1 - MediaPortal Wiki it looks corrupt to me
    Media Portal version: 1.16.0 MP-TVSeries version: 4.3.0.0 LAV Filters: 0.69.0 madVR: 0.91.8 Operating System: Windows 10...
    Replies
    7
    Views
    1K
    That was it. My speakers were unplugged at the PC end while I was installing the new card so sound was switched off line - no audio output. Thanks so much to both of you for quick and spot on replies
    That was it. My speakers were unplugged at the PC end while I was installing the new card so sound was switched off line - no...
    Hi All, I have Media Portal 1.13.0 Final on Win10. Client and server are both on same PC. I upgraded video card from NVidia...
    Replies
    3
    Views
    1K
    Top Bottom