strange problem with ffdshow upsampling from stereo to 5.1 after 1.0RC1 (1 Viewer)

Al_Capone

MP Donator
  • Premium Supporter
  • September 26, 2006
    527
    19
    Norway Norway
    TV-Server Version: 1.0 RC1 SVN 19158
    MediaPortal Version: 1.0 RC1 SVN 19158 +updated TsReader.ax
    MediaPortal Skin: Bluetwo Wide
    Windows Version: XP SP2
    CPU Type: Pentium Mobile 1,73Ghz
    HDD: 160GB toshiba 2,5" SATA
    Memory: 1GB
    Motherboard: Aopen
    Video Card: Nvidia 8400GS
    Video Card Driver: 169.28
    Sound Card: Realtek ALC880 (onboard)
    Sound Card AC3: Realtek ALC880 (onboard)
    Sound Card Driver: 5.10.00.5345
    1. TV Card: Hauppauge WinPVR USB2 (hardware compression)
    1. TV Card Type: Analog
    1. TV Card Driver: 24023
    2. TV Card: FireDTV S2, Firmware 1.4.0
    2. TV Card Type: Sat
    2. TV Card Driver: 4.4N
    MPEG2 Video Codec: ffdshow tryouts 1723
    MPEG2 Audio Codec: ffdshow tryouts 1723
    h.264 Video Codec: ffdshow tryouts 1723
    Satelite/CableTV Provider: canal digital
    HTPC Case: XC Cube mini
    Cooling: internal fan
    Power Supply: XC Cube-mini's standard
    Remote: FireFly
    TV: Widescreen 26" monitor, DLP projector
    TV - HTPC Connection: DVI

    I am using the same ffdshow and audio system since 0.2.3 (where it worked as supposed to)

    2.3.0 config: (not working the same way with MP1.0RC1 +SVN)

    I used ffdshow to decompress videos, I also added "ffdshow audio processor" to postprocessing
    ffdshow settings:
    "mixer"-(checked)
    "output speakers configuration" - (3/2/1 5.1)
    "expand stereo" - (checked)

    now, this does not work anymore, what's even more strange that the only way to get stereo expansion is to select:
    "output speakers configuration" - (2/0/0 stereo)
    !! - this way all speakers actually work !!

    Similiar problem with AC3filter - stereo expansion won't work.

    I know it's a far shot - but I guess it might have something to do with 1.0RC1 - again - the very same codecs, on this very same OS , was used in 0.2.3 - and worked fine.

    any ideas ?

    (why I just can't live with "stereo" selection because it works ? - because: even it expands stereo, then LFE volume setting in ffdshow does not work in stereo mode - and this channel is too loud in movies)
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    Hi

    Just updated my setup, which uses Vista codec pack (ffdshow AC3).

    Cannot get anything regarding 5.1 from TV with mpeg audio, just some gibberish sound coming from rear speakers.
    Ripped Movies (mp4\avi) all work as they should with stereo expand.

    Not sure which part may have broken here, as ffdshow shows audio being correctly recognised.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    C strange tuner(?) problem TV-Cards 0
    ajs [fixed] 4936 - Strange behavior of the font in the skin MediaPortal 1 35
    T [Resolved] Strange apostrophe issue My TVSeries 8
    W Strange recording behavior - Schedule shows type once when should be always General Support 1
    CyberSimian Strange behaviour of the VALIGN tag MediaPortal 1 3
    S Watched flag, strange behaviour My Films 0
    A [solved] Strange entries in series index General 18
    F Problems with new install of MP2 Newcomers Forum 3
    A [solved] DiseqC problems after upgrade to 1.25 General Support 6
    M Problems with VFD Display after standby- Futaba DM140GINK Mini Display 0
    R Connection (api) problems with thetvdb.com General 3
    123vak123 [solved] 5008: The problem with scrolling text in the "listcontrol" in 4K General Support 22
    framug 1.24.0 1.25.0 pre : problem with build ? 1.24 Pre Release 89
    J Problems with 1.24 StreamedMP 19
    Rob Hexenmeister Navigation problems adding menu buttons to EPG General Support 1
    404 [solved] EPG problem after Win10 'upgrade' General Support 1
    framug [EPG] Some problems with DVB EPG Improvement Suggestions 49
    R Problems accessing MySQL database remotely MediaPortal 1 Talk 0
    T [solved] Startup problem General 6
    G Problems with DRR MediaPortal 1 Talk 1
    rsbrux 1.23.0 MPE Manager Problem with LAV Filters Bugreports 2
    S Problem with Remote Control One-for-all Streamer Newcomers Forum 6
    joecrow Default Wide HD Xmas Theme Problem General Support 3
    K Sleep mode problem after formating General Support 2
    P IPTV Channel Problem TV-Server 0
    Top Bottom