Stuttering (or tearing)-free TV

Discussion in 'Tips and Tricks' started by Artman, February 7, 2005.

  1. Artman

    Artman Portal Member

    Joined:
    February 7, 2005
    Messages:
    13
    Likes Received:
    0
    Occupation:
    Graduated
    Location:
    Rotterdam, Netherlands
    Ratings:
    +0 / 0
    I took me some time to finally get rid of the stuttering or tearing (is it tearing?) when watching TV. It really drove me crazy. But now I've a solution that worked for me so I hope some other people also can take advantage of these tips:



    When updating to a new version of MP your database setting are being saved so you don't have to reorder your channels again. Here I think is the problem.
    Because after deleting the TVDatabaseV12.db file which can be found in the database folder I can watch TV without stuttering. MP will make a new TVDatabaseV12.db file and you have to reorder your channels. This is a time-demanding job but everything is better than stuttering TV!

    So get rid of this file, reorder and hopefully you will now get the most out of MP. It worked fine for me.
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. mama

    mama Portal Pro

    Joined:
    May 31, 2004
    Messages:
    334
    Likes Received:
    0
    Occupation:
    Sales Manager
    Location:
    Germany
    Ratings:
    +0 / 0
    Normally it´s enough to delete all TV and radio channels inside the configuration.exe. Then press OK, reopen the config and rescan and reorder.
     
  4. htpcNoob

    htpcNoob Portal Pro

    Joined:
    January 23, 2005
    Messages:
    52
    Likes Received:
    0
    Ratings:
    +0 / 0
    If you enable VSync for your video card drivers, that may solve the problem as well.
     
  5. tklon

    tklon Portal Pro

    Joined:
    September 3, 2004
    Messages:
    353
    Likes Received:
    3
    Location:
    Germany
    Ratings:
    +6 / 0
    Home Country:
    Germany Germany
    Show System Specs
    Since today I had stuttering picture in my TV with overlay. I upgraded the Catalyst drivers to Version 5.2 yesterday so I supposed the problem there.

    After installing the new driver there were missing some registry settings for dxva. Some time ago I found a tip to enable dxva for ati radeon cards.

    Here it is:

    Code (Text):
    1. Windows Registry Editor Version 5.00
    2.  
    3.  
    4. [HKEY_LOCAL_MACHINE\SOFTWARE\ATI Technologies\DirectX VA]
    5. "DXVA"=dword:00000001
    6.  
    7. [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\ati2mtag\Device0]
    8. "DXVA"=dword:00000001
    9.  
    10. [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\ati2mtag\Device0]
    11. "DXVA"=dword:00000001
    12.  
    13. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ati2mtag\Device0]
    14. "DXVA"=dword:00000001
    15.  
    What to do with it?

    1. Copy the code to a plain text file and rename it to "dxva_on.reg".
    2. Double click on the file in explorer to write the setting to the registry.
    3. Make a reboot. (Perhaps it works without it, I didn't try.)
    4. Have a look a the cpu usage when watching my TV or recorded shows. :)
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!