Timeshift bugs viewing live TV

Discussion in 'fixed TV-Server / Client Bugs' started by swifty, January 2, 2007.

  1. swifty

    swifty Portal Pro

    Joined:
    January 6, 2006
    Messages:
    205
    Likes Received:
    3
    Ratings:
    +10 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    MediaPortal Version: 0.2.2.0 + SVN 02/01/07
    MediaPortal Skin: B2 Wide
    Windows Version: XP Pro
    CPU Type: AMD Athlon 2000+
    HDD: Maxtor 40GB
    Memory: 1GB DDR
    Motherboard: ECS KM400-M Deluxe
    Video Card: Nvidia GeForce FX5200 128MB
    1. TV Card: Freecom USB DVB-T Stick
    1. TV Card Type: DVB-T (USB)
    MPEG2 Video Codec: NVidia Purevideo 1.233
    MPEG2 Audio Codec: MPA



    Starting around 2 weeks back I noticed some wierd issues with timeshifting when viewing live TV with TVE3 and the Mediaportal plugin, when I change channels mediaportal jumps back in the timeshift buffer (to a random point it chooses) and starts playing TV from there instead of changing channel and playing the live tv.
    This doesn't happen every time I change channel and doesn't appear to be linked to any perticular stations, to only way to recover from the bug (as once its ocurred I am then stuck in the buffer) is to turn off live tv and turn it back on again, I then get the correct channel and whatever is playing live...
    Any ideas on what would cause this behaviour / any one else experience this ?
    (btw, I have a totally fresh install and new mobo + cpu since I first saw this issue..)
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. Nemulate

    Nemulate Portal Pro

    Joined:
    December 29, 2005
    Messages:
    607
    Likes Received:
    9
    Gender:
    Male
    Occupation:
    IT Manager
    Location:
    IOW
    Ratings:
    +9 / 0
    Home Country:
    England England
    Yep experienced the very same thing, put it down to just being beta software and sure Frodo is aware as he's improving it greatly almost evey day!
     
  4. josu

    josu Portal Pro

    Joined:
    March 14, 2006
    Messages:
    192
    Likes Received:
    0
    Occupation:
    Dipl-Ing FH
    Location:
    Kassel, Germany
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    Hello,
    I have the same error :-(
    After switching the channels, the client plays the timeshiftbuffer. If the buffer is empty, the client switches to selected channel. This error is only on the client !!
    I hope, the bug will solved in the next svn :)
    Many greetings !!!
     
  5. swifty

    swifty Portal Pro

    Joined:
    January 6, 2006
    Messages:
    205
    Likes Received:
    3
    Ratings:
    +10 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Well at least it isn't just me :)

    If any dev's would like log files etc.. if they don't have this problem themselves just shout for what you need.
     
  6. josu

    josu Portal Pro

    Joined:
    March 14, 2006
    Messages:
    192
    Likes Received:
    0
    Occupation:
    Dipl-Ing FH
    Location:
    Kassel, Germany
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    hello so late,

    I think, the bug exists since this bugfix from frodo:

    01/01/2007 [20:33h] _Frodo_ added: tvplugin play recording from livepoint and beginning

    I have tried the latest december-svn without this errors :)

    But I say: A GREAT WORK OF THE PROGRAMMERS :)
     
  7. swifty

    swifty Portal Pro

    Joined:
    January 6, 2006
    Messages:
    205
    Likes Received:
    3
    Ratings:
    +10 / 0
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
    Frodo has edited the title to include [Fixed] so I will try out the latest SVN later on today and report back.
    Here's hoping :)
     
  8. josu

    josu Portal Pro

    Joined:
    March 14, 2006
    Messages:
    192
    Likes Received:
    0
    Occupation:
    Dipl-Ing FH
    Location:
    Kassel, Germany
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    Looks good with the latest svn 12518, but every 15 minutes I get a message-window from JIT-debugger (look to the attachment).


    First part of the message:
    ......************** Ausnahmetext **************
    System.MissingMethodException: Methode nicht gefunden: Void MediaPortal.GUI.Library.Log.WriteFile(MediaPortal.Services.LogType, System.String, System.Object[]).
    bei ProcessPlugins.DiskSpace.DiskManagement.CheckDriveFreeDiskSpace(String drive)
    bei ProcessPlugins.DiskSpace.DiskManagement.CheckFreeDiskSpace()
    bei ProcessPlugins.DiskSpace.DiskManagement.OnTimerElapsed(Object sender, EventArgs e)
    bei System.Windows.Forms.Timer.OnTick(EventArgs e)
    bei System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
    bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    ......

    I have this message on the master and on the clients. If you click on continue, mp runs without errors the next 15 minutes :)

    many greetings



    I have opened a new thread for this problem !!!!!!
     
  9. SpongeBob

    SpongeBob New Member

    Joined:
    January 7, 2007
    Messages:
    2
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    Hi,

    the TVEngine3 works otherwise completely well, but I have the same error with the latest SVN-Build
     
  10. Gintas

    Gintas Portal Member

    Joined:
    January 4, 2007
    Messages:
    17
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    MediaPortal Version: 0.2.2.0 + svn 01-09-2007--01-01-Rev12580
    MediaPortal Skin: BlueTwo wide
    Windows Version: WinXP MCE 2005
    1. TV Card: AverMedia Volar DVB-T USB
    1. TV Card Type: DVB-T

    Hello,

    Are you sure that this problem is fixed? Because I still have this problem. By the way I'm watching h264 compressed DVB-T channels.

    Regards,
    Gintas
     
  11. josu

    josu Portal Pro

    Joined:
    March 14, 2006
    Messages:
    192
    Likes Received:
    0
    Occupation:
    Dipl-Ing FH
    Location:
    Kassel, Germany
    Ratings:
    +0 / 0
    Home Country:
    Germany Germany
    Hello,
    isnt fixed, look here
     
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!