Timeshifting backwards only works after several tries (1 Viewer)

stoked

MP Donator
  • Premium Supporter
  • December 14, 2007
    297
    8
    Canada Canada
    TV-Server Version: 1.0RC2
    MediaPortal Version: 1.0RC2
    MediaPortal Skin: Bluetwo Wide and XFace
    Windows Version: XP SP3
    CPU Type: Intel 2.4Ghz Core 2 Quad
    HDD:
    Memory: 4GB DDR2-800
    Motherboard: Intel P5E-VM DO(TVserver), Giga-byte P35(TVclient1), Nvidia 8200(TVclient2)
    Video Card: Onboard(TVserver), 8800GT(TVclient1), Onboard 8200(TVclient2)
    Video Card Driver: 175.14
    Sound Card: onboard
    Sound Card AC3:
    Sound Card Driver:
    1. TV Card: Skystar2 DVB-S
    1. TV Card Type: DVB-S
    1. TV Card Driver: 4.4.3
    2. TV Card: Twinhan 102G
    2. TV Card Type: DVB-S
    2. TV Card Driver:
    3. TV Card:
    3. TV Card Type:
    3. TV Card Driver:
    4. TV Card:
    4. TV Card Type:
    4. TV Card Driver:
    MPEG2 Video Codec: Nvidia
    MPEG2 Audio Codec: Nvidia
    h.264 Video Codec: Corecodec
    HTPC Case: Origenae X11
    Cooling:
    Power Supply: Corsair 550W
    Remote: Harmony 880, MCE
    TV: Sony 50" SXRD A3000, Optoma H71 Projector
    TV - HTPC Connection: DVI, HDMI



    Upgraded to RC2 and still have this problem. No devs have commented on this problem, but other users have the same problem. Original bug report: https://forum.team-mediaportal.com/...ckwards-only-works-after-several-tries-42049/ I will try and post logs from RC2 when I get a chance.

    Hi,

    I've had this problem for awhile now. I'm using latest SVN, multiseat TVServer setup. When I try to seek -15sec, the info bar shows -15sec but the stream pauses then continues on live TV. If I do press the left arrow button a few times, it usually does the same thing but eventually will timeshift back. I've attached the logs, I turned the TV stream on, waited for around 45-60sec, and then attempted to seek -15sec. I had to do it 4-5 times before it worked. The last timeshift in the logs is the one that worked.

    I changed the timeshift directory to C:\MPRecording as can be seen in the logs. I also tried increasing the timeshift max size to 512MB per a recommendation from one of the devs but it didn't help.
    NOTE: I don't have permission to move a post, so I created a new one in the RC2 forum. Forum admin, please move original thread to this forum if you prefer. Thanks.

    UPDATE: Changed to channel, deleted all logs, waited 1min, and tried to skip back -15sec. The last one is the one that worked... it also seemed to cumulatively skip however seconds back of the total number of tries I did -15sec. Logs attached.
     

    SciDoctor

    Retired Team Member
  • Premium Supporter
  • February 2, 2005
    1,465
    139
    England
    Country flag
    I have tried to reproduce this bug with VISTA32sp1 and XPsp3 but can't as of yet.

    Your previous thread unfortunately had only two members who replied and neither posts had logs or their system specs which didn't help and they didn't post back with further updates or concerns.

    We take all bug reports seriously and try to confirm the bug and post help.

    The closest to your problem I have seen is when the time bar and hence time known by the client isn't updated correctly making time jumps impossible but this is repeatable by many and in mantis for client playback of recordings in progress only.

    The only sugestion is if this problem is so bad for you that a clean fresh instal of RC2 and svn is done, a bind but may help.
     

    stoked

    MP Donator
  • Premium Supporter
  • December 14, 2007
    297
    8
    Canada Canada
    Thanks for updating me, SciDoctor. I didn't know if anyone looked into it at all. I have done a fresh install of RC2 (installer removes old installation AFAIK). I'll double check the time settings but I'm pretty sure they are synched to a ntp source. Server/Client both have same time and are setup for default ntp interval at time.microsoft.com.
     

    stoked

    MP Donator
  • Premium Supporter
  • December 14, 2007
    297
    8
    Canada Canada
    Please post logs when you have the chance.
     

    Paranoid Delusion

    Moderation Manager
  • Premium Supporter
  • June 13, 2005
    13,062
    2,978
    Cheshire
    United Kingdom United Kingdom
    The problem comes in here, when it cannot be reproduced, my timeshifting in live TV works fine, so we need to find why its not working for all, this is on Vista\XP, so the OS is not relevant.

    One of the things i have found is, do not use the same folder for timeshifting as recording, maybe this does make a difference, just not sure, as no one has confirmed\denied.
     

    stoked

    MP Donator
  • Premium Supporter
  • December 14, 2007
    297
    8
    Canada Canada
    One of the things i have found is, do not use the same folder for timeshifting as recording, maybe this does make a difference, just not sure, as no one has confirmed\denied.
    I have seperate folders for recording and timeshifting and it hasn't helped in my case. I will post my logs when I have a chance tonight when I get home. If there's a way to get more debug info than the logs provide, please let me know.

    Thanks.
     

    Marcusb

    Retired Team Member
  • Premium Supporter
  • February 16, 2005
    1,995
    29
    Melbourne
    If this is what I think it's referring to, it's important to note that this only happens on remote clients and not on the server.
    can you confirm if this is the case?

    I find that on clients, timeshifting very small amounts on live TV usually just ends up at the live point again. Small amounts is usually < 1 minute.
     

    stoked

    MP Donator
  • Premium Supporter
  • December 14, 2007
    297
    8
    Canada Canada
    My server is headless so I can't confirm if it works on a local client. Maybe someone else with the same problem can try. Tried timeshifting back -3min and it seems to work if the timeshift steps show. Sometimes if I press the left arrow it just shows End.
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    G [solved] timeshift error Newcomers Forum 2
    k12158 [solved] Keine Zugriff auf NAS Ordner mit Recordings und TimeShift Allgemeines Support- und Diskussionsforum 6
    P Timeshifting in XMLTV General 2
    joecool70 Fehlermeldung Error invoking action "Start Timeshift" Allgemeines Support- und Diskussionsforum 1
    cladinshadows85 timeshift error <solved> General 2
    S EPG timeshift advice needed please Electronic Program Guide 3
    R Mp2.2 verschiedene (neue) probleme, server nicht gefunden, client stürzt bei tv ab, timeshift... Allgemeines Support- und Diskussionsforum 1
    O Kodi Client tries to access wrong timeshift file Installation, configuration support 0
    M Timeshift vergrößern (mehr als 1024 MB) TV / Streaming 6
    C Hauppauge HVR-1265 -- does it work with MP1? MediaPortal 1 Talk 0
    Rob Hexenmeister ITV Player still not working for me OnlineVideos 2
    V Do you have to have a smart tv for it to work? Newcomers Forum 4
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    D Does Schedules Direct work with mp 1.24? General Support 3
    J [solved] Blu-ray disc playback does not work. Bugreports 13
    P MP2: US user, OTA - can NOT get SchedulesDirect plugin to work on MP1 or MP2 --> how do I get OTA schedule? General 5
    ratata [solved] Can't get two virtual IPTV cards to work side by side... General Support 6
    S TV-Server MP1 - Automatic search doesn't work Installation, configuration support 2
    T [solved] Green Button start MP not working....but box ticked in config. General Support 1
    mickb [solved] Mediaportal Stops working General Support 5
    C Importer works super slow My TVSeries 5
    D [solved] Movie artwork download stopped working Submit: Bug Reports 9
    A 1.24.0 CD art grabber not working in Shares view 1.24 Pre Release 17
    RoChess Random GPU crash leads to MePo restart, but works fine afterwards MediaPortal 1 14
    Dark Eyes Updated to Windows 10, now TVServer won't work Installation, configuration support 1
    Similar threads

























    Top Bottom