tsreader filter problem (black screen for .ts) (1 Viewer)


New Member
January 12, 2009
Home Country
TV-Server Version: 1.0
MediaPortal Version:
MediaPortal Skin: Blue3
Windows Version: Vista x64
CPU Type: Intel c2d E6750
HDD: 320gb WD
Memory: 4gb (4x1gb adata)
Video Card: ATI HD4870
Video Card Driver: 8.11
Sound Card: -
Sound Card AC3: -
Sound Card Driver: -
1. TV Card: Hauppauge HVR-1110 (triangle version)
1. TV Card Type: DVB-T
1. TV Card Driver: 1_303_5_25085_WHQL
MPEG2 Video Codec: ffdshow revision 2457
MPEG2 Audio Codec: ffdshow revision 2457
h.264 Video Codec: DivX 7
Satelite/CableTV Provider: Levira
HTPC Case: No
Cooling: Air
Power Supply: 750W
Remote: Hauppauge
TV: Samsung
TV - HTPC Connection: VGA

Im trying to use my hauppauge hvr-1110 tv card to see mpeg4 channels but the picture is always black when i try to view live tv, but the audio is ok.
I asked in IRC and tried recording it manually with tv server and playing the recording with vlc - and it worked! So after that i was advised to rename myrecording.ts to .mkv and try playing it with "MyVideo" under MP - it worked great.
So, it turns out theres some kind of a problem with tsreader filter and I was told to make a bugreport here. I've uploaded my .ts sample for you to test it. I hope it gets fixed soon =)
my recording (20mb) in rapidshare
my recording (20mb) in speedyshare


Retired Team Member
  • Premium Supporter
  • December 24, 2007
    Home Country
    France France
    Works like a charm with Cyberlink 8 codec and XP. ( I'll try today with Vista64 ).

    I'd also these kind of problem with ATI drivers. I've solved it removing the automatic CCC launch at power-up.
    ( Note : when CCC is not running you got really less chance to have PC crash !;))

    btw, attach the tsReader.log file.



    Retired Team Member
  • Premium Supporter
  • January 7, 2005
    I have seen exactly the same behavior (sorry, I'm not currently able to test the .ts file provided...)

    With H264 stream Arcsoft and Cyberlink codecs are able to connect TsReader's video output pin, but ffdshow and MPC codecs fail. This is an error on TsReader (unfortunately I still haven't figured out how to fix it).

    Users who are viewing this thread

    Top Bottom