TV card crash and some other issues - preliminary thread (1 Viewer)

Cordraconis

Portal Pro
July 26, 2016
82
2
Home Country
Belgium Belgium
BIOS settings for PCIe power savings were disabled, so no change there.

Manually added a (undetected in scan) channel from the upper frequencies as in the Wiki --> Success!
Merged analog channel with the same DVB-C (EPG only) channel and cheched the guide --> Success!

Opened a detected analog channel (clicked Edit, like in this picture http://wiki.team-mediaportal.com/@api/deki/files/2644/=Combined_Channels.png ) to compare to what I did. To my surprise I saw it was a Combined channel! There were 3 frequencies there (channel 16, 17 and 18.) Haven't checked other analog detected channels.
Now this raises the question of the chicken and the egg: did the crash cause the triple detection/combination of this channel, or is something wrong in the scanning parameters (for Belgium?) causing the tuner to jump around while finding a channel on multiple freq?
I can imagine when selecting this channel, the driver ASAP tries all 3 freq and then occasionaly crashes from the rapid tuning. (=still my theory.)

So now next on my list - when I get back at home - is deleting all scanned analog channels, then manually adding+mapping+EPGcombine them from the localized list at www.zenders.be
I think when every channel is only once in the database, this will again increase stability.
(Edit: try to type "9000" as area code in the website and click "zoek". You will see a list of the available frequencies in Ghent. Notice the big gap between 280 and 460MHz, I cannot find more info, but I think that is where the DVB-C transport streams are located.)



The older driver still hasn't been tried yet. No reason to for the moment.
 

mm1352000

Development Group
  • Team MediaPortal
  • September 1, 2008
    21,577
    8,223
    Home Country
    New Zealand New Zealand
    @Cordraconis
    The crash conditions are very simple: analog tuner locked on signal => analog tuner not locked on signal ==> crash.
    This happens most often when scanning, because not all frequencies/channels that are scanned are actually used.

    Now this raises the question of the chicken and the egg: did the crash cause the triple detection/combination of this channel...
    No.

    ...or is something wrong in the scanning parameters (for Belgium?) causing the tuner to jump around while finding a channel on multiple freq?
    No.
     

    Cordraconis

    Portal Pro
    July 26, 2016
    82
    2
    Home Country
    Belgium Belgium
    So I double checked and indeed some channels are double or triple combined:
    Some examples:
    - "unknown channels" 21, 22 and 23, are all three Discovery Channel in the preview pane.
    - History Channel is a combined channel: 2 different ID's but both the same frequency.
    - The same for Disney Channel, but the 3 ID's have *different* frequencies.

    So I decided to add everything manually and only once.

    It took several days, but here is what I did since my last post:
    - removed all analog channels
    - scanned for radio channels (crash - first time this happened)
    - after reboot scanned again for radio channels. no problem this time, but some freq were 0,3 MHz off)
    - added+mapped all TV channels manually from www.zenders.be
    - combined analog and DVB-C channels (EPG only), where appropriate
    - did the same with radio channels and ended up adding some of them manually
    - stress-test with "sync" enabled --> crash

    right now it should be recording some analog programs as a test. I'l get back on that later. I feel it might be stable enough for that, but still it seems these things shouldn't happen.

    Seems one of these days I'll try the older driver and after that fails, make this a bug report.
     

    Cordraconis

    Portal Pro
    July 26, 2016
    82
    2
    Home Country
    Belgium Belgium
    Sorry for the long wait, with a baby in the house one is happy to get some sleep at all or to form a coherent tought for more than 15minutes. :)



    recording from 2 tuners at once is stable so far. With zapping I have BSOD after about 10-15 channel changes. Obviously I havent recorded that much. Channel change is slow at 5-6 seconds. WinTV does it in 3, no big deal.

    I did this:
    - setup a RAMdisk of 5GB with ImDisk and moved timeshifting to there. It works.
    - removed drivers with haupauge's tool HCWclear and reboot. Then try to install the older stable drivers. "No compatible hardware found". It was worth the try mm1352000. ;)
    - setup file folders for films, series etc...
    - made log file

    BEFORE I tried this, I got an error message when opening the TV configuration. See attached screenshot. Looks like it doesn't find any TV card? The driver reinstall didn't fix anything, and I cant get into the TV setup program. WinTV does work, so this is a MP cough-up. Now it is reduced to a media player.

    Regardless, the BSOD is a ligit bug, and now I have reached the end of what I can try out myself to find a workaround.
     

    Attachments

    • error msg.zip
      15.3 KB

    Users who are viewing this thread

    Similar threads

    Then, "Mixer" line is not here when "skin sounds" setting is disabled ? Right ? Then, we could imagine that "presumably MP generating the button sound' would be "for sure". Maybe is there really a bug in your audio driver ? Generating an "Enter" action when, not needed ? No clue other than trying differents audio drivers.... Also...
    Then, "Mixer" line is not here when "skin sounds" setting is disabled ? Right ? Then, we could imagine that "presumably MP...
    I recollect someone else reporting this problem, but I cannot now find the relevant post. In this thread I want describe the...
    Replies
    8
    Views
    232
    Well, that was easy, thanks a lot :) (unfortunately, this did not solve the initial problem, for some reason MediaPortal cannot tune into a few channels which work using a different live-TV program, but I'll try to elaborate a bit further and then post in a different thread)
    Well, that was easy, thanks a lot :) (unfortunately, this did not solve the initial problem, for some reason MediaPortal cannot...
    Hi, since the channel scan cannot find a few channels (which can be found and tuned in using the software "WinTV", so the TV card...
    Replies
    2
    Views
    263
    To keep from uninstalling the WinTV 10 Tuner, I'll just use MP1's (manual control) & stop the TV server. This way both programs can be used. So far no-problems with stop & start MP1's TV server, when trying to use WinTV 10 tv screen.
    To keep from uninstalling the WinTV 10 Tuner, I'll just use MP1's (manual control) & stop the TV server. This way both programs can...
    After MP1 installment, the next step was to challenge behavior of the software with a "duel" tv tuner with screen watch & record...
    Replies
    2
    Views
    286
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this year, in march 2020) the Telenet provider will stop broadcasting Analog TV and Radio signals on their cable, and make the switch to Digital (DVB-C). The radio signals will disappear completely, so you'll...
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this...
    OK, this is specifically for people in Belgium (Vlaanderen) who are using Telenet Cable with MediaPortal 2. Next year (Edit: this...
    Replies
    0
    Views
    957
    Hi, must be really a while, cuz I can not remember any post from you ;) But might be also that I joined the team too late. Yes, there will be many things. Main reason is simply, that MP2 is not developed based on MP1. I for example never used MP1. I tried it lately to test voice control and was shocked about many inconsistancies in...
    Hi, must be really a while, cuz I can not remember any post from you ;) But might be also that I joined the team too late. Yes...
    It´s been a while... :) Well, simply the reason is cause MP1 was working so well... :) Now I decided to upgrade my old servers and...
    Replies
    1
    Views
    244
    Top Bottom