TV Play from beginning doesn't start while still recording (1 Viewer)

jverdeyen

Portal Member
January 5, 2008
21
0
TV-Server Version: RC1
MediaPortal Version: RC1
MediaPortal Skin: Indigo
Windows Version: Vista Ultimate SP1
CPU Type: Intel Core 2 Duo E6850
HDD: WD 250GB
Memory: 2GB DDR2 1033
Motherboard: ASUS PE5-VM HDMI
Video Card:
Video Card Driver:
Sound Card:
Sound Card AC3: optical out
Sound Card Driver:
1. TV Card: Hauppauge PVR500
1. TV Card Type: dual tuner analog
1. TV Card Driver:
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec: Nvidia
MPEG2 Audio Codec: Nvidia decoder
h.264 Video Codec: coreAVC
Satelite/CableTV Provider:
HTPC Case: Antec Fusion V2 Silver
Cooling: Syncth Ninja Mini
Power Supply:
Remote: Logitech Harmony 525
TV: Philips 37" LCD
TV - HTPC Connection: HDMI


Error description:
1. plan a new recording
2. recording starts
3. look at anything other channel, video, serie ...
4. try to look the recording channel, (while still recording the ending of the program)
5. start recording from beginning
6. black screen ....


Log file:

It seems like the pins can't get connected to the stream :
Code:
2008-05-16 11:07:41.767919 [Info.][MPMain]: Loading external players plugins

2008-05-16 11:07:41.772919 [Info.][MPMain]:   found plugin:MediaPortal.ITunesPlayer.ITunesPlugin in C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\ExternalPlayers\ExternalPlayers.dll

2008-05-16 11:07:41.773919 [Info.][MPMain]:   player:iTunes.  author: Frodo

2008-05-16 11:07:41.773919 [Info.][MPMain]:   found plugin:MediaPortal.FoobarPlugin.FoobarPlugin in C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\ExternalPlayers\ExternalPlayers.dll

2008-05-16 11:07:41.773919 [Info.][MPMain]:   player:Foobar2000.  author: int_20h/rtv

2008-05-16 11:07:41.773919 [Info.][MPMain]:   found plugin:MediaPortal.WinampPlayer.WinampPlugin in C:\Program Files (x86)\Team MediaPortal\MediaPortal\Plugins\ExternalPlayers\ExternalPlayers.dll

2008-05-16 11:07:41.773919 [Info.][MPMain]:   player:Winamp.  author: int_20h

2008-05-16 11:07:41.775919 [Info.][MPMain]: VideoPlayer:play E:\\Roary de racewagen - MTV - 2008-05-16_2.mpg

2008-05-16 11:07:41.809919 [Info.][MPMain]: VideoPlayerVMR9: Enabling DX9 exclusive mode

2008-05-16 11:07:41.809919 [Info.][MPMain]: Main: Received DX exclusive mode switch message. Fullscreen && maximized == True

2008-05-16 11:07:41.809919 [Info.][MPMain]:   fonts.SetDevice()

2008-05-16 11:07:41.814919 [Info.][MPMain]: added filter:ffdshow Video Decoder to graph

2008-05-16 11:07:41.816919 [Info.][MPMain]: added filter:ffdshow Audio Decoder to graph

2008-05-16 11:07:41.816919 [Info.][MPMain]: add filter:DirectSound: Digital Output Device (SPDIF) (2- High Definition Audio Device) to graph clock:False

2008-05-16 11:07:41.816919 [Info.][MPMain]: DirectShowUtils: found renderer - DirectSound: Digital Output Device (SPDIF) (2- High Definition Audio Device)

2008-05-16 11:07:41.820919 [Info.][MPMain]: DirectShowUtils: Passed removing audio renderer

2008-05-16 11:07:41.820919 [Info.][MPMain]: DirectShowUtils: Passed finding Audio Renderer

2008-05-16 11:07:41.822919 [Info.][MPMain]: added filter:DirectVobSub to graph

2008-05-16 11:07:41.822919 [Info.][MPMain]: VMR9: added EVR Renderer to graph

2008-05-16 11:07:41.848919 [Info.][MPMain]: VideoPlayerVMR9: add normal vob sub filter

2008-05-16 11:07:41.848919 [Info.][MPMain]: VideoPlayerVMR9: Setting DirectVobsub parameters

2008-05-16 11:07:41.849919 [Warn.][MPMain]: VMR9: Pin: 0 not connected: 80040209

2008-05-16 11:07:41.849919 [Warn.][MPMain]: VMR9: Pin: 1 not connected: 80040209

2008-05-16 11:07:41.849919 [Warn.][MPMain]: VMR9: Pin: 2 not connected: 80040209

2008-05-16 11:07:41.849919 [Warn.][MPMain]: VMR9: Pin: 0 not connected: 80040209

2008-05-16 11:07:41.849919 [Warn.][MPMain]: VMR9: Pin: 1 not connected: 80040209

2008-05-16 11:07:41.850919 [Warn.][MPMain]: VMR9: Pin: 2 not connected: 80040209
 

Noelix

Portal Pro
February 18, 2006
393
1
Salt Lake City, UT
United States of America United States of America
I can confirm this issue. Having the same problem.

Here's how to reproduce:
1. Wait for a scheduled recording to start recording.
2. Go to recorded tv shows and try to play the television program that is being actively recorded.
3. You'll be asked if you want to start from the beginning of the program or from the live point. Choose from the beginning.
4. The file will not play now. Nothing appears to happen and you are back to where you were at step 2.
 

Atreidae

New Member
March 1, 2008
2
0
I can conform i experience this issue too.. trying to play recording from the beginning just flickers the screen, trying to watch live throws no cards avail error...
will post details hen son not screaming
 

johnzered

Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    Hi,

    I can't confirm this. When I select the show from the recorded tv shows list It just starts from the beginning with no questions asked which I think is the right thing. If I from the tvguide select the channel that is being recorded I get the option to start from the beginning of the program or from the live point, both options works as expected.

    What version of mp are you using? I have RC1 + SVN-Snapshot:-06-13-2008 23-32h - Revision:19376 (released yesterday).


    //johnzered
     

    ronilse

    Retired Team Member
  • Premium Supporter
  • July 19, 2005
    4,422
    282
    Moss
    Norway Norway
    Country flag
    Hi,
    I'm not able to confirm this either.
    So what did i test (both single seat & multi seat):
    1. Scheduled a recording
    2. Wait for rec to start
    3. After 10 mins ->
    4. Into scheduled screen & selected, view from start (rec started from start) -> watched some time & stopped it.
    5. Into Recorded TV -> The one recording hit "ok"(which is play), rec started from start -> watched some time & stopped it again.

    One quest to the ones that have problems, do you use same codecs for TV & Movies(could be something with codecs selection, but thats a known bug)?

    Regards
    Roy
     

    SciDoctor

    Retired Team Member
  • Premium Supporter
  • February 2, 2005
    1,465
    139
    England
    Country flag
    Works fine here.

    Scheduled recording active.

    From 'recorded tv' the recording starts fine from the beggining.

    From 'scheduled' where the options are presented :

    ..From the begging plays the recording fine from the beggining.
    ..From live point starts a new buffer stream and plays live. (the recording stream isn't accesed)

    From EPG all actions as from 'scheduled' worked fine .

    Please post your full clean logs for the actions that are causing problems so we can see what is actualy happening.
     

    Noelix

    Portal Pro
    February 18, 2006
    393
    1
    Salt Lake City, UT
    United States of America United States of America
    I've reverted to a more stable build for the time being but I'll be certain to check for it when my curiosity gets the better of me again...
     

    johnzered

    Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    Hi with the latest svn (SVN-Snapshot:-06-27-2008 19-25h - Revision:19510) I have some troubles which somewhat related to this. From 'recorded tv' I don't get the question if I want to play live tv or start from the beginning anymore. Instead it just starts from the beginning, if I then stop playing and try to play again I get the question if I wan't to start from were i was or not. So in recorded tv it somehow doesn't recognize that it's actually recording that show for the moment. If I try the same from TV-Guide everything is normal.

    //johnzered
     

    gibman

    Retired Team Member
  • Premium Supporter
  • October 4, 2006
    2,998
    1,372
    Aarhus
    Denmark Denmark
    Country flag
    Its in next SVN.

    check;
    0001430: Rec. TV - playing back a live recording does not result in a prompt. - MediaPortal Bugtracker
    0001431: Tuning a currently rec. channel results in start of timeshifting buffer. - MediaPortal Bugtracker

    /gibman

    Hi with the latest svn (SVN-Snapshot:-06-27-2008 19-25h - Revision:19510) I have some troubles which somewhat related to this. From 'recorded tv' I don't get the question if I want to play live tv or start from the beginning anymore. Instead it just starts from the beginning, if I then stop playing and try to play again I get the question if I wan't to start from were i was or not. So in recorded tv it somehow doesn't recognize that it's actually recording that show for the moment. If I try the same from TV-Guide everything is normal.

    //johnzered
     

    johnzered

    Retired Team Member
  • Premium Supporter
  • April 20, 2008
    358
    80
    Finland Finland
    Country flag
    Thanks!

    It got better now but once you have chosen start from beginning and then stop you don't get the options anymore, this is probably not happening really often in a real life situation but still it's a bit inconsistent. I don't know if this is possible but a very nice solution would be that if the show is recording and you have already watched a bit of the show then you would be presented with 3 alternatives:
    -start from the beginning
    -start from where you ended
    -start from live point

    //johnzered
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    OP Similar threads Forum Replies Date
    joecrow [solved] DVD won't play properly. General Support 3
    M.Hulot MP plays in Internal Blu-ray-Player-mode always first audio stream not the one I chosen in settings General Support 1
    BrownGhost Mepo/MediaInfo takes 59 secunds to open library and start play :o( General Support 26
    I 1.25.0 Videos in HEVC UHD 2160p don't play good watch/edit Videos 8
    CanadianEh MP TV server rebuild with Colossus 2 - Kodi clients receive PMT error when playing videos recoreded by Colossus 2 TV-Server 1
    M [solved] WTV Files does not play on client, MPEG files works well General 1
    A [solved] How to Play All Videos in a List watch/edit Videos 3
    horned_reaper [solved] When playing music Fanart does not shuffle Fanart Handler 20
    horned_reaper [solved] No Fanart when playing Fanart Handler 115
    horned_reaper [solved] When playing music Fanart does not appear immediately after downloading Fanart Handler 272
    B MP 2.2.3 Error playing videos from NAS Submit: Bug Reports 2
    N Play a TV recording needs a double selection - twice ok on remote Television (MyTV frontend and TV-Server) 2
    M MP 2.2.3 Unable to play .ts recordings and MediaPortal stops working for TV viewing General 31
    Z Error when attempting to play Blu Ray General 1
    Rob Hexenmeister Playing with hyperlinkParameter and List Control indexes General Support 2
    C Problem playing videos created on IPhone X and Samsung S9 General Support 2
    2BitSculptor MP 1.23.. music stops playing General Support 6
    C Attempt to play DVD locks up MediaPortal watch/edit Videos 0
    H Unable to play stream - again... Television (MyTV frontend and TV-Server) 2
    B Suddenly MP is unable to play anything Watch / Listen Media 6
    Edwardfc [solved] Mp 2.2.1 Configuration Issues - Goes to Sleep while playing Music General 6
    M After a while Live TV or Recorded TV doesn't play first time General Support 9
    L [solved] MP2 doesnt play anything - player missing? General 1
    badboyxx MP 1.22 final is crashing when jumping forward while playing DVD-Iso watch/edit Videos 26
    S [solved] Live TV playing stopped General 13
    Similar threads

























    Top Bottom