TV server lost and MP crashes

Discussion in 'General Support' started by kimnach, February 8, 2012.

  1. kimnach

    kimnach Portal Member

    Joined:
    March 18, 2008
    Messages:
    46
    Likes Received:
    1
    Gender:
    Male
    Occupation:
    Electrical Engineer
    Location:
    Hinckley, OH
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    My system specs are listed to the left.

    Although I run a single seat setup and have no clients, my system seems to lose the connection to the TV Server often. It's always happened, but more so over the past few months (since 1.1.x). A clean install/update to Win7 in November 2011 did not solve my problems. I have a collection of more than 50 crash reports since November. Most often they occur when the system is sitting idle. I do not use hibernate or standby at all.



    I'll turn on my TV after days of not using it only to see MP sitting with a "Connection to TV Server lost", or "MP has stopped working", or I may exit MP when it seems to be working and find a number of crash reports on my desktop. I've missed many TV recordings but, luckily, it's not earth shattering to have that happen.

    Tonight, it was both a "TV server" and "Stopped Working" error and then it crashed again after a log was created and while MP was restarting. Attached are two sets of logs, the other 50+ are getting deleted.

    TV server logs have numerous " TvLibrary.Implementations.TvCardBase.get_IsTunerLocked()" entries. Why and is that the cause? Also, I don't see in the MP logs why it "stops working." (BTW, I do not think that the loopback solution mentioned in a much older thread that I saw is applicable.)

    Thanks and here's to stability.....
     
  2. Google AdSense Guest Advertisement



    to hide all adverts.
  3. grandalf

    grandalf Portal Pro

    Joined:
    January 26, 2007
    Messages:
    83
    Likes Received:
    0
    Ratings:
    +0 / 0
    Home Country:
    United Kingdom United Kingdom
    I have similar problems to you, mepo loses connection to tv server, usually after a freeze requiring a reset to restart. The only way to get it back seemed to be a clean re-install including the database server. After getting very tired of having to do this every other day I resorted to deleting everything then re-install mepo without tv services and set it up. Then I installed fortherecord with the argus tuner and mepo plugin. Ftr is not capable of extracting EPG from sat data stream so has to be used with xmltv guide data. Rather than losing mepo all together I was reluctant to lose the program mainly because of the online video plugin that seems to have no real equivalent in any other PVR software. Anyway so far it seems like a good combination and locking up is a lot less frequent. Hope this helps.
     
  4. kimnach

    kimnach Portal Member

    Joined:
    March 18, 2008
    Messages:
    46
    Likes Received:
    1
    Gender:
    Male
    Occupation:
    Electrical Engineer
    Location:
    Hinckley, OH
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    I recently upgraded to an SSD system drive, and did a fresh install of win7pro and MP 1.2.2. Still got lost connection to TV Server errors. Knowing that only MP was installed and the errors occurring, a couple of weeks later I installed all of my favorite plugins and skins. Cannot blame those.
     
  5. robbo100
    • Premium Supporter

    robbo100 Retired Team Member

    Joined:
    May 5, 2009
    Messages:
    1,291
    Likes Received:
    285
    Gender:
    Male
    Occupation:
    Herding Cats
    Location:
    UK
    Ratings:
    +322 / 1
    Home Country:
    United Kingdom United Kingdom
    Show System Specs
  6. kimnach

    kimnach Portal Member

    Joined:
    March 18, 2008
    Messages:
    46
    Likes Received:
    1
    Gender:
    Male
    Occupation:
    Electrical Engineer
    Location:
    Hinckley, OH
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    thanks for the suggestion. unfortunately tv service continues to be lost occassionaly.
     
  7. ronilse
    • Premium Supporter

    ronilse Retired Team Member

    Joined:
    July 19, 2005
    Messages:
    4,422
    Likes Received:
    280
    Gender:
    Male
    Occupation:
    MediaPortal tester
    Location:
    Moss
    Ratings:
    +280 / 0
    Home Country:
    Norway Norway
    Show System Specs
    Hi,
    Have you tried to disable ComSkipLauncher or set it to launch at end of recording?

    Regards
    Roy
     
  8. kimnach

    kimnach Portal Member

    Joined:
    March 18, 2008
    Messages:
    46
    Likes Received:
    1
    Gender:
    Male
    Occupation:
    Electrical Engineer
    Location:
    Hinckley, OH
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    tonight i tried disabling comskiplauncher, per your suggestion. five minutes before the recording was to stop, the tvserver crashed.

    thanks.
     
  9. ronilse
    • Premium Supporter

    ronilse Retired Team Member

    Joined:
    July 19, 2005
    Messages:
    4,422
    Likes Received:
    280
    Gender:
    Male
    Occupation:
    MediaPortal tester
    Location:
    Moss
    Ratings:
    +280 / 0
    Home Country:
    Norway Norway
    Show System Specs
    Hi,
    ok, can you attach those logs to this post, need to check what happen around the crash?
    Another thing, do you run anti virus, if you do try disable it or disable scan for recording folder(have seen some problems with that but it's a long time since :) )

    Regards
    Roy
     
  10. mbuzina
    • Premium Supporter

    mbuzina Retired Team Member

    Joined:
    April 11, 2005
    Messages:
    2,839
    Likes Received:
    627
    Location:
    Germany
    Ratings:
    +723 / 4
    Home Country:
    Germany Germany
    Show System Specs
    Also important: Check if Server has a fixed IP and does not loose NW Connection in the mean time. If it is not constantly networked, install MS Loopback Adapter
     
  11. kimnach

    kimnach Portal Member

    Joined:
    March 18, 2008
    Messages:
    46
    Likes Received:
    1
    Gender:
    Male
    Occupation:
    Electrical Engineer
    Location:
    Hinckley, OH
    Ratings:
    +1 / 0
    Home Country:
    United States of America United States of America
    Show System Specs
    just came downstairs and noticed on the htpc touchscreen that the tv sever had crashed. just 20-minutes earlier it was recording (little red "record" indicator). trying to run the tv server configuration indicates that it has stopped working.

    my machine is a Single Seat installation (se my first post at top of thread).

    attached is the tv.log from a few minutes ago. (comskiplauncher was disabled, as was crc check, and my epg grabbing is scheduled at roughly 2a.m. each morning.) I notice in the tv.log that the heartbeat timer sometimes times out.

    kids are home, gotta go.....

    UPDATE:
    came home from our two-week disney vacation and noticed the attached zipped log (may 31) on the desktop
     
    Last edited: June 14, 2012
Loading...

Users Viewing Thread (Users: 0, Guests: 0)

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice
  • About The Project

    The vision of the MediaPortal project is to create a free open source media centre application, which supports all advanced media centre functions, and is accessible to all Windows users.

    In reaching this goal we are working every day to make sure our software is one of the best.

             

  • Support MediaPortal!

    The team works very hard to make sure the community is running the best HTPC-software. We give away MediaPortal for free but hosting and software is not for us.

    Care to support our work with a few bucks? We'd really appreciate it!