TV Viewing / Management - Problems and Overall Usability (1 Viewer)

Bobnz

MP Donator
  • Premium Supporter
  • September 28, 2013
    16
    4
    Home Country
    New Zealand New Zealand
    Trying out MP 2.1 for TV use but encountering problems. I am now using network credentials username and passwords but this made no improvement. I am not using passwords in the windows/network environment.
    My set up:
    • Server: I have a PC (always on) dedicated as a server with MP 2.1 installed as server and client plus other programs. All content and TV recordings get stored on this server. C Drive is an SSD, 4x hard drives for storage. I have a 6Gb ramdisk set as per an example in the guide. Actual installed ram is 16GB. Intel i3-3225 CPU @ 3.30GHz. No screen attached, nor keyboard, nor mouse.
    • Main TV-PC: this is a Brix PC connected to a TV. Controlled by wireless ARC mouse. MP 2.1 client installed. 4GB Ram, Intel Celeron J1900 CPU @ 1.99GHz. Connected to Server via Cat 6 Lan. Used for nearly all TV viewing by family.
    • LocoBob: typical PC setup with MP 2.1 Client installed. 8GB Ram. Intel i3-4350 CPU @ 3.6GHz. Connection to server via WiFi. From this PC I can remote-connect to either Server or TV-PC for testing via Splashtop program.
    • Other PCs with MP 2.1 clients for occasional use or testing.
    NB: all of the above run Windows 10 with Windows Defender. Maximum of 2 clients in use simultaneously for viewing MP. Using skin WMC, as the default is not as mouse friendly. This setup previously ran MP 1.6 with no problems. All TV is recorded from satellite in SD, stored over 3x hard drives.​

    This test is to demonstrate the problems and was run from client LocoBob.
    I have recorded the time of my actions thus: [00:00:00] Things for follow up are in numbered brackets thus () ...

    [12:20:34] Media Portal client LocoBob is launched.

    Navigated to the recordings screen [12:21:41] I right click on any recording but there is no option to delete it in the popup menu (1). NB The server's client popup menu does have an option to delete.

    [12:23:40] I select a recording and play it. I click on the fast forward ">>" button - there is no indication of speed such as 2x; 4x; 8x; 16x etc (2)

    [12:24:30] I stop the playback and return to the Guide

    [12:26:25] I select a series type program called 'Horders', right click and chose extended scheduling; then record series; then every time on this channel - success.

    [12:27:30] I go to the schedules screen - yes it appears. I select Manage Series Schedules and then the program 'Horders'. I choose Delete Full Series Schedule - success! It has gone.

    I go to the guide and scroll the EPG forward but find that the episodes are still set to record with the series linked symbol (3)

    I note that the controls that allow you to jump to the next day in the EPG display a date and not the day of the week. (4)

    [12:30:10] I choose a currently airing program "Bachelor NZ" and select Record. I navigate to the recordings screen but it has not yet appeared (5) NB some recording do not appear until after the program has finished which may be an hour or so later. I can force them to appear by exiting MP then going back in.

    [12:31:45] I end the test.

    This test was from a fresh install of server and clients. I note that the client Service Monitor shows "Disconnected" even when connected (6) - Server show clients as connected. On my earlier install it was working as intended although I still had the same problems mentioned above.

    Comment on usability: The MP1 fast forward controls causes the picture to jump to frames which is okay. The MP2 fast forward is a 'live stream'. While fine on a small screen, it is not suited to a large screen - ours is a 55 inch TV panel. It result in a flashing pixelated picture detracting from the viewing experience. A TV program with multiple advert breaks it is just too hard on the eyes. Clicking on the timeline proved too 'hit and miss' for locating the end of commercial breaks. It is a pity that a more elegant method is not available such as a sliding timeline with preview window. Sadly, this is why we have decided not to stay with MP2 at this time.
    My comments are intended to be constructive and I attach logs from client and server. MP2 is a neat program and I will follow it's development with interest - hope to try it again at some future time.
    Bob
     

    HTPCSourcer

    Retired Team Member
  • Premium Supporter
  • May 16, 2008
    11,431
    2,334
    Home Country
    Germany Germany
    Country flag
    Hello Bob,

    Thanks for the feedback :). Iti is not easy to thoroughly answer such an email in a few minutes and I guess that's why it took us so long to reply.

    The MP2 fast forward is a 'live stream'. While fine on a small screen, it is not suited to a large screen - ours is a 55 inch TV panel. It result in a flashing pixelated picture detracting from the viewing experience.
    We don't recommend using fast forward. Its performance greatly depends on the hardware/codec combination as well as the connection speed. In your case Wifi is probably an additional factor that is impacting the experience. Instead you could skip steps a try: quickly pressing the right key on your remote will jump in steps of 15/30s/1min/3min/... etc. (individual steps can be adjusted in the settings menu).

    I am now using network credentials username and passwords but this made no improvement. I am not using passwords in the windows/network environment.
    It is important to understand that the MP2 serer is operating under a different user context than the logged on user. In other words, the client app is running under your personal user account, e.g. BobNZ, while the associated server process is using the system account. Access rights will depend on your individual network situation. Note that the fact that you are able to navigate to your shares with Windows Explorer doesn't mean that the MP2 Server is having sufficient access rights.

    I right click on any recording but there is no option to delete it in the popup menu (1). NB The server's client popup menu does have an option to delete.
    This is typical of insufficient rights

    I click on the fast forward ">>" button - there is no indication of speed such as 2x; 4x; 8x; 16x etc (2)
    I guess that this could be added. Can you please create a separate feature request just for this in the respective forum section?
    This was registered as MP2-663 Add Speed Indicator for FastForward/Rewind and has already been finished.(y) It will be part of the next release.
    I go to the guide and scroll the EPG forward but find that the episodes are still set to record with the series linked symbol (3)
    I tried this on my system and can confirm the behavior. The record settings in EPG don't disappear until you've restarted the MP2-Server service. Added as MP2-661 to Jira

    I note that the controls that allow you to jump to the next day in the EPG display a date and not the day of the week. (4)
    Correct. There are plans to allow choosing date/time format for this date display, similar to the setting area where you can use .Net format settings like "d" or "D".

    I navigate to the recordings screen but it has not yet appeared (5) NB some recording do not appear until after the program has finished which may be an hour or so later. I can force them to appear by exiting MP then going back in.
    I can't confirm this here. Recording a show leads to instantaneous display in the Recordings section. My hypothesis is that this is due to missing access rights by the client.
     
    Last edited:

    Users who are viewing this thread

    Similar threads

    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up a running mediaportal setup. Without the logs however, I don't have a clue on what exactly is wrong...
    Could be that a sudden powercut corrupts the database, or give all your pcs a new ipadres, or several more things that can break up...
    Hi there, I'm a happy long time user and am currently using MP 1.25. Up until now I had no issues with my setup. Yesterday...
    Replies
    1
    Views
    486
    I see only site printscreen. You need to run Mediaportal.exe
    I see only site printscreen. You need to run Mediaportal.exe
    After I managed to install basic components for the MP1, I had problems getting the main viewing screen to open, without going to...
    Replies
    6
    Views
    588
    Well it's been a couple of days and we've had no more unable to play errors .
    Well it's been a couple of days and we've had no more unable to play errors .
    I've just upgraded the motherboard, CPU, ram, boot drives and PSU in my TV Server (always on), and am now having intermittent...
    Replies
    8
    Views
    1K
    Ok, the importer also remembers the queue of items that are still needed to be processed in settings file. If there is something stuck, it will try again on next server start and probably stuck again. But removing the media source also removes the associated queue. The server's TV plugin automatically creates the media sources for...
    Ok, the importer also remembers the queue of items that are still needed to be processed in settings file. If there is something...
    Hi, I’ve been struggling with MP 2 now for several weeks. Initially all was fine. Then in the client, the listings of recorded TV...
    Replies
    8
    Views
    873
    P.S. - Strangely, the TV Server my single seat setup (1.27 on a modest machine running Windows 10 Pro x64) is working from my office machine MP client. Same exact network, firewall, Defender settings. It's a slightly older version of Win 10 though - I haven't updated to 20Hx on it yet. Maybe I shouldn't (or maybe I should image it...
    P.S. - Strangely, the TV Server my single seat setup (1.27 on a modest machine running Windows 10 Pro x64) is working from my...
    Let me start by asking if anyone has TV Server running PROPERLY on a Windows 10 machine, and if so are you using RTSP or UNC share...
    Replies
    9
    Views
    847
    Top Bottom