TVService not closing, timeshift freeze: Disable EPG. (1 Viewer)

Cybertex

Portal Pro
August 9, 2007
200
14
Milano
Italy Italy
TV-Server Version: TV Engine V3 Latest SVNs
MediaPortal Version: 0.2.3.0 Latest SVNs
MediaPortal Skin: Blue Two
Windows Version: XP Pro SP2
CPU Type: Intel P4 HT 3.0GHz
HDD:
Memory: 1GB DDR2
Motherboard: Asus P4P800-E
Motherboard Chipset:
Motherboard Bios:
Video Card: Asus V9570 (Nvidia GeForce FX 5700)
Video Card Driver: ForceWare 169 (169.21)
Sound Card:
Sound Card AC3:
Sound Card Driver:
1. TV Card: Hauppauge HVR-1300 MCE
1. TV Card Type: Hybrid (Analog+DVB-T)
1. TV Card Driver: Latest from Hauppauge
2. TV Card:
2. TV Card Type:
2. TV Card Driver:
3. TV Card:
3. TV Card Type:
3. TV Card Driver:
4. TV Card:
4. TV Card Type:
4. TV Card Driver:
MPEG2 Video Codec:
MPEG2 Audio Codec:
Satelite/CableTV Provider:
HTPC Case:
Cooling:
Power Supply:
Remote: MCE remote
TV: Samsung Syncmaster 203B
TV - HTPC Connection:

Hello,
(excuse me, I'd like to share my experience, but I've very few time in these days to post...)
Since some time, more or less 1 month, I'm experiencing some problem with TVService; now, after a lot of tests, I've found the solution. This was the situation:

TVServer starts and works normally in the first minutes. I can start (and watch) timeshift, can stop the service. After a while TVServer service doesn't stop anymore, requiring a kill from task manager, and Timeshift doesn't work anymore, either with TVClient or MPTVClient or VLC. It simply freeze, without errors or notification (if opened, SetupTV freezes too). I noticed that this problem was always related with tvguide disappearing (see https://forum.team-mediaportal.com/...s_dissappearing_replaced-t33182.html?t=33182).

In brief, I totally disabled all the EPG grab (idle and when timeshifting), and I deselect all the EPG grabs for channels in "TV Channels" -> "TV EPG grabber".

Now Tvservice works like a charm, it stops, it starts, it does timeshift.
Maybe this is related with gemx's EPG re-write...
 

splatterpop

MP Donator
  • Premium Supporter
  • December 17, 2007
    177
    54
    planet ASPARAGUS
    Germany Germany
    I just came across the same thing. DVB-S EPG grabbing definitely freezes the TV Server, and it gets worse the more LNBs you configure (this is of course only based on my experience with my Hauppauge WinTV Nova-S). The TV server would run stable for some time, an hour or so, and then go to freeze. I did not notive any log messages, and CPU use is at zero.

    When I swiched to a commercial EPG provider, the problem disappeared instantly. So I assume this is still an issue.
     

    dida128

    Portal Member
    February 11, 2008
    5
    0
    Croatia Croatia
    Cool solution, but what with XML EPG? My TVServica also hangs, and I need to kill it from taskmanager to shut down my machine. Does it mean that I cannot use EPG??
     

    splatterpop

    MP Donator
  • Premium Supporter
  • December 17, 2007
    177
    54
    planet ASPARAGUS
    Germany Germany
    I can only guess, but I assume this is a DVB EPG grabbing issue, so a third party EPG source would not be affected, as long as this data goes directly to the database.
     

    Cybertex

    Portal Pro
    August 9, 2007
    200
    14
    Milano
    Italy Italy
    I can only guess, but I assume this is a DVB EPG grabbing issue, so a third party EPG source would not be affected, as long as this data goes directly to the database.
    Yes, It's a DVB EPG issue, WebEPG works ok. For me the problem is still here, for sure with Idle EPG grabber; timeshift EPG seems to work ok (does EPG grab occur also during recording? I think yes it does).

    Unfortunately, I'm very busy in these months, so I'm not able to perform a deep problem determination.. I'm sorry :(
     

    sepp776

    MP Donator
  • Premium Supporter
  • January 28, 2008
    147
    6
    Cologne
    Germany Germany
    Hi All,

    I had this issue for a month or two now, too.
    With the last couple of svn builds, timeshift grabbing works fine again, but idle grabbing still makes Mediaportal and TV Service hang. Both can only be killed with task manager.

    Is it possible that this is related to the specific channels being grabbed? This might explain why timeshift EPG works fine (since i usually don't watch all of the channels checked for idle grabbing).

    Regards,
    Sepp.
     

    splatterpop

    MP Donator
  • Premium Supporter
  • December 17, 2007
    177
    54
    planet ASPARAGUS
    Germany Germany
    Afaik the problem is unsolved and the source in unknown.

    (Did you get the recent SVN builds of tvserver installed? I would have liked to check them out, but ran into serious problems with power scheduler components not being present and server crashes.)

    Anyway at least for germany I think clikfinder is a far better EPG solution than DVB EPG.

    + Way much better content, such as ratings, actors etc.
    + valid categories, not everything is "soap/melodram/folkloric" anymore (joking). I found the categories to be very misleading sometimes. If you try to watch selectively, you are having a hard time with DVB EPG.

    The price i think is very reasonable too.
     

    sepp776

    MP Donator
  • Premium Supporter
  • January 28, 2008
    147
    6
    Cologne
    Germany Germany
    is there anyone who would like to take a look at this? If so, I could try to find out which of the channels I have configured for grabbing are causing the problems and maybe provide a stream dump...
     

    splatterpop

    MP Donator
  • Premium Supporter
  • December 17, 2007
    177
    54
    planet ASPARAGUS
    Germany Germany
    I checked the bugtracker and found nothing, is this correct? Should this not be reported as a bug?
     

    Users Who Are Viewing This Thread (Users: 0, Guests: 1)

    Top Bottom